summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2020-01-07 06:24:22 +0100
committerHans de Graaff <graaff@gentoo.org>2020-01-07 07:06:04 +0100
commitc6d0df6f75d98e2c8906b41898e60048780e86e3 (patch)
tree0a70214640dd2cdc8a7982b517fb67fcde35c92b
parentdev-ruby/mini_magick: add 4.10.1 (diff)
downloadgentoo-c6d0df6f75d98e2c8906b41898e60048780e86e3.tar.gz
gentoo-c6d0df6f75d98e2c8906b41898e60048780e86e3.tar.bz2
gentoo-c6d0df6f75d98e2c8906b41898e60048780e86e3.zip
dev-ruby/mixlib-shellout: add 3.0.9
Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
-rw-r--r--dev-ruby/mixlib-shellout/Manifest1
-rw-r--r--dev-ruby/mixlib-shellout/mixlib-shellout-3.0.9.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-ruby/mixlib-shellout/Manifest b/dev-ruby/mixlib-shellout/Manifest
index d7ea49f8d4bc..2ccbe502e254 100644
--- a/dev-ruby/mixlib-shellout/Manifest
+++ b/dev-ruby/mixlib-shellout/Manifest
@@ -1,2 +1,3 @@
DIST mixlib-shellout-2.4.4.tar.gz 38305 BLAKE2B 19e4211dee056e03f007971d4d77685a2d2d6a111439903bd33e0ed8dee62090b54b6f15e0bc6db168591491c2462869645174a909609b7499bdce251a6ceeef SHA512 e42217a6ced0fb8335cb2df60947168c629d637d280b36fe3d77f47593dc73eda72578b0e9ddf48498e27460cb878764c5dff1b5648a0c7d244c16558d57eef4
DIST mixlib-shellout-3.0.4.tar.gz 42533 BLAKE2B 4d71cfb2d41120be04613749fd5c0e73d6939fe64410e46285a6f81ec61107b1e658ecc011c032621b433eb15e9ffd42b4f589419ffd8f68b7c5977691e011d1 SHA512 2ed866333874c8c40109de9bb4a1e5a3afea4f4c4cf537b11a1ccd670d374b9ce132717e87d43bb41065a9361e45de13bb1fa2db3e1f2d9f4af18253548f5811
+DIST mixlib-shellout-3.0.9.tar.gz 42476 BLAKE2B 4fab1d0f7d7ee5190f65d312304c7137d940b5cc19bb205d4de1d14eb5bc5829671560785b7f3179220246433b15b9022f8a1d16fb7491e180940c9dc6da5280 SHA512 7234c188e25cc6da3c4859eb12e4f86ce0d6538d17e4c90b1b5105fe677fcd13d884d7045be9767473c3ac63ffcfac7af25dc8efcec184928ba32852a5a760cc
diff --git a/dev-ruby/mixlib-shellout/mixlib-shellout-3.0.9.ebuild b/dev-ruby/mixlib-shellout/mixlib-shellout-3.0.9.ebuild
new file mode 100644
index 000000000000..ce5ed5b376c3
--- /dev/null
+++ b/dev-ruby/mixlib-shellout/mixlib-shellout-3.0.9.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRA_DOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="mixlib-shellout.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Run external commands on Unix or Windows"
+HOMEPAGE="https://github.com/opscode/mixlib-shellout"
+SRC_URI="https://github.com/opscode/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+each_ruby_prepare() {
+ # Make sure we actually use the right interpreter for testing
+ sed -i -e "/ruby_eval/ s:ruby :${RUBY} :" spec/mixlib/shellout_spec.rb || die
+
+ # Avoid spec that requires an interactive terminal
+ sed -i -e '/with subprocess writing lots of data to both stdout and stderr/,/^ end/ s:^:#:' spec/mixlib/shellout_spec.rb || die
+}