summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2021-04-22 09:39:52 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2021-04-22 09:41:13 -0700
commitc6ec5086fd71473ce5f71a0aac0d2761811a499a (patch)
tree14cf2b04ddb38a64d5a4b992973efae981fad57f
parentpackage.mask: unmask www-apps/liquid_feedback_frontend (diff)
downloadgentoo-c6ec5086fd71473ce5f71a0aac0d2761811a499a.tar.gz
gentoo-c6ec5086fd71473ce5f71a0aac0d2761811a499a.tar.bz2
gentoo-c6ec5086fd71473ce5f71a0aac0d2761811a499a.zip
app-emulation/docker: rebase patch, get rid of custom src_prepare
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
-rw-r--r--app-emulation/docker/docker-20.10.6-r1.ebuild11
-rw-r--r--app-emulation/docker/files/etcd-F_OFD_GETLK-fix.patch4
2 files changed, 5 insertions, 10 deletions
diff --git a/app-emulation/docker/docker-20.10.6-r1.ebuild b/app-emulation/docker/docker-20.10.6-r1.ebuild
index 798980694c7c..2b99383d6b7f 100644
--- a/app-emulation/docker/docker-20.10.6-r1.ebuild
+++ b/app-emulation/docker/docker-20.10.6-r1.ebuild
@@ -54,6 +54,9 @@ RESTRICT="installsources strip"
S="${WORKDIR}/${P}/src/${EGO_PN}"
+# https://bugs.gentoo.org/748984 https://github.com/etcd-io/etcd/pull/12552
+PATCHES=( "${FILESDIR}/etcd-F_OFD_GETLK-fix.patch" )
+
# see "contrib/check-config.sh" from upstream's sources
CONFIG_CHECK="
~NAMESPACES ~NET_NS ~PID_NS ~IPC_NS ~UTS_NS
@@ -158,14 +161,6 @@ pkg_setup() {
linux-info_pkg_setup
}
-src_prepare() {
- default
- # https://bugs.gentoo.org/748984 https://github.com/etcd-io/etcd/pull/12552
- pushd "${S}/vendor/github.com/coreos/etcd" >/dev/null || die
- eapply "${FILESDIR}/etcd-F_OFD_GETLK-fix.patch"
- popd >/dev/null || die
-}
-
src_compile() {
export DOCKER_GITCOMMIT="${GIT_COMMIT}"
export GOPATH="${WORKDIR}/${P}"
diff --git a/app-emulation/docker/files/etcd-F_OFD_GETLK-fix.patch b/app-emulation/docker/files/etcd-F_OFD_GETLK-fix.patch
index d912e59e985b..bd574e26f040 100644
--- a/app-emulation/docker/files/etcd-F_OFD_GETLK-fix.patch
+++ b/app-emulation/docker/files/etcd-F_OFD_GETLK-fix.patch
@@ -15,8 +15,8 @@ Fixes #31182
diff --git a/pkg/fileutil/lock_linux.go b/pkg/fileutil/lock_linux.go
index 939fea62381..004d35fa23b 100644
---- a/pkg/fileutil/lock_linux.go
-+++ b/pkg/fileutil/lock_linux.go
+--- a/vendor/github.com/coreos/etcd/pkg/fileutil/lock_linux.go
++++ b/vendor/github.com/coreos/etcd/pkg/fileutil/lock_linux.go
@@ -29,7 +29,7 @@ import (
//
// constants from /usr/include/bits/fcntl-linux.h