summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2019-09-18 21:05:52 -0700
committerZac Medico <zmedico@gentoo.org>2019-09-18 21:05:52 -0700
commitc6f2fb6ee370a263bda4d95ce7ecbd6659719d07 (patch)
tree0190c1b169e6d061a63d53887ca6ad4becb1bffd
parentapp-emulation/cri-o: LICENSE: account for vendored software (diff)
downloadgentoo-c6f2fb6ee370a263bda4d95ce7ecbd6659719d07.tar.gz
gentoo-c6f2fb6ee370a263bda4d95ce7ecbd6659719d07.tar.bz2
gentoo-c6f2fb6ee370a263bda4d95ce7ecbd6659719d07.zip
app-emulation/cri-o: Bump to version 1.15.2
Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Zac Medico <zmedico@gentoo.org>
-rw-r--r--app-emulation/cri-o/Manifest1
-rw-r--r--app-emulation/cri-o/cri-o-1.15.2.ebuild107
2 files changed, 108 insertions, 0 deletions
diff --git a/app-emulation/cri-o/Manifest b/app-emulation/cri-o/Manifest
index 5dd7da5d78d2..d271f088bf6c 100644
--- a/app-emulation/cri-o/Manifest
+++ b/app-emulation/cri-o/Manifest
@@ -1,3 +1,4 @@
DIST cri-o-1.10.6.tar.gz 5161858 BLAKE2B bbfaf60c92dee3a9f42e9d4fc9b5482057a7a0ff2de36d74d434e2e60b53f92f70980c83825c18089c4a48bfa01c164b77aa01506c68c763f00265796e07d367 SHA512 b6a412cf5859dab79095732c2528e2ba373b3c21740203441fd3646862e2458e78e71f1895a5def05207964ef96a354c04395356e426600994bb39d3adfd0894
DIST cri-o-1.13.9.tar.gz 6685519 BLAKE2B 5d9e68c7a0ae532e2406e5e47562693cddbc34a8b3ddcab0a7a34509dff8383d1fc255cba634efb186193e5784cc6a7638387ca29e68288af7621b8b25f1a71a SHA512 1541368955c62c697dbd6b850cdf6762a13a7a308f699e3a50dbfe29fbf991f4f47cfcce75bc41745e0c27acb29457ec86d3312ef13341a5d94526865e60eb3e
DIST cri-o-1.15.1.tar.gz 11811389 BLAKE2B 2f6e223e2d3964f480e9739ee4808101ae2ca8c0a16eb589d2e3501d370c60694843309b602a4a4b8e16ed97094f97c81ff4f23b542a9536b38f9fe9a97bcd97 SHA512 2b9122692d84e8a6832d7172782c41d354185809cd3fa999951485f8df8fd1750dd15b2005fbb3bc422f5199daeb32a768e824402c9e95f25593e250bd7ecc07
+DIST cri-o-1.15.2.tar.gz 11861335 BLAKE2B 159bdf322540c3d49f44b1fc1106d1717706f7817e4621743078dfbb5d9088318d7dda5da54ff94ed43ea58204413d496ffda424ea94ed6fd0c6e090bbba37f0 SHA512 d30a27d98537cd73bf341267922b94434958bf5e5d3a26de3af2b7899fd9d860be12a194531f81fb704abed79eac1c5139271fab1e52b994b939dafab00f1cfd
diff --git a/app-emulation/cri-o/cri-o-1.15.2.ebuild b/app-emulation/cri-o/cri-o-1.15.2.ebuild
new file mode 100644
index 000000000000..c439086a987c
--- /dev/null
+++ b/app-emulation/cri-o/cri-o-1.15.2.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+EGIT_COMMIT="f0827bb332854ffcff2f4d9f64d68b8139970b3d"
+EGO_PN="github.com/cri-o/${PN}"
+
+inherit golang-vcs-snapshot
+
+DESCRIPTION="OCI-based implementation of Kubernetes Container Runtime Interface"
+HOMEPAGE="https://cri-o.io/"
+SRC_URI="https://github.com/cri-o/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0 BSD BSD-2 CC-BY-SA-4.0 ISC MIT MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="btrfs +device-mapper selinux systemd"
+
+COMMON_DEPEND="
+ app-crypt/gpgme:=
+ app-emulation/runc
+ dev-libs/glib:=
+ dev-libs/libassuan:=
+ dev-libs/libgpg-error:=
+ net-firewall/conntrack-tools
+ net-firewall/iptables
+ net-misc/cni-plugins
+ net-misc/socat
+ sys-apps/iproute2
+ sys-libs/libseccomp:=
+ btrfs? ( sys-fs/btrfs-progs )
+ device-mapper? ( sys-fs/lvm2:= )
+ selinux? ( sys-libs/libselinux:= )
+ systemd? ( sys-apps/systemd:= )"
+DEPEND="
+ ${COMMON_DEPEND}"
+RDEPEND="${COMMON_DEPEND}
+ !<app-emulation/libpod-1.3.2-r1"
+S="${WORKDIR}/${P}/src/${EGO_PN}"
+
+src_prepare() {
+ default
+
+ # Avoid network-sandbox violations since go-1.13
+ rm go.mod || die
+
+ sed -e '/^GIT_.*/d' \
+ -e '/ git diff --exit-code/d' \
+ -e 's/$(GO) build -i/$(GO) build -v -work -x/' \
+ -e 's/\${GIT_COMMIT}/'${EGIT_COMMIT}'/' \
+ -i Makefile || die
+
+ echo ".NOTPARALLEL: binaries docs" >> Makefile || die
+
+ sed -e "s|^COMMIT_NO := .*|COMMIT_NO := ${EGIT_COMMIT}|" \
+ -e "s|^GIT_COMMIT := .*|GIT_COMMIT := ${EGIT_COMMIT}|" \
+ -i Makefile.inc || die
+
+ sed -e 's:/usr/local/bin:/usr/bin:' \
+ -i contrib/systemd/* || die
+
+ if ! use systemd; then
+ sed -e 's| pkg-config --exists libsystemd-journal | false |' \
+ -e 's| pkg-config --exists libsystemd | false |' \
+ -i conmon/Makefile || die
+ fi
+}
+
+src_compile() {
+ [[ -f hack/btrfs_installed_tag.sh ]] || die
+ use btrfs || { echo -e "#!/bin/sh\necho exclude_graphdriver_btrfs" > \
+ hack/btrfs_installed_tag.sh || die; }
+
+ [[ -f hack/libdm_installed.sh ]] || die
+ use device-mapper || { echo -e "#!/bin/sh\necho exclude_graphdriver_devicemapper" > \
+ hack/libdm_installed.sh || die; }
+
+ [[ -f hack/selinux_tag.sh ]] || die
+ use selinux || { echo -e "#!/bin/sh\ntrue" > \
+ hack/selinux_tag.sh || die; }
+
+ mkdir -p bin || die
+ GOPATH="${WORKDIR}/${P}" GOBIN="${WORKDIR}/${P}/bin" \
+ emake all
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${D}${EPREFIX}/usr" install install.config install.systemd
+
+ keepdir /etc/crio
+ mv "${ED}/etc/crio/crio.conf"{,.example} || die
+
+ newinitd "${FILESDIR}/crio.initd" crio
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/${PN}.logrotated" "${PN}"
+
+ # Suppress crio log error messages triggered if these don't exist.
+ keepdir /etc/containers/oci/hooks.d
+ keepdir /usr/share/containers/oci/hooks.d
+
+ # Suppress crio "Missing CNI default network" log message.
+ keepdir /etc/cni/net.d
+ insinto /etc/cni/net.d
+ doins contrib/cni/99-loopback.conf
+}