summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2019-05-19 08:34:37 +0200
committerUlrich Müller <ulm@gentoo.org>2019-05-19 08:34:37 +0200
commitc75d623018a94633efb092e4cd3e2cc78e83a1f2 (patch)
treeda6797b95fe412fc9dec23bd1c9425f4a9ff0f50
parentprofiles: Update LDFLAGS in developer profiles (diff)
downloadgentoo-c75d623018a94633efb092e4cd3e2cc78e83a1f2.tar.gz
gentoo-c75d623018a94633efb092e4cd3e2cc78e83a1f2.tar.bz2
gentoo-c75d623018a94633efb092e4cd3e2cc78e83a1f2.zip
sys-kernel/linux-firmware: Flip order of if blocks in src_prepare.
Otherwise, the second rm will fail because of previously removed files. Remove the ewarn message which isn't useful after separation of flags. Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
-rw-r--r--sys-kernel/linux-firmware/linux-firmware-20190514.ebuild14
1 files changed, 5 insertions, 9 deletions
diff --git a/sys-kernel/linux-firmware/linux-firmware-20190514.ebuild b/sys-kernel/linux-firmware/linux-firmware-20190514.ebuild
index 45c50b3372de..d89f8c43e2e4 100644
--- a/sys-kernel/linux-firmware/linux-firmware-20190514.ebuild
+++ b/sys-kernel/linux-firmware/linux-firmware-20190514.ebuild
@@ -228,6 +228,11 @@ src_prepare() {
# remove sources and documentation (wildcards are expanded)
rm -r ${source_files[@]} || die
+ if use !unknown-license; then
+ # remove files in the unknown_license blacklist
+ rm "${unknown_license[@]}" || die
+ fi
+
if use !redistributable; then
# remove files _not_ in the free_software whitelist
local file remove=()
@@ -235,15 +240,6 @@ src_prepare() {
has "${file#./}" "${free_software[@]}" || remove+=("${file}")
done < <(find * ! -type d -print0 || die)
printf "%s\0" "${remove[@]}" | xargs -0 rm || die
-
- if use unknown-license; then
- ewarn 'The "unknown-license" flag is set, while "-redistributable"'
- ewarn 'asks for free software only. Ignoring "unknown-license".'
- fi
- fi
- if use !unknown-license; then
- # remove files in the unknown_license blacklist
- rm "${unknown_license[@]}" || die
fi
echo "# Remove files that shall not be installed from this list." > ${PN}.conf