summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-01-29 13:03:59 +0100
committerJustin Lecher <jlec@gentoo.org>2016-01-30 16:11:26 +0100
commitc7be56114fb2b1b174b831faab3507a2ba0d9b7a (patch)
tree90faaadabc4caa86ac577990406a909b342680a2
parentdev-ruby/commander: add 4.3.7 (diff)
downloadgentoo-c7be56114fb2b1b174b831faab3507a2ba0d9b7a.tar.gz
gentoo-c7be56114fb2b1b174b831faab3507a2ba0d9b7a.tar.bz2
gentoo-c7be56114fb2b1b174b831faab3507a2ba0d9b7a.zip
dev-python/setuptools: Version Bump
Package-Manager: portage-2.2.27 Signed-off-by: Justin Lecher <jlec@gentoo.org>
-rw-r--r--dev-python/setuptools/Manifest1
-rw-r--r--dev-python/setuptools/setuptools-19.6.1.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/setuptools/Manifest b/dev-python/setuptools/Manifest
index d3c5ff95e712..3c92f0d9c5c6 100644
--- a/dev-python/setuptools/Manifest
+++ b/dev-python/setuptools/Manifest
@@ -8,4 +8,5 @@ DIST setuptools-18.8.tar.gz 629367 SHA256 04180e33a40a114ff9b458f31786d885964612
DIST setuptools-19.1.1.tar.gz 640997 SHA256 32ebb08b72aee11fefa6907ddf5db5a81e0eef9cf62c7fa6b58d8e32da249960 SHA512 480aaed577ab9bc4d3cae71d957407ecb71e743dab7fb06f165b76683445f356ce141e1057b5a057101f9546df8c62e2abc2c35ebd751e4bb3febb846a71ac41 WHIRLPOOL 608af5cb22e9b87de3cb0181519058cc7437b7e74b7be4774337d18a562e869cb361edf17f0488c2594039e87dcdc1f201723520568490b0e0be105992abeb37
DIST setuptools-19.2.tar.gz 641777 SHA256 f90ed8eb70b14b0594ba74e9de4ffca040c0ec8ee505cbf3570499467859f71a SHA512 2494606930d6d422e8c105e8e5b40a07b23709f361164c5df40ff24c80328b861179652c7212fa38137534206c187bc4de42d249bc686d43fad18f23d0a26126 WHIRLPOOL ee861dc97a48ec7a07eadc3ceb42077b396a14c1448f0c3d8c6edf2266f4da241bb0e9f31922bc687b6e943802b95b440aea9f2e5d60b8d338c8392102353100
DIST setuptools-19.4.tar.gz 641797 SHA256 214bf29933f47cf25e6faa569f710731728a07a19cae91ea64f826051f68a8cf SHA512 463a2b00193b972e684569dce1527b34d7be9a9d0f866fd8a0c2c1a475558c539148841ca117b0a9c5507d8344dfd5ca515bc6beee59b44c6e8bf05771bc448a WHIRLPOOL 37bdb6592e63c8594051ddfa1df4295dc3417e29b338f66a44270619bf30c6e87b12a7086a8f337f3497bd036cbacc10ab2f179c2768af685b6ee5d93a747897
+DIST setuptools-19.6.1.tar.gz 637780 SHA256 d7fd89a4bbd89ea51aaf18100b50411cc881866f3456f11a8732f1c957f3d7da SHA512 542c41aafdeca3e7658650dfb1c2f5209eb89ae17586cddf1a57316b987507c1263648c93d4177d8d1f775c0ce60c0849b9f4639e395b364ddfe4d92f019be0c WHIRLPOOL 597ed23c4fed9e61f3e8dadfe405fc0cb6be8ccc34c38b3933f69da08452ac53c2ce9e743555544209dd7e55a57fd327bcd7060eb6d0367f869288945dda1a96
DIST setuptools-19.6.tar.gz 641502 SHA256 ecd48d753c1a8ecc6a2826b863a6defaafbfd4ceafc0c1d62e5362f5a86912e9 SHA512 79b9a0f595bda16f18997d9937c6bc2e21bb2bb23fcca4be29df2fb71649c5ba973428472e3c795f2a5d6fbcccf1d5f29096a0fb593a4c52fa87b1d003e474da WHIRLPOOL 391f3e20739c717cc42613e099b867ee01cd8a1f3623f31062dee23131c3b1bad2e34345348f76e44ff2b92652cf65931b3fd8b6a7663b9c135a7c03b6954405
diff --git a/dev-python/setuptools/setuptools-19.6.1.ebuild b/dev-python/setuptools/setuptools-19.6.1.ebuild
new file mode 100644
index 000000000000..300425331f6d
--- /dev/null
+++ b/dev-python/setuptools/setuptools-19.6.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Collection of extensions to Distutils"
+HOMEPAGE="https://pypi.python.org/pypi/setuptools"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/packaging-15.3-r1[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}
+ test? (
+ >=dev-python/pytest-2.8[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+PDEPEND=">=dev-python/certifi-2015.11.20[${PYTHON_USEDEP}]"
+
+# Force in-source build because build system modifies sources.
+DISTUTILS_IN_SOURCE_BUILD=1
+
+DOCS=( README.txt docs/{easy_install.txt,pkg_resources.txt,setuptools.txt} )
+
+python_prepare_all() {
+ rm -r ./pkg_resources/_vendor || die
+ # disable tests requiring a network connection
+ rm setuptools/tests/test_packageindex.py || die
+
+ # don't run integration tests
+ rm setuptools/tests/test_integration.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ # test_easy_install raises a SandboxViolation due to ${HOME}/.pydistutils.cfg
+ # It tries to sandbox the test in a tempdir
+ HOME="${PWD}" py.test --verbose ${PN} || die "Tests failed under ${EPYTHON}"
+}
+
+python_install() {
+ export DISTRIBUTE_DISABLE_VERSIONED_EASY_INSTALL_SCRIPT=1
+ distutils-r1_python_install
+}