summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-06-29 17:02:36 +0200
committerMichał Górny <mgorny@gentoo.org>2020-06-29 17:04:57 +0200
commitc854f9dddefb1a826a82b7e23fcba7162ce9d409 (patch)
treeb370ad7da5a20cf0ea79b5ff4bb5a1220eb81273
parentwww-apps/nikola: bump to v8.1.0 (diff)
downloadgentoo-c854f9dddefb1a826a82b7e23fcba7162ce9d409.tar.gz
gentoo-c854f9dddefb1a826a82b7e23fcba7162ce9d409.tar.bz2
gentoo-c854f9dddefb1a826a82b7e23fcba7162ce9d409.zip
sys-devel/llvm: Pass -Wl,--no-keep-memory to linker on x86
Closes: https://bugs.gentoo.org/730050 Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--sys-devel/llvm/llvm-10.0.0.ebuild4
-rw-r--r--sys-devel/llvm/llvm-10.0.1.9999.ebuild4
-rw-r--r--sys-devel/llvm/llvm-10.0.1_rc1.ebuild4
-rw-r--r--sys-devel/llvm/llvm-11.0.0.9999.ebuild4
4 files changed, 16 insertions, 0 deletions
diff --git a/sys-devel/llvm/llvm-10.0.0.ebuild b/sys-devel/llvm/llvm-10.0.0.ebuild
index c36aefaa55f3..ebb7e7f3f615 100644
--- a/sys-devel/llvm/llvm-10.0.0.ebuild
+++ b/sys-devel/llvm/llvm-10.0.0.ebuild
@@ -344,6 +344,10 @@ multilib_src_configure() {
local CXXFLAGS="${CXXFLAGS} -mno-bmi"
fi
+ # LLVM can have very high memory consumption while linking,
+ # exhausting the limit on 32-bit linker executable
+ use x86 && local -x LDFLAGS="${LDFLAGS} -Wl,--no-keep-memory"
+
# LLVM_ENABLE_ASSERTIONS=NO does not guarantee this for us, #614844
use debug || local -x CPPFLAGS="${CPPFLAGS} -DNDEBUG"
cmake-utils_src_configure
diff --git a/sys-devel/llvm/llvm-10.0.1.9999.ebuild b/sys-devel/llvm/llvm-10.0.1.9999.ebuild
index 6bf2a545f962..0cbd220d5637 100644
--- a/sys-devel/llvm/llvm-10.0.1.9999.ebuild
+++ b/sys-devel/llvm/llvm-10.0.1.9999.ebuild
@@ -432,6 +432,10 @@ multilib_src_configure() {
local CXXFLAGS="${CXXFLAGS} -mno-bmi"
fi
+ # LLVM can have very high memory consumption while linking,
+ # exhausting the limit on 32-bit linker executable
+ use x86 && local -x LDFLAGS="${LDFLAGS} -Wl,--no-keep-memory"
+
# LLVM_ENABLE_ASSERTIONS=NO does not guarantee this for us, #614844
use debug || local -x CPPFLAGS="${CPPFLAGS} -DNDEBUG"
cmake_src_configure
diff --git a/sys-devel/llvm/llvm-10.0.1_rc1.ebuild b/sys-devel/llvm/llvm-10.0.1_rc1.ebuild
index 5ac7c6e2a8c3..bc805c1b4d35 100644
--- a/sys-devel/llvm/llvm-10.0.1_rc1.ebuild
+++ b/sys-devel/llvm/llvm-10.0.1_rc1.ebuild
@@ -397,6 +397,10 @@ multilib_src_configure() {
local CXXFLAGS="${CXXFLAGS} -mno-bmi"
fi
+ # LLVM can have very high memory consumption while linking,
+ # exhausting the limit on 32-bit linker executable
+ use x86 && local -x LDFLAGS="${LDFLAGS} -Wl,--no-keep-memory"
+
# LLVM_ENABLE_ASSERTIONS=NO does not guarantee this for us, #614844
use debug || local -x CPPFLAGS="${CPPFLAGS} -DNDEBUG"
cmake_src_configure
diff --git a/sys-devel/llvm/llvm-11.0.0.9999.ebuild b/sys-devel/llvm/llvm-11.0.0.9999.ebuild
index 877b10f63882..087e2736708d 100644
--- a/sys-devel/llvm/llvm-11.0.0.9999.ebuild
+++ b/sys-devel/llvm/llvm-11.0.0.9999.ebuild
@@ -428,6 +428,10 @@ multilib_src_configure() {
local CXXFLAGS="${CXXFLAGS} -mno-bmi"
fi
+ # LLVM can have very high memory consumption while linking,
+ # exhausting the limit on 32-bit linker executable
+ use x86 && local -x LDFLAGS="${LDFLAGS} -Wl,--no-keep-memory"
+
# LLVM_ENABLE_ASSERTIONS=NO does not guarantee this for us, #614844
use debug || local -x CPPFLAGS="${CPPFLAGS} -DNDEBUG"
cmake_src_configure