summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2015-08-22 11:57:13 -0700
committerMatt Turner <mattst88@gentoo.org>2015-08-22 11:57:13 -0700
commitc99099f8ccf96619eabc5664b05d20db5296d781 (patch)
treeca549da4088715de2141407ff52a4210b2681615
parentkde-misc/kdirstat: version bump. (diff)
downloadgentoo-c99099f8ccf96619eabc5664b05d20db5296d781.tar.gz
gentoo-c99099f8ccf96619eabc5664b05d20db5296d781.tar.bz2
gentoo-c99099f8ccf96619eabc5664b05d20db5296d781.zip
x11-libs/libdrm: Version bump to 2.4.64.
Package-Manager: portage-2.2.20.1
-rw-r--r--x11-libs/libdrm/Manifest1
-rw-r--r--x11-libs/libdrm/libdrm-2.4.64.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/x11-libs/libdrm/Manifest b/x11-libs/libdrm/Manifest
index b28243c3317b..d0eb742f4008 100644
--- a/x11-libs/libdrm/Manifest
+++ b/x11-libs/libdrm/Manifest
@@ -8,3 +8,4 @@ DIST libdrm-2.4.56.tar.bz2 590856 SHA256 e20fbbe092177a8422913d8884a1255477456ab
DIST libdrm-2.4.58.tar.bz2 573202 SHA256 b155fae6b9c9a3b02ef8b77f58c7c219194c996a4018dc55ba66c03996a365dd SHA512 26776b3f93fe173f4e0f94668813ec1a756d9f15385d1cad70c7af8d4d5d503aef00e14081c76f6fcac6e0c606e106e47ddf76038f8601b71fc380306536f937 WHIRLPOOL 36d8915b3189fd0722f96698ce5e7a94188859c7372631c4126b0e09e8fa6dbd4e34de5e9d62e053c36e9f431d84d68d327be307d69caf92e1016893e77cf190
DIST libdrm-2.4.59.tar.bz2 592722 SHA256 68d26e1fd85582f4243d66864f9b43ca4ee93662825de32b5506fc8e181ea41b SHA512 b9f61cfd47cf4a02c10e7fe79b0e9c5701383c76425cf4985a9b91d909f905334ca1ace7334aa0a4ab400694ad84a1a3bc1c3f29842d808026702b35fa9f87c3 WHIRLPOOL 6b0e1be70164db86152503e4b72373736f0462ff97ffac2c79a6c1fce83d658e6030d5435be5a61c1f6ca50728db4c7e3a5d8f5e48073fc74169696ff1b7c5be
DIST libdrm-2.4.62.tar.bz2 637472 SHA256 906c294bdbe1c94c3ca084305d61a6e5a8367f3b4986e6cc13b1e9b3f75931dc SHA512 f7e2ef79c80dd0c3a837970052b7e66110e9b99d3e87b3cd278646bb4cb39832a9562144016a7e956a85212d9251b191279f5ba25d7e8bc0bfbfc1a311df3873 WHIRLPOOL e9ca493f01598bcb7e5664c531e48e74570a7ee0c754794ed2247314123821509448d62290b594073389ff545a019e24305d365ba7435f933665cc57d85385dc
+DIST libdrm-2.4.64.tar.bz2 640440 SHA256 b60786fe7d6e42adb3966ce1a658f63fec528d537396381cbda93bcc99a934b6 SHA512 f4fae23b981c761622b6170ae1f5bc805fc9fe2c5f3531dd45b3e3fcb65c4c4f08d39744c30e2d7f9c14ce6f13dac4a655c0b0ca9785965c59917a4e594e507b WHIRLPOOL 49a96a5d2795f2a9c9fca5cc5808cbfa5e06717d7f4b8221cee55288e16cee503a109321aea04680900fb0bc80e56482a6c8cd15e887eee3d327f0af52706fac
diff --git a/x11-libs/libdrm/libdrm-2.4.64.ebuild b/x11-libs/libdrm/libdrm-2.4.64.ebuild
new file mode 100644
index 000000000000..3e5cc0621b4e
--- /dev/null
+++ b/x11-libs/libdrm/libdrm-2.4.64.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+XORG_MULTILIB=yes
+inherit xorg-2
+
+DESCRIPTION="X.Org libdrm library"
+HOMEPAGE="http://dri.freedesktop.org/"
+if [[ ${PV} = 9999* ]]; then
+ EGIT_REPO_URI="git://anongit.freedesktop.org/git/mesa/drm"
+else
+ SRC_URI="http://dri.freedesktop.org/${PN}/${P}.tar.bz2"
+fi
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~amd64-linux ~arm-linux ~x86-linux"
+VIDEO_CARDS="exynos freedreno intel nouveau omap radeon tegra vmware"
+for card in ${VIDEO_CARDS}; do
+ IUSE_VIDEO_CARDS+=" video_cards_${card}"
+done
+
+IUSE="${IUSE_VIDEO_CARDS} libkms valgrind"
+RESTRICT="test" # see bug #236845
+
+RDEPEND=">=dev-libs/libpthread-stubs-0.3-r1:=[${MULTILIB_USEDEP}]
+ video_cards_intel? ( >=x11-libs/libpciaccess-0.13.1-r1:=[${MULTILIB_USEDEP}] )
+ abi_x86_32? ( !app-emulation/emul-linux-x86-opengl[-abi_x86_32(-)] )"
+DEPEND="${RDEPEND}
+ valgrind? ( dev-util/valgrind )"
+
+src_prepare() {
+ if [[ ${PV} = 9999* ]]; then
+ # tests are restricted, no point in building them
+ sed -ie 's/tests //' "${S}"/Makefile.am
+ fi
+ xorg-2_src_prepare
+}
+
+src_configure() {
+ XORG_CONFIGURE_OPTIONS=(
+ # Udev is only used by tests now.
+ --disable-udev
+ --disable-cairo-tests
+ $(use_enable video_cards_exynos exynos-experimental-api)
+ $(use_enable video_cards_freedreno freedreno)
+ $(use_enable video_cards_intel intel)
+ $(use_enable video_cards_nouveau nouveau)
+ $(use_enable video_cards_omap omap-experimental-api)
+ $(use_enable video_cards_radeon radeon)
+ $(use_enable video_cards_tegra tegra-experimental-api)
+ $(use_enable video_cards_vmware vmwgfx)
+ $(use_enable libkms)
+ # valgrind installs its .pc file to the pkgconfig for the primary arch
+ --enable-valgrind=$(usex valgrind auto no)
+ )
+
+ xorg-2_src_configure
+}