summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-08 19:10:25 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-08 19:30:19 +0200
commitc9ad36dd206bdc84247aba0625ea618301f078d5 (patch)
treeae3c9a46f7d912eafc4ef04af2b1ce7d169e48d6
parentdev-ros/test_rospy: bump eapi (diff)
downloadgentoo-c9ad36dd206bdc84247aba0625ea618301f078d5.tar.gz
gentoo-c9ad36dd206bdc84247aba0625ea618301f078d5.tar.bz2
gentoo-c9ad36dd206bdc84247aba0625ea618301f078d5.zip
dev-ros/test_rospy: Remove old
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
-rw-r--r--dev-ros/test_rospy/Manifest2
-rw-r--r--dev-ros/test_rospy/files/py3-2.patch40
-rw-r--r--dev-ros/test_rospy/files/py3.patch34
-rw-r--r--dev-ros/test_rospy/test_rospy-1.14.3-r1.ebuild34
-rw-r--r--dev-ros/test_rospy/test_rospy-1.15.4.ebuild33
5 files changed, 0 insertions, 143 deletions
diff --git a/dev-ros/test_rospy/Manifest b/dev-ros/test_rospy/Manifest
index e7119a998e05..5d86517495e4 100644
--- a/dev-ros/test_rospy/Manifest
+++ b/dev-ros/test_rospy/Manifest
@@ -1,3 +1 @@
-DIST ros_comm-1.14.3.tar.gz 1045287 BLAKE2B c079983aa730e70028d1bf2c365d01d99ce09ced0c0f6443b18f9d0fb83715f6af4b313d6db4eb99dcc10052c81fa3e6560e7b3591b2fbe14b9ec20fac24babe SHA512 52df24f10f476697ee6fa340da354b45431f35018a25e2674dc9306f175929a4b0368753503ea143f87aeb4945a2e67c37f83d833f54b53f9a76a81022c280a3
-DIST ros_comm-1.15.4.tar.gz 1071246 BLAKE2B 57867c192bfd48f3a0534762808c668031081a6155510879e68f9618226b9c5eff0d5fc9ec0e7ec8d0cc1f0d74794a4e55151036275ae6fc5bb613cc42137ddc SHA512 f92233cbf5ee97832023545730d3e756dfa08507072c074ac3e0763db1c2c2ab9fcbb0c90995a0c5d43f0ddc2ee528c185173a664b19abe4f8159aa3f3cb20dc
DIST ros_comm-1.15.7.tar.gz 1080092 BLAKE2B d5c0dd1f54eac7aa11be21bbc680f85f988cc9328382c0c675b7d5986e888be603ed82affa5f51a270974d07044debe3ecf86f5647fd59cb29e8e791a227feb9 SHA512 67dc100e8ed03a25ea228cc7d456ec2203324098f9e11c9a249299df73bfc34efc75b1221c0fb6fceb38fece627f1dc5f2c23be93c9a1c85b1075784a45ff20e
diff --git a/dev-ros/test_rospy/files/py3-2.patch b/dev-ros/test_rospy/files/py3-2.patch
deleted file mode 100644
index 18ac23d16866..000000000000
--- a/dev-ros/test_rospy/files/py3-2.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-From 1933acfa8107a164ec825d3223d14589fefd1b5b Mon Sep 17 00:00:00 2001
-From: Dirk Thomas <dirk-thomas@users.noreply.github.com>
-Date: Tue, 6 Aug 2019 16:06:51 -0700
-Subject: [PATCH] more Python 3 compatibility (#1783)
-
----
- test/test_rospy/test/unit/test_genmsg_py.py | 6 +--
- tools/rosgraph/src/rosgraph/roslogging.py | 2 +-
- .../test/test_roslogging_user_logger.py | 8 +++-
- tools/roslaunch/test/unit/test_xmlloader.py | 2 +-
- tools/rosmsg/src/rosmsg/__init__.py | 2 +-
- tools/rosmsg/test/test_rosmsg_command_line.py | 46 +++++++++----------
- .../test/test_rosmsgproto_command_line.py | 20 ++++----
- .../test_rostopic_command_line_offline.py | 44 +++++++++---------
- 8 files changed, 67 insertions(+), 63 deletions(-)
-
-diff --git a/test/test_rospy/test/unit/test_genmsg_py.py b/test/test_rospy/test/unit/test_genmsg_py.py
-index 397b35cee..38be1648e 100644
---- a/test/test_rospy/test/unit/test_genmsg_py.py
-+++ b/test/test_rospy/test/unit/test_genmsg_py.py
-@@ -95,8 +95,8 @@ def test_test_rospy_TestFixedArray(self):
- self.assertEquals([0., 0., 0.], m.f64_3)
- self.assertEquals([0], m.i8_1)
- self.assertEquals([0, 0, 0], m.i8_3)
-- self.assertEquals(chr(0), m.u8_1)
-- self.assertEquals(chr(0)*3, m.u8_3)
-+ self.assertEquals(chr(0).encode(), m.u8_1)
-+ self.assertEquals((chr(0)*3).encode(), m.u8_3)
- self.assertEquals([0], m.i32_1)
- self.assertEquals([0, 0, 0], m.i32_3)
- self.assertEquals([0], m.u32_1)
-@@ -358,7 +358,7 @@ def test_std_msgs_MultiArray(self):
- # test. the buff was with the uint8[] type consistency
- buff = StringIO()
- self.assertEquals(UInt8MultiArray(),UInt8MultiArray())
-- self.assertEquals('',UInt8MultiArray().data)
-+ self.assertEquals(b'', UInt8MultiArray().data)
- UInt8MultiArray().serialize(buff)
- self.assertEquals(UInt8MultiArray(layout=MultiArrayLayout()),UInt8MultiArray())
- UInt8MultiArray(layout=MultiArrayLayout()).serialize(buff)
diff --git a/dev-ros/test_rospy/files/py3.patch b/dev-ros/test_rospy/files/py3.patch
deleted file mode 100644
index d7ed0f9c9606..000000000000
--- a/dev-ros/test_rospy/files/py3.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-From 8f22c20e418abe4abe23e789eef517a16a50604d Mon Sep 17 00:00:00 2001
-From: Dirk Thomas <dirk-thomas@users.noreply.github.com>
-Date: Tue, 6 Aug 2019 12:50:24 -0700
-Subject: [PATCH] more Python 3 compatibility (#1782)
-
----
- test/test_rosmaster/test/nodes/testAllCommonFlows | 2 +-
- test/test_rosmaster/test/nodes/testMaster | 2 +-
- test/test_rosmaster/test/nodes/testSlave | 2 +-
- test/test_rospy/test/unit/test_genmsg_py.py | 8 +++++++-
- tools/rosgraph/test/test_roslogging.py | 5 ++++-
- tools/rosgraph/test/test_roslogging_user_logger.py | 5 ++++-
- tools/roslaunch/src/roslaunch/depends.py | 8 ++++----
- 7 files changed, 22 insertions(+), 10 deletions(-)
-
-diff --git a/test/test_rospy/test/unit/test_genmsg_py.py b/test/test_rospy/test/unit/test_genmsg_py.py
-index aebf95b22..397b35cee 100644
---- a/test/test_rospy/test/unit/test_genmsg_py.py
-+++ b/test/test_rospy/test/unit/test_genmsg_py.py
-@@ -44,7 +44,13 @@
- import math
-
- from roslib.message import SerializationError
--
-+
-+try:
-+ long
-+except NameError:
-+ long = int
-+
-+
- class TestGenmsgPy(unittest.TestCase):
-
- def test_PythonKeyword(self):
diff --git a/dev-ros/test_rospy/test_rospy-1.14.3-r1.ebuild b/dev-ros/test_rospy/test_rospy-1.14.3-r1.ebuild
deleted file mode 100644
index 2cf6f2717553..000000000000
--- a/dev-ros/test_rospy/test_rospy-1.14.3-r1.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-ROS_REPO_URI="https://github.com/ros/ros_comm"
-KEYWORDS="~amd64 ~arm"
-ROS_SUBDIR=test/${PN}
-CATKIN_HAS_MESSAGES=yes
-CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs dev-ros/test_rosmaster"
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit ros-catkin
-
-DESCRIPTION="Unit tests for rospy"
-LICENSE="BSD"
-SLOT="0"
-IUSE=""
-
-RDEPEND=""
-DEPEND="${RDEPEND}
- dev-ros/rostest[${PYTHON_USEDEP}]
- dev-ros/std_msgs[${PYTHON_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
- dev-ros/test_rosmaster[${PYTHON_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
- dev-ros/rosunit[${PYTHON_USEDEP}]
- test? (
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-ros/rosbuild
- dev-ros/rosgraph[${PYTHON_USEDEP}]
- dev-ros/rospy[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
- )"
-PATCHES=( "${FILESDIR}/py3.patch" "${FILESDIR}/py3-2.patch" )
diff --git a/dev-ros/test_rospy/test_rospy-1.15.4.ebuild b/dev-ros/test_rospy/test_rospy-1.15.4.ebuild
deleted file mode 100644
index a60ab86abc52..000000000000
--- a/dev-ros/test_rospy/test_rospy-1.15.4.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-ROS_REPO_URI="https://github.com/ros/ros_comm"
-KEYWORDS="~amd64 ~arm"
-ROS_SUBDIR=test/${PN}
-CATKIN_HAS_MESSAGES=yes
-CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs dev-ros/test_rosmaster"
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit ros-catkin
-
-DESCRIPTION="Unit tests for rospy"
-LICENSE="BSD"
-SLOT="0"
-IUSE=""
-
-RDEPEND=""
-DEPEND="${RDEPEND}
- dev-ros/rostest[${PYTHON_USEDEP}]
- dev-ros/std_msgs[${PYTHON_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
- dev-ros/test_rosmaster[${PYTHON_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
- dev-ros/rosunit[${PYTHON_USEDEP}]
- test? (
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-ros/rosbuild
- dev-ros/rosgraph[${PYTHON_USEDEP}]
- dev-ros/rospy[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
- )"