summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-10-14 13:31:36 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-10-14 13:31:36 +0200
commitc9e9bc84987cc2c62a547be30a453c7bfc347b7f (patch)
tree6f1af4483132e89848d15b62880dbc2b1103c90d
parentdev-lang/ocaml: bump to 4.06.0_beta2 (diff)
downloadgentoo-c9e9bc84987cc2c62a547be30a453c7bfc347b7f.tar.gz
gentoo-c9e9bc84987cc2c62a547be30a453c7bfc347b7f.tar.bz2
gentoo-c9e9bc84987cc2c62a547be30a453c7bfc347b7f.zip
dev-python/rospkg: bump to 1.1.4
Package-Manager: Portage-2.3.11, Repoman-2.3.3
-rw-r--r--dev-python/rospkg/Manifest1
-rw-r--r--dev-python/rospkg/rospkg-1.1.4.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/rospkg/Manifest b/dev-python/rospkg/Manifest
index 1acf60b32f43..a544e3688c05 100644
--- a/dev-python/rospkg/Manifest
+++ b/dev-python/rospkg/Manifest
@@ -1 +1,2 @@
DIST rospkg-1.1.3.tar.gz 89534 SHA256 ba0948fbb3be14082f9e83763cbe3a12857127eb78e142748c9d16d41ab4479c SHA512 2bb0521fbb87492dbc83d2582a8de3034f2e5548c1a464cfc558915157f3ef9d34d6166a4378d5e5cb226f2c8f714df86879220f7041d37b58a9ad33be2ce3cd WHIRLPOOL 77082d0927626a5350300c556fd15eceb3527ee3a64239ade75aa2758288c1835e3f7797425ea6921674cab187593ec494406717a8daa88093dea874efad95d0
+DIST rospkg-1.1.4.tar.gz 89554 SHA256 9d93bbf646c3db7e5ffd9814a879fe76cf45d2aa0a0bb210f44e807ea41a4c70 SHA512 1758dcbe28c18c834a60bbda2e5e6be34629b3dd4f6519f24dfa1324ff9fc59fb7d0ae9d324c002eee06ff672309627e48f97119b36601390b24a24ae196d5c5 WHIRLPOOL ab3eedf4df5bac5cfb19c50e8452928c8a879fc506a13e1ff2f92cb37afdd610ade43efd367d5c5cf09fbbc331177e42d79f8825da23ed05fae2f9f3953b4ab2
diff --git a/dev-python/rospkg/rospkg-1.1.4.ebuild b/dev-python/rospkg/rospkg-1.1.4.ebuild
new file mode 100644
index 000000000000..dff594067afb
--- /dev/null
+++ b/dev-python/rospkg/rospkg-1.1.4.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+
+SCM=""
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SCM="git-r3"
+ EGIT_REPO_URI="https://github.com/ros-infrastructure/rospkg"
+fi
+
+inherit ${SCM} distutils-r1
+
+DESCRIPTION="Standalone Python library for the ROS package system"
+HOMEPAGE="http://wiki.ros.org/rospkg"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SRC_URI=""
+ KEYWORDS=""
+ # Needed for tests
+ S="${WORKDIR}/${PN}"
+ EGIT_CHECKOUT_DIR="${S}"
+else
+ SRC_URI="https://github.com/ros-infrastructure/rospkg/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="dev-python/pyyaml[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ )
+"
+PATCHES=( "${FILESDIR}/gentoo.patch" )
+
+python_test() {
+ nosetests --with-coverage --cover-package=rospkg --with-xunit test || die
+}