summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-05-02 11:23:12 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-05-02 11:33:28 +0200
commitc9f0d6762925bea95fe065f692d2238c071339a1 (patch)
treedb6b9651d303c1d70f93a0ecf77dd99d2cda10f9
parentdev-ros/rqt_nav_view: bump to 0.5.7 and switch to split repos (diff)
downloadgentoo-c9f0d6762925bea95fe065f692d2238c071339a1.tar.gz
gentoo-c9f0d6762925bea95fe065f692d2238c071339a1.tar.bz2
gentoo-c9f0d6762925bea95fe065f692d2238c071339a1.zip
dev-ros/rqt_pose_view: bump to 0.5.7 and update to split repos
Package-Manager: Portage-2.3.5, Repoman-2.3.2
-rw-r--r--dev-ros/rqt_pose_view/Manifest1
-rw-r--r--dev-ros/rqt_pose_view/metadata.xml2
-rw-r--r--dev-ros/rqt_pose_view/rqt_pose_view-0.5.7.ebuild29
-rw-r--r--dev-ros/rqt_pose_view/rqt_pose_view-9999.ebuild3
4 files changed, 32 insertions, 3 deletions
diff --git a/dev-ros/rqt_pose_view/Manifest b/dev-ros/rqt_pose_view/Manifest
index bb0da5c3c13b..072f5f5e6dd7 100644
--- a/dev-ros/rqt_pose_view/Manifest
+++ b/dev-ros/rqt_pose_view/Manifest
@@ -1 +1,2 @@
+DIST rqt_pose_view-0.5.7.tar.gz 8217 SHA256 857191b2a53e9ad688d8757d1ca44b5e7c417f64f13141f4878a43f6a81a217f SHA512 34103deaf3fadc505c17e75f5ccc11acf93c1752a2ab76d2552e842b6072cce9c2cd73c5a7520a38f57e3a053a8ecfa5f29f9317c128275663d2435d0a660007 WHIRLPOOL bbeec4d042358ece77eb9d94c2783e598b3126c83b74e4707674c6c26f71f3d66677fd2f411f80c942aeea8f7837b027e357c84bcd7200bed0779a312b51292d
DIST rqt_robot_plugins-0.5.6.tar.gz 2107696 SHA256 d5f1b509df54b253d3b2952560e8dc5e764c3259b0e9dcff08541e27ac9fed71 SHA512 871f660e22afafd510e34984b94d2530bc3314db194c06ff458430e15b1183a60147289e9544a5fb070665a3c83034cbcccefe2f820e62f091c3bbc0edfd0a51 WHIRLPOOL a90882b1e762f5e53b7ce7ff92695ba8eb63242b53304a08c928f2667ceb206cfda72e64d81b73d1d951e6b92cb5f16327528846f6b54e28b2acaf898424a664
diff --git a/dev-ros/rqt_pose_view/metadata.xml b/dev-ros/rqt_pose_view/metadata.xml
index 70d1993e2855..02b6f18344ab 100644
--- a/dev-ros/rqt_pose_view/metadata.xml
+++ b/dev-ros/rqt_pose_view/metadata.xml
@@ -6,6 +6,6 @@
<name>Gentoo ROS Project</name>
</maintainer>
<upstream>
- <remote-id type="github">ros-visualization/rqt_robot_plugins</remote-id>
+ <remote-id type="github">ros-visualization/rqt_pose_view</remote-id>
</upstream>
</pkgmetadata>
diff --git a/dev-ros/rqt_pose_view/rqt_pose_view-0.5.7.ebuild b/dev-ros/rqt_pose_view/rqt_pose_view-0.5.7.ebuild
new file mode 100644
index 000000000000..f4b93343f49c
--- /dev/null
+++ b/dev-ros/rqt_pose_view/rqt_pose_view-0.5.7.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_pose_view"
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="GUI plugin for visualizing 3D poses"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-python/pyopengl[${PYTHON_USEDEP}]
+ dev-ros/python_qt_binding[${PYTHON_USEDEP}]
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rostopic[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui_py[${PYTHON_USEDEP}]
+ dev-ros/tf[${PYTHON_USEDEP}]
+ dev-ros/rqt_py_common[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/rqt_pose_view/rqt_pose_view-9999.ebuild b/dev-ros/rqt_pose_view/rqt_pose_view-9999.ebuild
index 515ae61769ea..f4b93343f49c 100644
--- a/dev-ros/rqt_pose_view/rqt_pose_view-9999.ebuild
+++ b/dev-ros/rqt_pose_view/rqt_pose_view-9999.ebuild
@@ -4,9 +4,8 @@
EAPI=5
KEYWORDS="~amd64"
-ROS_REPO_URI="https://github.com/ros-visualization/rqt_robot_plugins"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_pose_view"
PYTHON_COMPAT=( python2_7 )
-ROS_SUBDIR=${PN}
inherit ros-catkin