summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2019-07-14 11:02:30 -0700
committerMatt Turner <mattst88@gentoo.org>2019-07-14 11:23:14 -0700
commitca7a1a6d5417f0fd2af87a480ddc936f1535bb34 (patch)
treef7e0c7ae3edc89524c636301115edf83c1be45e2
parentdev-db/sqlcl-bin: remove old (diff)
downloadgentoo-ca7a1a6d5417f0fd2af87a480ddc936f1535bb34.tar.gz
gentoo-ca7a1a6d5417f0fd2af87a480ddc936f1535bb34.tar.bz2
gentoo-ca7a1a6d5417f0fd2af87a480ddc936f1535bb34.zip
x11-libs/libICE: Version bump to 1.0.10
Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--x11-libs/libICE/Manifest1
-rw-r--r--x11-libs/libICE/libICE-1.0.10.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/x11-libs/libICE/Manifest b/x11-libs/libICE/Manifest
index f1733d590a79..09f64b4db983 100644
--- a/x11-libs/libICE/Manifest
+++ b/x11-libs/libICE/Manifest
@@ -1 +1,2 @@
+DIST libICE-1.0.10.tar.bz2 393116 BLAKE2B 2089cbddab679f8565f0b7bf0313616b71f33cd403aea2cb84032a247c1e1d01de343058c31be73214bd6dea7fc167fa6a0f81704c960bc279d904bdf4bf804f SHA512 2f1ef2c32c833c71894a08fa7e7ed53f301f6c7bd22485d71c12884d8e8b36b99f362ec886349dcc84d08edc81c8b2cea035320831d64974edeba021b433c468
DIST libICE-1.0.9.tar.bz2 384921 BLAKE2B 701122d9ef6bfa9077f63b35131dc4603964dbb0b7f58bd54ca49e25be24265142d39da4e1f7c72fdf4945dfb358f7b061acb848dfb0c1bcac5973c9fc728a26 SHA512 daa8126ee5279c08f801274a2754132762dea2a40f4733c4b0bf8e8bdad61cba826939a2e067beb3524e256a98a2b83f23c8d4643f3e75a284ab02cc73da41b7
diff --git a/x11-libs/libICE/libICE-1.0.10.ebuild b/x11-libs/libICE/libICE-1.0.10.ebuild
new file mode 100644
index 000000000000..fcf1112fea93
--- /dev/null
+++ b/x11-libs/libICE/libICE-1.0.10.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+XORG_MULTILIB=yes
+inherit xorg-3
+
+DESCRIPTION="X.Org Inter-Client Exchange library"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
+IUSE="ipv6"
+
+DEPEND="x11-base/xorg-proto
+ x11-libs/xtrans"
+RDEPEND="${DEPEND}
+ elibc_glibc? ( dev-libs/libbsd )"
+
+pkg_setup() {
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_enable ipv6)
+ --disable-docs
+ --disable-specs
+ --without-fop
+ )
+}