summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-10-06 00:31:05 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2020-10-06 00:42:19 -0500
commitcc3b5797292d17ff1f966b2492f830959f360a36 (patch)
treeceec46b1694829e8b52a5fbbb6a47bb5874b807a
parentdev-python/pyclipper: Stabilize 1.2.0 arm64, #733550 (diff)
downloadgentoo-cc3b5797292d17ff1f966b2492f830959f360a36.tar.gz
gentoo-cc3b5797292d17ff1f966b2492f830959f360a36.tar.bz2
gentoo-cc3b5797292d17ff1f966b2492f830959f360a36.zip
app-admin/ansible: 2.9.14 bump
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
-rw-r--r--app-admin/ansible/Manifest1
-rw-r--r--app-admin/ansible/ansible-2.9.14.ebuild69
2 files changed, 70 insertions, 0 deletions
diff --git a/app-admin/ansible/Manifest b/app-admin/ansible/Manifest
index afeaf6678c42..d7ca2462bb48 100644
--- a/app-admin/ansible/Manifest
+++ b/app-admin/ansible/Manifest
@@ -1,2 +1,3 @@
DIST ansible-2.10.0.tar.gz 25454980 BLAKE2B 91f930518b90b36aa2c21f553092233059fada86fd1674c9c6e881484b1bd4e68a3eaa05d82e15115906e55da99c43394c3de36a898e26bb222f780b82f8a5bd SHA512 878036f06e1705e4392223bda210b2acae0232069d0cec02a47f13f6b3bc6c9538fb515a2d2dc6003695bcf0915fdd3dfc5b8dc59355e37e2ca8fa48bbd79657
DIST ansible-2.9.13.tar.gz 14261322 BLAKE2B 5de939a99cd703eaf240f536a9a4b707e3931364647782dde2bbebd5b755253594cbb1cf8c4e9f22a14fca85c9f018ee6ea26bce1cbe2145ba72e5f5ec313670 SHA512 cb08adf62df0f3650425a5d960baadd7439c7c1e95b8f9df3d08e7504f9622b9e5f7104b8700b0f1e9fe318d349a6a5728e9178f0193fb4a190456e30a2f1eb2
+DIST ansible-2.9.14.tar.gz 14272261 BLAKE2B d0d631d5e3382361e1781008d3189aae028c45cdfcf8c4d19838388751da0770dc65ea186f935d6183367dea306142d4629ef01ac855676960dceb182eab875a SHA512 1c69970629619814c02ff10e9d857d36ddc3ab6b4ff3f4e66fb0ea0b9a2fd5bc2de2c9d550427bcf3c9387d9e0138aff100c9fc1b92838871d7d8fe8a5cca8bd
diff --git a/app-admin/ansible/ansible-2.9.14.ebuild b/app-admin/ansible/ansible-2.9.14.ebuild
new file mode 100644
index 000000000000..5641f4825a3c
--- /dev/null
+++ b/app-admin/ansible/ansible-2.9.14.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="Model-driven deployment, config management, and command execution framework"
+HOMEPAGE="https://ansible.com/"
+SRC_URI="https://releases.ansible.com/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~x64-macos"
+IUSE="doc test"
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/httplib2[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/netaddr[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ net-misc/sshpass
+ virtual/ssh
+ !app-admin/ansible-base
+"
+DEPEND="
+ !app-admin/ansible-base
+ >=dev-python/packaging-16.6[${PYTHON_USEDEP}]
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinx-notfound-page[${PYTHON_USEDEP}]
+ >=dev-python/pygments-2.4.0[${PYTHON_USEDEP}]
+ )
+ test? (
+ ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ >=dev-python/mock-1.0.1[${PYTHON_USEDEP}]
+ dev-python/passlib[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/unittest2[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )"
+
+python_compile_all() {
+ if use doc; then
+ cd docs/docsite || die
+ export CPUS=4
+ emake -f Makefile.sphinx html
+ fi
+}
+
+python_test() {
+ nosetests -d -w test/units -v --with-coverage --cover-package=ansible --cover-branches || die
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/docsite/_build/html/. )
+ distutils-r1_python_install_all
+
+ dodoc -r examples
+}