summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2017-08-27 04:05:53 -0400
committerTim Harder <radhermit@gentoo.org>2017-08-27 04:05:53 -0400
commitcc63c1c5644efa7329726a03da1bcc6c1e289ea8 (patch)
tree185697ebf0283469a6ba84ad9798f15fe318c058
parentdev-python/python-dateutil: version bump to 2.6.1 (diff)
downloadgentoo-cc63c1c5644efa7329726a03da1bcc6c1e289ea8.tar.gz
gentoo-cc63c1c5644efa7329726a03da1bcc6c1e289ea8.tar.bz2
gentoo-cc63c1c5644efa7329726a03da1bcc6c1e289ea8.zip
dev-python/wrapt: version bump to 1.10.11
-rw-r--r--dev-python/wrapt/Manifest1
-rw-r--r--dev-python/wrapt/wrapt-1.10.11.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/wrapt/Manifest b/dev-python/wrapt/Manifest
index 6d4eeac2ca91..c721dd71a9c5 100644
--- a/dev-python/wrapt/Manifest
+++ b/dev-python/wrapt/Manifest
@@ -1,3 +1,4 @@
DIST wrapt-1.10.10.tar.gz 122052 SHA256 ded853e421bbc7bb668b085391f2e2be9bd83f8e3565f8efddc937284446e3aa SHA512 e18283cac7bbb137f43fa8c2839fff14072db1fdae57da2b393a5db4007656706838b64bc6785cea25602205b595fc4e7fe033e580d2fb484fd8c77351e046d1 WHIRLPOOL e00854862bc0f0b8bd558642de3ffb99540166b6e888df7159185f1fe3d962e34cd5f88d483f245eb9b013c7d0120d4b9950cce0630a8dec08704d9ceb168b21
+DIST wrapt-1.10.11.tar.gz 122499 SHA256 948bb6ed9a633034924420de701bb0f5f95970f195a509cee2df92f752ab9ae9 SHA512 cc051749341bcd6fc1a950607fad94f74334a00acf0366129470181a5af7a3af32a26e5c5deee9242ee12bcc7e4c47dacb958c514aba8a764be3bcc662845b98 WHIRLPOOL 126210cb96950eefaf856fe3bfd07a0fcc3fc315c04455b41709d88aad09244f2417820f39d5818087ec5aaa5d681ccd610e8892a5186dcea3d5ca5f8963a3a7
DIST wrapt-1.10.5.tar.gz 119157 SHA256 4fd82193b23f60e1a39f3e10c81143c1e29e26cd5fc9afe1a7dc0f5e4b4a67d7 SHA512 450b32eea67774081d23c0e020ed7eea3c8ac458925a16cd606a4f95ee5b7631bda5ff00ceb914e9ccc28a5e0a7302534b6711bb23d637c77327a8a9d228cb55 WHIRLPOOL 7cfa9477f525e60f16a7b1689ba43b327192837bea34e96977442b9cd143a63fafdfa7d0b3895c93052b0e6f426e76fa439b155ee4e481dd5e922c529676691c
DIST wrapt-1.10.8.tar.gz 120359 SHA256 096b47f44e3197934ccc335c53d2d21bf6ed9fd941b294726e26a1fd18fd4541 SHA512 2a37584b3c3a33a2d39d5cbe9f7e61a50131db55ffd5be7902b5ee84c347d8ff4d6094e5639d2f854fab274b2517a0e47420da9f543f11cf92973acd6d15d42e WHIRLPOOL 5f27b048b9f06c03c3e3acdd9c3a64308958585deb7e314c80158910cfc1eac154540a0e4a3c838718456d5ed38751d85f49645e634a7d2734cad916547a5bc7
diff --git a/dev-python/wrapt/wrapt-1.10.11.ebuild b/dev-python/wrapt/wrapt-1.10.11.ebuild
new file mode 100644
index 000000000000..5ff5ec966398
--- /dev/null
+++ b/dev-python/wrapt/wrapt-1.10.11.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Module for decorators, wrappers and monkey patching"
+HOMEPAGE="https://github.com/GrahamDumpleton/wrapt"
+SRC_URI="https://github.com/GrahamDumpleton/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux"
+IUSE="doc test"
+
+DEPEND="
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND=""
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_compile() {
+ local WRAPT_EXTENSIONS=true
+
+ distutils-r1_python_compile
+}
+
+python_test() {
+ py.test -vv || die "tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+
+ distutils-r1_python_install_all
+}