summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-01-22 20:39:46 +0100
committerHans de Graaff <graaff@gentoo.org>2018-01-22 20:39:46 +0100
commitcd96e192c02e172b1b8fab80159a47af13171eb6 (patch)
tree19b929029f00694c556636c17d4ad2208609334c
parentdev-ruby/gpgme: cleanup (diff)
downloadgentoo-cd96e192c02e172b1b8fab80159a47af13171eb6.tar.gz
gentoo-cd96e192c02e172b1b8fab80159a47af13171eb6.tar.bz2
gentoo-cd96e192c02e172b1b8fab80159a47af13171eb6.zip
dev-ruby/github_api: cleanup
Package-Manager: Portage-2.3.19, Repoman-2.3.6
-rw-r--r--dev-ruby/github_api/Manifest3
-rw-r--r--dev-ruby/github_api/github_api-0.14.5.ebuild42
-rw-r--r--dev-ruby/github_api/github_api-0.17.0.ebuild31
-rw-r--r--dev-ruby/github_api/github_api-0.18.1.ebuild30
4 files changed, 0 insertions, 106 deletions
diff --git a/dev-ruby/github_api/Manifest b/dev-ruby/github_api/Manifest
index 23b32ea9a0e4..a66d234c3b9d 100644
--- a/dev-ruby/github_api/Manifest
+++ b/dev-ruby/github_api/Manifest
@@ -1,4 +1 @@
-DIST github_api-0.14.5.tar.gz 2047231 BLAKE2B 3c44afacbb7c50908b553464266d1f66f50b71869987a43086fa8c88a9d038901790661c9515aa7eac54128fb9b946a77278f2cc129e0aeba120726c7b984fdb SHA512 c19b8364e627427ae0447810b7d56b5bf50f89030a02af9b19116abc906ac780149b47d54ae3a93d4e1a3f52461fd1b8fe969501fa5ec6e535db22749b8ecd89
-DIST github_api-0.17.0.tar.gz 2122803 BLAKE2B 66bc23ef31d2d7a4e45cadea0b20e64a451672d4ecac2822b01db166af9a4af92681d9c8ec79d05eb930e78935ddacc885d17f0f4db5e42166737467c6f33f02 SHA512 0b85b299fb85e8f5e48d5c0a18fbab1d6d43fc2a35bd3dc7d6517b06267c9daed6bd60fd1572b64d61c034be30729e7aeda38aad15f7749b40935761d3db7a98
-DIST github_api-0.18.1.tar.gz 2124835 BLAKE2B 23d0e884aeec023233d2be534a2de336ae6702ada6933d52572fd1695b1217a0cf7be062b233c614456def11014b182fba182585c8d8665a6f8e126d813bd9ef SHA512 92c0348807307d00d92d12cf72e736bfbd525b2db9cc6ccc0caa74753a88166941e0300db55f353a7b2d169fd0b409ada7eb76b505b902a949388b5bf24c0457
DIST github_api-0.18.2.tar.gz 2124932 BLAKE2B 62ce868b5437262c3cbcac7cf8e3966288cdf5b78e4698f3d3e35d1da3e839f6445e582db74db47292749014a9532a0ad3077a7b5bd30e2148546348241e52a0 SHA512 ebc57fb86bf56b5af6f6ed96c3dab9190dc7695f37826851d35a7621f8f655c3aae5ef613e48fd6bc98e74e8cb6218a3cf425173feb98e6e054d7fced115ac14
diff --git a/dev-ruby/github_api/github_api-0.14.5.ebuild b/dev-ruby/github_api/github_api-0.14.5.ebuild
deleted file mode 100644
index 51ebdfb245b4..000000000000
--- a/dev-ruby/github_api/github_api-0.14.5.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-USE_RUBY="ruby20 ruby21 ruby22"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec"
-RUBY_FAKEGEM_RECIPE_DOC="rdoc"
-RUBY_FAKEGEM_EXTRADOC="README.md"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A Ruby wrapper for the GitHub REST API v3"
-HOMEPAGE="https://github.com/peter-murach/github"
-SRC_URI="https://github.com/peter-murach/github/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-RUBY_S="github-${PV}"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc64 ~x86"
-IUSE=""
-
-ruby_add_rdepend "
- >=dev-ruby/addressable-2.4 =dev-ruby/addressable-2.4*
- >=dev-ruby/descendants_tracker-0.0.4 =dev-ruby/descendants_tracker-0.0*
- >=dev-ruby/faraday-0.8 <dev-ruby/faraday-0.10
- >=dev-ruby/hashie-3.4
- =dev-ruby/oauth2-1*"
-
-ruby_add_bdepend "test? ( >=dev-ruby/rspec-2.14 dev-ruby/webmock:0 )"
-
-all_ruby_prepare() {
- # Work around or avoid webmock incompatibilities
- sed -i -e '1igem "webmock", "~>1.17"' spec/spec_helper.rb || die
- files=$(grep -R -l "with(inputs)" spec)
- sed -i -e 's/\.with(inputs)//' \
- -e 's/\.with(inputs.except(.*))//' ${files} || die
- sed -i -e 's/.with(hub_inputs.*)//' spec/github/client/repos/pub_sub_hubbub/*subscribe* || die
- sed -i -e 's/.with({})//i' spec/github/client/repos/{list,contributors}_spec.rb || die
- sed -i -e 's/.with({.*})//' spec/unit/client/orgs/memberships/edit_spec.rb || die
- rm -f spec/unit/error/service_error_spec.rb ./spec/unit/error/unprocessable_entity_spec.rb spec/github/client/authorizations/two_factor_spec.rb || die
-}
diff --git a/dev-ruby/github_api/github_api-0.17.0.ebuild b/dev-ruby/github_api/github_api-0.17.0.ebuild
deleted file mode 100644
index 3f81c5eddb54..000000000000
--- a/dev-ruby/github_api/github_api-0.17.0.ebuild
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-USE_RUBY="ruby21 ruby22 ruby23"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec"
-RUBY_FAKEGEM_RECIPE_DOC="rdoc"
-RUBY_FAKEGEM_EXTRADOC="README.md"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A Ruby wrapper for the GitHub REST API v3"
-HOMEPAGE="https://github.com/peter-murach/github"
-SRC_URI="https://github.com/peter-murach/github/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-RUBY_S="github-${PV}"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE=""
-
-ruby_add_rdepend "
- >=dev-ruby/addressable-2.4 =dev-ruby/addressable-2.4*
- >=dev-ruby/descendants_tracker-0.0.4 =dev-ruby/descendants_tracker-0.0*
- >=dev-ruby/faraday-0.8 <dev-ruby/faraday-0.10
- >=dev-ruby/hashie-3.4
- >=dev-ruby/mime-types-1.16:* <dev-ruby/mime-types-3:*
- =dev-ruby/oauth2-1*"
-
-ruby_add_bdepend "test? ( >=dev-ruby/rspec-2.14 dev-ruby/webmock:2 dev-ruby/vcr:3 )"
diff --git a/dev-ruby/github_api/github_api-0.18.1.ebuild b/dev-ruby/github_api/github_api-0.18.1.ebuild
deleted file mode 100644
index fd1ba6c6b751..000000000000
--- a/dev-ruby/github_api/github_api-0.18.1.ebuild
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-USE_RUBY="ruby22 ruby23"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec"
-RUBY_FAKEGEM_RECIPE_DOC="rdoc"
-RUBY_FAKEGEM_EXTRADOC="README.md"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A Ruby wrapper for the GitHub REST API v3"
-HOMEPAGE="https://github.com/peter-murach/github"
-SRC_URI="https://github.com/peter-murach/github/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-RUBY_S="github-${PV}"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE=""
-
-ruby_add_rdepend "
- >=dev-ruby/addressable-2.4 =dev-ruby/addressable-2.4*
- >=dev-ruby/descendants_tracker-0.0.4 =dev-ruby/descendants_tracker-0.0*
- >=dev-ruby/faraday-0.8:0
- >=dev-ruby/hashie-3.4
- =dev-ruby/oauth2-1*"
-
-ruby_add_bdepend "test? ( >=dev-ruby/rspec-2.14 dev-ruby/webmock:2 dev-ruby/vcr:3 )"