summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2019-08-11 16:36:20 +0200
committerJeroen Roovers <jer@gentoo.org>2019-08-11 16:38:11 +0200
commitcdd5b1924773d13e40a6c53d3825ab4343de2721 (patch)
tree73ade1878d500552d2620521c32cf1063417d5fa
parentnet-analyzer/wireshark: Add IUSE=minizip (diff)
downloadgentoo-cdd5b1924773d13e40a6c53d3825ab4343de2721.tar.gz
gentoo-cdd5b1924773d13e40a6c53d3825ab4343de2721.tar.bz2
gentoo-cdd5b1924773d13e40a6c53d3825ab4343de2721.zip
dev-util/dialog: Version 1.3.20190808
Package-Manager: Portage-2.3.71, Repoman-2.3.17 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
-rw-r--r--dev-util/dialog/Manifest1
-rw-r--r--dev-util/dialog/dialog-1.3.20190808.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-util/dialog/Manifest b/dev-util/dialog/Manifest
index 9669b277eb96..00b030d9bb5f 100644
--- a/dev-util/dialog/Manifest
+++ b/dev-util/dialog/Manifest
@@ -1,3 +1,4 @@
DIST dialog-1.3-20170131.tgz 507783 BLAKE2B a98c436eabc8d06619bd64a8b1d647a0712630f0f89565253636ef2f38333ca6926177aa0c2001305b0c06fc7a1f576cda87da493183402ef9ec3cdc3fa8be23 SHA512 818b4e9d0d5ee55377b78ccceacf59a78e5e6d6fbc09e24a19e62b4988ff8de32f3364132b9ee88c86e126114eda45c82d86397d5f26fae81a6bda91be979786
DIST dialog-1.3-20190724.tar.gz 534551 BLAKE2B 184865abfc98a509fbb2746e8476433c53b08157a53b9786066d7c48c94f3c2e50785c3546a963516f66af382903a33778188d0bfca85ef1f513165157c18196 SHA512 85dbec30bbd5bf5f3e40c8cf2af54236050fe3f96ca66c22d21e0447c2b851d7529b3d155d76b946e9360262959a44bf436b7f7fcf49040b38cc3f6c106c4b81
DIST dialog-1.3-20190728.tar.gz 534764 BLAKE2B c38df2a2a71036a60c08b2f9caa0cb0b6be9f07ed0137d592ed48c6f3e57a0d24760ff85df44f0fdb4cc690b47c6a206f6eaf84a7ea7e71366424dedb7a9e1d6 SHA512 e539f9691fbca289192deec87439b9d6a463b875b24082f6684c2a1c7f7b46bed1ba29a5380dd93dadd800a99bc7c60c9d065d7230bf21dcfbb8f361d7d15de6
+DIST dialog-1.3-20190808.tar.gz 537376 BLAKE2B 38c849ef12ae6c5fc703fe5f8d172c92ba9c6d498e163d622b5dfc7c638a7058fbca79ecfbf1f3e4f274fd53c6cce0d4ef0f67fc5efb8dc16b451064d609e214 SHA512 780cecaf68616723242426f9e78c772f81ec63f0761f67061c4fa06510ba9ca229c921ee15443b63c1581726751f79bf3e6d3b6b8148bbbb3a986043b6b82f86
diff --git a/dev-util/dialog/dialog-1.3.20190808.ebuild b/dev-util/dialog/dialog-1.3.20190808.ebuild
new file mode 100644
index 000000000000..021642f25719
--- /dev/null
+++ b/dev-util/dialog/dialog-1.3.20190808.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils multilib versionator
+
+DIA_P="${PN}-$(replace_version_separator 2 '-')"
+DESCRIPTION="tool to display dialog boxes from a shell"
+HOMEPAGE="https://invisible-island.net/dialog/"
+SRC_URI="https://dev.gentoo.org/~jer/${DIA_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0/15"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="examples minimal nls static-libs unicode"
+
+RDEPEND="
+ >=sys-libs/ncurses-5.2-r5:=[unicode?]
+"
+DEPEND="
+ ${RDEPEND}
+ nls? ( sys-devel/gettext )
+ !minimal? ( sys-devel/libtool )
+ !<=sys-freebsd/freebsd-contrib-8.9999
+"
+S=${WORKDIR}/${DIA_P}
+
+src_prepare() {
+ default
+ sed -i -e '/LIB_CREATE=/s:${CC}:& ${LDFLAGS}:g' configure || die
+ sed -i '/$(LIBTOOL_COMPILE)/s:$: $(LIBTOOL_OPTS):' makefile.in || die
+}
+
+src_configure() {
+ econf \
+ --disable-rpath-hack \
+ $(use_enable nls) \
+ $(use_with !minimal libtool) \
+ --with-libtool-opts=$(usex static-libs '' '-shared') \
+ --with-ncurses$(usex unicode w '')
+}
+
+src_install() {
+ use minimal && default || emake DESTDIR="${D}" install-full
+
+ use examples && dodoc -r samples
+
+ dodoc CHANGES README
+
+ prune_libtool_files
+}