summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Stakenvicius <axs@gentoo.org>2019-03-07 12:16:51 -0500
committerIan Stakenvicius <axs@gentoo.org>2019-03-07 12:37:45 -0500
commitce0f064025bf0d46de8c07f3372f32569a4e80b2 (patch)
treeb020ada5cce76470bed13ea3fb3308d9325dfb81
parentsys-cluster/torque: fix documentation URLs in postinst message (diff)
downloadgentoo-ce0f064025bf0d46de8c07f3372f32569a4e80b2.tar.gz
gentoo-ce0f064025bf0d46de8c07f3372f32569a4e80b2.tar.bz2
gentoo-ce0f064025bf0d46de8c07f3372f32569a4e80b2.zip
sys-cluster/torque: bump to 6.0.4
Source tarball is from latest 6.0 github commit, snapshot from 2018-08-29 Signed-off-by: Ian Stakenvicius <axs@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
-rw-r--r--sys-cluster/torque/Manifest2
-rw-r--r--sys-cluster/torque/torque-6.0.4.ebuild (renamed from sys-cluster/torque/torque-6.0.3.ebuild)18
2 files changed, 12 insertions, 8 deletions
diff --git a/sys-cluster/torque/Manifest b/sys-cluster/torque/Manifest
index 7126d8424438..14f7f3010123 100644
--- a/sys-cluster/torque/Manifest
+++ b/sys-cluster/torque/Manifest
@@ -1,3 +1,3 @@
DIST torque-4.1.7.tar.gz 6218108 BLAKE2B 6c1ad0f1bb3f364603ad7f498999bd910491910fa5632b9f6b82e08b3afb8c54e8775c38bc8e5c959aa99d0647c54c7c348cd07bcbe11add8bfab5f3f06a4c80 SHA512 5a085c0a7b205fed075bff4599db90ca5c4bb5f22d87d76fd56539d5cc1935bb8eeffcd4d18ba84401bd4ca128718070b69c8b91ab6814a4638622ba351654e6
DIST torque-4.2.10-gh-20150517.tar.gz 5836286 BLAKE2B 7108f1adcb6f674526b7db97df4ebcee04ae5c818d4f35ed1230a4e72e52ec0bc3b44e17334a143b21bcd3acccefc3927eca4f98d54d37745c8bb46a75e07045 SHA512 600bb5389b6a4161732b7aa82627f1ebeae238d7091aa2e223d9a14c44bf4668662f664b976f62ba3f1d8a366f90fb6058a8c904e20c26432dccd6abcd9c57fa
-DIST torque-6.0.3-1485300822_19e79ad.tar.gz 41660338 BLAKE2B 5e6c2e4bfffbe96d3a3e441f4c4420b4cb81a882bc498c4bf9474cf15a6808234f444183876a5ccfd46b6a9e4113d404cf72359ab3166146c3040854485f807d SHA512 40531f2e7732a11ffc224c536f61adc48ce5699a7caebb8aa1fbe7536b5ca4ed66c8436420bc918f7538ef980818141888aa26390a5a2c8185c8cc57373a0ac1
+DIST torque-6.0.4-gh-20170829.tar.gz 6182495 BLAKE2B f9156ae4ffe388a7f3fa0df142e5f2d48c16fd7b8c148a3a80cd1c977eb0c1ef4a455da275f993100867be043422526ed05c53734e707851083d6d23ee1a2cc4 SHA512 8f1101adb89e06617de501f7956e126633b78b495baeb7980d3c534d34537cc604a3cf0a7c23c48eb2554b26cc13672b0e00c75d0f722d63ac4d42d57388ed94
diff --git a/sys-cluster/torque/torque-6.0.3.ebuild b/sys-cluster/torque/torque-6.0.4.ebuild
index 755081486523..42f1f078421e 100644
--- a/sys-cluster/torque/torque-6.0.3.ebuild
+++ b/sys-cluster/torque/torque-6.0.4.ebuild
@@ -1,14 +1,13 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
-inherit flag-o-matic eutils linux-info
+inherit autotools flag-o-matic linux-info
DESCRIPTION="Resource manager and queuing system based on OpenPBS"
HOMEPAGE="http://www.adaptivecomputing.com/products/open-source/torque"
-DISTFILEHASH="1485300822_19e79ad"
-SRC_URI="http://wpfilebase.s3.amazonaws.com/torque/${P}-${DISTFILEHASH}.tar.gz"
+SRC_URI="https://github.com/adaptivecomputing/torque/archive/6a0b37f85c7d644e9217cbab1542792d646f59a6.tar.gz -> ${P}-gh-20170829.tar.gz"
LICENSE="torque-2.5"
SLOT="0"
@@ -47,7 +46,11 @@ RDEPEND="${DEPEND_COMMON}
# by the configure.ac and Makefile.am are missing.
# http://www.supercluster.org/pipermail/torquedev/2014-October/004773.html
-S="${WORKDIR}"/${P}-${DISTFILEHASH}
+S="${WORKDIR}"/${PN}-6a0b37f85c7d644e9217cbab1542792d646f59a6
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-6.0.3-fix-emptystring-comparison.patch
+)
pkg_setup() {
PBS_SERVER_HOME="${PBS_SERVER_HOME:-/var/spool/${PN}}"
@@ -81,10 +84,11 @@ pkg_setup() {
}
src_prepare() {
- epatch "${FILESDIR}"/${P}-fix-emptystring-comparison.patch
+ default
# We install to a valid location, no need to muck with ld.so.conf
# --without-loadlibfile is supposed to do this for us...
sed -i '/mk_default_ld_lib_file || return 1/d' buildutils/pbs_mkdirs.in || die
+ eautoreconf
}
src_configure() {
@@ -165,7 +169,7 @@ pkg_preinst() {
}
pkg_postinst() {
- if [[ -z "${REPLACING_VERSIONS}" ]] ; then
+ if [[ -z "${REPLACING_VERSIONS}" ]] ; then
elog "If this is the first time torque has been installed, then you are not"
elog "ready to start the server. Please refer to the documentation located at:"
elog "http://docs.adaptivecomputing.com/torque/${PN//./-}/adminGuide/help.htm#topics/torque/1-installConfig/initializeConfigOnServer.htm"