summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-01-02 14:34:30 +0100
committerMichał Górny <mgorny@gentoo.org>2018-01-02 15:57:30 +0100
commitd1ab0801974c53383d952a07b81b36019a981720 (patch)
treec6b5c3779bd554e96d6fcd9df4988b005f161ad2
parentsys-block/open-iscsi: Bump to v2.0.875 (diff)
downloadgentoo-d1ab0801974c53383d952a07b81b36019a981720.tar.gz
gentoo-d1ab0801974c53383d952a07b81b36019a981720.tar.bz2
gentoo-d1ab0801974c53383d952a07b81b36019a981720.zip
dev-python/Babel: Clean old up
-rw-r--r--dev-python/Babel/Babel-2.1.1.ebuild49
-rw-r--r--dev-python/Babel/Babel-2.3.4.ebuild52
-rw-r--r--dev-python/Babel/Babel-2.4.0.ebuild48
-rw-r--r--dev-python/Babel/Manifest3
-rw-r--r--dev-python/Babel/files/2.3-Fix-the-way-local-time-is-constructed-in-tests.patch30
5 files changed, 0 insertions, 182 deletions
diff --git a/dev-python/Babel/Babel-2.1.1.ebuild b/dev-python/Babel/Babel-2.1.1.ebuild
deleted file mode 100644
index 8d2b76ef7aba..000000000000
--- a/dev-python/Babel/Babel-2.1.1.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="A collection of tools for internationalizing Python applications"
-HOMEPAGE="http://babel.edgewall.org/ https://pypi.python.org/pypi/Babel"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="doc test"
-
-RDEPEND="dev-python/pytz[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]"
-DEPEND="${DEPEND}
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( >=dev-python/pytest-2.3.5[${PYTHON_USEDEP}] )"
-
-python_prepare_all() {
- # Make the tests use implementation-specific datadir,
- # because they try to write in it.
- sed -e '/datadir =/s:os\.path\.dirname(__file__):os.environ["BUILD_DIR"]:' \
- -i tests/messages/test_frontend.py || die
- sed -e '/^intersphinx_mapping/,+3d' -i docs/conf.py || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- # Create implementation-specific datadir for tests.
- cp -R -l tests/messages/data "${BUILD_DIR}"/ || die
- export BUILD_DIR
- py.test || die
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/Babel/Babel-2.3.4.ebuild b/dev-python/Babel/Babel-2.3.4.ebuild
deleted file mode 100644
index c333bf32f4e1..000000000000
--- a/dev-python/Babel/Babel-2.3.4.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy{,3} )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="A collection of tools for internationalizing Python applications"
-HOMEPAGE="http://babel.edgewall.org/ https://pypi.python.org/pypi/Babel"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="doc test"
-
-RDEPEND="dev-python/pytz[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]"
-DEPEND="${DEPEND}
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( >=dev-python/pytest-2.3.5[${PYTHON_USEDEP}] )"
-
-PATCHES=(
- "${FILESDIR}"/2.3-Fix-the-way-local-time-is-constructed-in-tests.patch
-)
-
-python_prepare_all() {
- # Make the tests use implementation-specific datadir,
- # because they try to write in it.
- sed -e '/datadir =/s:os\.path\.dirname(__file__):os.environ["BUILD_DIR"]:' \
- -i tests/messages/test_frontend.py || die
- sed -e '/^intersphinx_mapping/,+3d' -i docs/conf.py || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- # Create implementation-specific datadir for tests.
- cp -R -l tests/messages/data "${BUILD_DIR}"/ || die
- py.test || die
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/Babel/Babel-2.4.0.ebuild b/dev-python/Babel/Babel-2.4.0.ebuild
deleted file mode 100644
index 9ec087d4bd7e..000000000000
--- a/dev-python/Babel/Babel-2.4.0.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy{,3} )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="Collection of tools for internationalizing Python applications"
-HOMEPAGE="http://babel.edgewall.org/ https://pypi.python.org/pypi/Babel"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="doc test"
-
-RDEPEND="dev-python/pytz[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]"
-DEPEND="${DEPEND}
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
-
-python_prepare_all() {
- # Make the tests use implementation-specific datadir,
- # because they try to write in it.
- sed -e '/datadir =/s:os\.path\.dirname(__file__):os.environ["BUILD_DIR"]:' \
- -i tests/messages/test_frontend.py || die
- sed -e '/^intersphinx_mapping/,+3d' -i docs/conf.py || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- # Create implementation-specific datadir for tests.
- cp -R -l tests/messages/data "${BUILD_DIR}"/ || die
- py.test || die
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/Babel/Manifest b/dev-python/Babel/Manifest
index 6ac52401f2a4..311dc91cc7ce 100644
--- a/dev-python/Babel/Manifest
+++ b/dev-python/Babel/Manifest
@@ -1,4 +1 @@
-DIST Babel-2.1.1.tar.gz 3437647 BLAKE2B 0007a2225e99e5643d36527d3b84f330df5e9010a4ef8e920da90bce7389a0504fc889fe6e149e756f51db2ebd77eff04c7e5c6295e01f4225bfef9d6e1de790 SHA512 ec7ebb8648101588eecc72913adc45c0593ed6ee5f10874edcd4b932959f9552edcecc8e2ec966dae6ef5e8adb23341f1a4f87ea2d9e6cbba57a9b8b0a352a94
-DIST Babel-2.3.4.tar.gz 6866920 BLAKE2B 2f4b5d33364e20aef2ef47fe606dd0d531fc00ea80556584d3493c4b5af497a096c45c79683405a878a64c119730789f51ddcb993ee75e403f0097878b95871a SHA512 1fdba01946e7a8ebe3fef23843e23707cd060b0a179d775e29f938318d824e8779df2852fb8bbd18f61fc47de33af5d988c509dc67f54ea4cb3a4a66767869a5
-DIST Babel-2.4.0.tar.gz 6607513 BLAKE2B 2936a0eb1ea0ecae827681f1a86e3fd66c4952c4563b1b5e01c81695a233abe59c2b63c4c2aa6c0e71934f004aaea459ad0ecee73aab0780c47d7d41b2ee00db SHA512 4e1341144dfb319c172a446facc47204c9b9f49972c8646b62e082975d8ec41c35e503e610d7114ef5346a5c073e87ed8d40a65a60d9540fb7ca947681cc0beb
DIST Babel-2.5.0.tar.gz 6612353 BLAKE2B 85268f0226f1db019fb906da0dfbbc6b6aa199ab491e9d767c932fb5ca77cb6d86328ebaa9c6eb61fb8d28c8e566babd435cdcee9b900c3c680d0dfb49c2bcac SHA512 b24b74121695e0068fb28a6294d4b5b2065e94dcd62ca0d70c8fde3a00cb5ff111480505594460989c6f67a75935f55e153b1b493f917317d2c5ee0f0d7921fc
diff --git a/dev-python/Babel/files/2.3-Fix-the-way-local-time-is-constructed-in-tests.patch b/dev-python/Babel/files/2.3-Fix-the-way-local-time-is-constructed-in-tests.patch
deleted file mode 100644
index fdfb31d7c62a..000000000000
--- a/dev-python/Babel/files/2.3-Fix-the-way-local-time-is-constructed-in-tests.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-From 476515c2418039e471656f47efbfc43e5230c1fd Mon Sep 17 00:00:00 2001
-From: Isaac Jurado <diptongo@gmail.com>
-Date: Sun, 29 May 2016 10:50:42 +0200
-Subject: [PATCH] Fix the way local time is constructed in tests
-
-In summer time zones, the test for "get_timezone_name" failed because the
-construct used to obtain a local time did not deal properly with DST offsets.
-As recommended by pytz, it is better to convert to local time from UTC.
----
- tests/test_dates.py | 3 ++-
- 1 file changed, 2 insertions(+), 1 deletion(-)
-
-diff --git a/tests/test_dates.py b/tests/test_dates.py
-index 3bb9e8b..b0d093e 100644
---- a/tests/test_dates.py
-+++ b/tests/test_dates.py
-@@ -624,8 +624,9 @@ def test_get_timezone_name():
- assert dates.get_timezone_name(tz, locale='en', width='long',
- zone_variant='daylight') == u'Pacific Daylight Time'
-
-+ localnow = datetime.utcnow().replace(tzinfo=timezone('UTC')).astimezone(dates.LOCALTZ)
- assert (dates.get_timezone_name(None, locale='en_US') ==
-- dates.get_timezone_name(datetime.now().replace(tzinfo=dates.LOCALTZ), locale='en_US'))
-+ dates.get_timezone_name(localnow, locale='en_US'))
-
- assert (dates.get_timezone_name('Europe/Berlin', locale='en_US') == "Central European Time")
-
---
-2.13.0
-