summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2019-01-17 21:16:34 +0200
committerMart Raudsepp <leio@gentoo.org>2019-01-17 21:35:37 +0200
commitd2e4db289aa5671d58a414a972faeafa5d507b0e (patch)
treecb96c228298ed02312a11a9e5ab055ab4015025b
parentdev-java/java-sdk-docs-11.0.2: bump (diff)
downloadgentoo-d2e4db289aa5671d58a414a972faeafa5d507b0e.tar.gz
gentoo-d2e4db289aa5671d58a414a972faeafa5d507b0e.tar.bz2
gentoo-d2e4db289aa5671d58a414a972faeafa5d507b0e.zip
net-libs/glib-networking: bump to 2.58.0 - works better with gnutls-3.6
2.58.0 (and maybe 2.56.x) is enough to have a working TLS 1.3 when gnutls is upgraded to 3.6. glib-networking-2.59.1 just makes test suite work for that - we comment out those tests for 2.58.0 for now instead. Closes: https://bugs.gentoo.org/675252 Closes: https://bugs.gentoo.org/673448 Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
-rw-r--r--net-libs/glib-networking/Manifest1
-rw-r--r--net-libs/glib-networking/files/2.58.0-disable-failing-tests.patch36
-rw-r--r--net-libs/glib-networking/glib-networking-2.58.0.ebuild75
3 files changed, 112 insertions, 0 deletions
diff --git a/net-libs/glib-networking/Manifest b/net-libs/glib-networking/Manifest
index 44c5644f139c..a5993fb07b39 100644
--- a/net-libs/glib-networking/Manifest
+++ b/net-libs/glib-networking/Manifest
@@ -1,2 +1,3 @@
DIST glib-networking-2.50.0.tar.xz 435380 BLAKE2B 02eea0692cf20c9b1df8efc7e65eb144675fa307851450d461a73df6ccd55cb2ad4e8db5790ca8b0a38a14e30391e583dada30e858154e7c5b7fa0970658410a SHA512 a1e9d28a546f83d461057f088ca2467a32be110f444c8ede1cbfeb20244637d8d5fb5b5b0ee4485feb517beebc3536671442bbfdd3ba01663b52e6da138bd7fe
DIST glib-networking-2.54.1.tar.xz 441232 BLAKE2B 4697ac5fe248d12839d2a3c1340e2e699fa2ea65a9b5d741c50d069c904e82eb23feb89d648bc127959d9ac15e18d3a4cd2bd8b08202d48d33937affb9df13c9 SHA512 8356d835914e33df43f4f2bb6a915ddcd48dd0565e4d5bc1f1d692e9c3124ee4421b99f87f2586f74e9fed24ef7421159f3242fd1eb7bd74950bd25e860896ec
+DIST glib-networking-2.58.0.tar.xz 172632 BLAKE2B 2b1e478ecac7ffb25f0d4e319fc71f7a0c6d9bd4181a5e8abb310d11774491312b0ff1c81b9d8b383ae0b236ece89253d6bd222740199d816c94ea557b4e3511 SHA512 d9cfd97ef9905eceb1f807a7d18c648fcf148214bf3fc55c718c5bcd6fb0afc429ab5b7bf72e83cf959d5ce7f145ce17952c1288d4225cc99d3c6ad66e4494ff
diff --git a/net-libs/glib-networking/files/2.58.0-disable-failing-tests.patch b/net-libs/glib-networking/files/2.58.0-disable-failing-tests.patch
new file mode 100644
index 000000000000..c3802392e3b5
--- /dev/null
+++ b/net-libs/glib-networking/files/2.58.0-disable-failing-tests.patch
@@ -0,0 +1,36 @@
+From 7fd8c24182ea054d6d890b6f6325e63458a10392 Mon Sep 17 00:00:00 2001
+From: Mart Raudsepp <leio@gentoo.org>
+Date: Thu, 17 Jan 2019 21:03:06 +0200
+Subject: [PATCH] tests: Disable test that fails with gnutls-3.6 (or in
+ general)
+
+Tests for TLS 1.3 are still problematic on 2.58.x releases; should
+be better once 2.60 comes out, but the changes are still being worked
+on and would cause regressions for real world programs right now if
+backported.
+---
+ tls/tests/connection.c | 4 ----
+ 1 file changed, 4 deletions(-)
+
+diff --git a/tls/tests/connection.c b/tls/tests/connection.c
+index 6087efc..accca78 100644
+--- a/tls/tests/connection.c
++++ b/tls/tests/connection.c
+@@ -2017,14 +2017,10 @@ main (int argc,
+ setup_connection, test_client_auth_connection, teardown_connection);
+ g_test_add ("/tls/connection/client-auth-rehandshake", TestConnection, NULL,
+ setup_connection, test_client_auth_rehandshake, teardown_connection);
+- g_test_add ("/tls/connection/client-auth-failure", TestConnection, NULL,
+- setup_connection, test_client_auth_failure, teardown_connection);
+ g_test_add ("/tls/connection/client-auth-fail-missing-client-private-key", TestConnection, NULL,
+ setup_connection, test_client_auth_fail_missing_client_private_key, teardown_connection);
+ g_test_add ("/tls/connection/client-auth-request-cert", TestConnection, NULL,
+ setup_connection, test_client_auth_request_cert, teardown_connection);
+- g_test_add ("/tls/connection/client-auth-request-fail", TestConnection, NULL,
+- setup_connection, test_client_auth_request_fail, teardown_connection);
+ g_test_add ("/tls/connection/no-database", TestConnection, NULL,
+ setup_connection, test_connection_no_database, teardown_connection);
+ g_test_add ("/tls/connection/failed", TestConnection, NULL,
+--
+2.17.0
+
diff --git a/net-libs/glib-networking/glib-networking-2.58.0.ebuild b/net-libs/glib-networking/glib-networking-2.58.0.ebuild
new file mode 100644
index 000000000000..0bb5dd626f75
--- /dev/null
+++ b/net-libs/glib-networking/glib-networking-2.58.0.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome.org gnome2-utils meson multilib-minimal xdg
+
+DESCRIPTION="Network-related giomodules for glib"
+HOMEPAGE="https://git.gnome.org/browse/glib-networking/"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+IUSE="+gnome +libproxy +ssl test"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+RDEPEND="
+ >=dev-libs/glib-2.55.1:2[${MULTILIB_USEDEP}]
+ libproxy? ( >=net-libs/libproxy-0.4.11-r1:=[${MULTILIB_USEDEP}] )
+ >=net-libs/gnutls-3:=[${MULTILIB_USEDEP}]
+ ssl? ( app-misc/ca-certificates )
+ gnome? ( gnome-base/gsettings-desktop-schemas )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/meson-0.46
+ >=sys-devel/gettext-0.19.8
+ >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]
+ test? ( sys-apps/dbus )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PV}-disable-failing-tests.patch # shouldn't be needed with 2.60
+)
+
+multilib_src_configure() {
+ local emesonargs=(
+ $(meson_use libproxy libproxy_support)
+ $(meson_use gnome gnome_proxy_support)
+ -Dpkcs11_support=false # deprecated, functionality should be available without it; removed in next version
+ -Dinstalled_tests=false
+ -Dstatic_modules=false
+ )
+ meson_src_configure
+}
+
+multilib_src_compile() {
+ meson_src_compile
+}
+
+multilib_src_install() {
+ meson_src_install
+}
+
+multilib_src_test() {
+ dbus-run-session meson test -C "${BUILD_DIR}" || die 'tests failed'
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ multilib_pkg_postinst() {
+ gnome2_giomodule_cache_update \
+ || die "Update GIO modules cache failed (for ${ABI})"
+ }
+ multilib_foreach_abi multilib_pkg_postinst
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+
+ multilib_pkg_postrm() {
+ gnome2_giomodule_cache_update \
+ || die "Update GIO modules cache failed (for ${ABI})"
+ }
+ multilib_foreach_abi multilib_pkg_postrm
+}