summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-09-20 11:32:34 +0200
committerJustin Lecher <jlec@gentoo.org>2015-09-20 11:33:45 +0200
commitd4d4b1273a1fa3050405cb778657d391759dff85 (patch)
treea95b6bfac9dc6883ccf8362137536a8de4d7f6f9
parentdev-python/testfixtures: Version Bump (diff)
downloadgentoo-d4d4b1273a1fa3050405cb778657d391759dff85.tar.gz
gentoo-d4d4b1273a1fa3050405cb778657d391759dff85.tar.bz2
gentoo-d4d4b1273a1fa3050405cb778657d391759dff85.zip
dev-python/autopep8: Version Bump
Package-Manager: portage-2.2.20.1 Signed-off-by: Justin Lecher <jlec@gentoo.org>
-rw-r--r--dev-python/autopep8/Manifest1
-rw-r--r--dev-python/autopep8/autopep8-1.2.1.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/autopep8/Manifest b/dev-python/autopep8/Manifest
index ba2b36cc6be1..6c2ddbd05d1a 100644
--- a/dev-python/autopep8/Manifest
+++ b/dev-python/autopep8/Manifest
@@ -1,4 +1,5 @@
DIST autopep8-1.0.4.tar.gz 121476 SHA256 58883a80d501f6f5d97859f100414c6b6f6131fcfc08bd88364c2ecb37a55153 SHA512 53e902dcdd654b9d67d9a31a2343503b754bec78630a7fd8d229843c53eb27d11c32fd6a4829714ac4d7cbee59b055d12e60453ae4ee01cb6131bf9c5045426f WHIRLPOOL 44748dfce6202e1e82c468862e4505500c939ee88eb474392767e606c537a66736f2788c0b6573db37b7c207f3f4608b2a6ecb0fb231bb8c3c090040d17f0642
DIST autopep8-1.1.1.tar.gz 123488 SHA256 6cdddca3ba69ecf68efefc00e50def2c6939029af3fab637fd797db76e64d3c0 SHA512 79301c1a6f5696daf29c3ac07d63c83c81b3c750b254ffd1d410dc5bc0711fda0dd7438ee062c60d4b69f5475518e959e963ac623851851955115d6b4a99c429 WHIRLPOOL 51be8fe86afcdd186bd4239b634a1919f671b9da07e9341c23d50fdc773d972753f79fb74e144cb1080dc20230a8e7eab5b9312b05452018e504ad2078176196
DIST autopep8-1.1.tar.gz 123305 SHA256 bf9e821b927169986dd5bbed20a3144afd7c4ddbb841e01d1deb09fd1121e7fa SHA512 6d82ae0ca0a20af2b5aeb467ec36ff0c1e76b45e72a712702e7002312915533c9c380c978fbd5787889a0b3a194b736b0bd830f1b61e302ecea95c968a7ac370 WHIRLPOOL 562bd3d27f90e7d7410ccd391c7245e87dd20ac165ed1153ccbc1500ccb90a9a83790028970dd74c49850d5870fab2c4c500c37ca06b3fd3f12e842af1f4ec31
+DIST autopep8-1.2.1.tar.gz 105142 SHA256 d0a7cdc397e46be0d91a968acb3f561cc1b9244f5df94a2514cf32acfc8a2e94 SHA512 e19583cae0ba1c616192fadff60af591e8b43482ff62890c65c727e219378966306898d145f0d5173a81ff0043e93f8e01e99088d35c6555e41ce542b1f1ca6b WHIRLPOOL 0b96d28baa687a20d60e5cc4f7be56fd99302c0d8200470ccbe5b3ec8cc800ee2525cabc38b38ceadbc85ab53758698c76ed5379548cd418bb6bf0db94f50f5a
DIST autopep8-1.2.tar.gz 155985 SHA256 dbd7015e55ebaa964fbd7c022fe75a5d280e6652be99aea86634eb4b68424752 SHA512 9f9cacbdc1cec4b4fb968d50600895ea411047a528c2a95c6b0cbfb437332eb4b793b190e591c7f36cb69ae4357294b47e7356384e880bd11c114436c112ec82 WHIRLPOOL 8a82a2f9ff5f932170be196721ec23f2e12a53c5182f0c82b2c71a640b6f86c6ba50c234dd08d2f6eae55dc08a1c29f26fc7ae1e10e50e007b176c2b312be956
diff --git a/dev-python/autopep8/autopep8-1.2.1.ebuild b/dev-python/autopep8/autopep8-1.2.1.ebuild
new file mode 100644
index 000000000000..60c3f6c37b88
--- /dev/null
+++ b/dev-python/autopep8/autopep8-1.2.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy3 )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Automatically formats Python code to conform to the PEP 8 style guide"
+HOMEPAGE="https://github.com/hhatto/autopep8 https://pypi.python.org/pypi/autopep8"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/pep8-1.5.7[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${DEPEND}
+ test? ( >=dev-python/pydiff-0.1.2[${PYTHON_USEDEP}] )"
+
+# https://github.com/hhatto/autopep8/issues/217
+RESTRICT=test
+
+python_prepare_all() {
+ # Prevent UnicodeDecodeError with LANG=C
+ sed -e "/é/d" -i MANIFEST.in || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ esetup.py test
+ # from the travis.yml
+ "${PYTHON}" test/test_autopep8.py || die
+ "${PYTHON}" test/acid.py -aaa --experimental test/example.py || die
+ "${PYTHON}" test/acid.py -aaa --experimental test/example_with_reduce.py || die
+ "${PYTHON}" test/acid.py -aaa --compare-bytecode --experimental test/example.py die
+ "${PYTHON}" test/acid.py --aggressive --line-range 550 610 test/inspect_example.py || die
+ "${PYTHON}" test/acid.py --line-range 289 925 test/vectors_example.py || die
+ "${PYTHON}" test/test_suite.py || die
+}
+
+pkg_postinst() {
+ ewarn "Since this version of autopep depends on >=dev-python/pep8-1.3"
+ ewarn "it is affected by https://github.com/jcrocholl/pep8/issues/45"
+ ewarn "(indentation checks inside triple-quotes)."
+ ewarn "If you do not want to be affected by this, then add the"
+ ewarn "following lines to your local package.mask:"
+ ewarn " >=dev-python/pep8-1.3"
+ ewarn " >=dev-python/autopep8-0.6"
+}