summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2019-11-28 11:55:00 -0800
committerPatrick McLean <chutzpah@gentoo.org>2019-11-28 12:07:27 -0800
commitd6bebf591925dbca9b3afd931d020ecf2e26a57b (patch)
tree9bf5fd3d7fb2884c7f2972109bf502131dae4061
parentx11-libs/libva-intel-driver: Version bump to 2.4.0_pre1 (diff)
downloadgentoo-d6bebf591925dbca9b3afd931d020ecf2e26a57b.tar.gz
gentoo-d6bebf591925dbca9b3afd931d020ecf2e26a57b.tar.bz2
gentoo-d6bebf591925dbca9b3afd931d020ecf2e26a57b.zip
dev-python/msgpack-0.6.2: version bump, add py38 and pypy3
Package-Manager: Portage-2.3.80, Repoman-2.3.19 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
-rw-r--r--dev-python/msgpack/Manifest1
-rw-r--r--dev-python/msgpack/msgpack-0.6.2.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/msgpack/Manifest b/dev-python/msgpack/Manifest
index acb546ae2551..d408b5bb72b2 100644
--- a/dev-python/msgpack/Manifest
+++ b/dev-python/msgpack/Manifest
@@ -1,4 +1,5 @@
DIST msgpack-0.5.6.tar.gz 138292 BLAKE2B 6a3b8472b785d77e142d21464b9e52c55166a8eff56009f63df5daa8cd5b6dbce4406a06ffa8d478cb44dfbdfab2f3b4b29cd11279ea82f67906b97d507f7eda SHA512 bdbd193bd3bd02e78d9c6e8d9d8fa687d13583dff2813bc77c5e6cbbe0d180765da3c9a80d176f9993589e35f548ad04973e3d523d0b6d41ef7916ecd86195aa
DIST msgpack-0.6.1.tar.gz 118812 BLAKE2B 9f5522ae7dc89e286a338bfdd91bd4cacefdf7d075136a2ce5e28896db9a9c6a9ed1fe71fff45aab09f8dd32878fcd996366346daa88d47a31a253dec06e2353 SHA512 1a60da428f4b69df817660f4c4f60b1744de17d2b72352286fb41c6703de1d100853f8701b947fb11fc38f2180a50be4a9d577550fcfb9da6a05fe30ed2af07c
+DIST msgpack-0.6.2.tar.gz 119062 BLAKE2B 6b20a0d31b811ae66e66dbfaacec6f0cf2152b2937423b78f3e6244bfa49c87767788c5ee1db41b9020801b8777a4c15b1fe1853182718adf622bc7e1bff858e SHA512 95b92e3d35e0500dd4256d18bf76e586e57cc66319b4459ac5daef599277a5049177a89ad86e291dbdc4c7a918901a89d9218353ddc4a7d0b399e8a98afef363
DIST msgpack-python-0.4.8.tar.gz 113641 BLAKE2B d22efe13302e28d0701b95b2dc4cf4792f9e045efdf77b31ac5c6170b503c885c265ff63387fe76a1aa67b1624963aa26d76dffb15fc2cb10cfe672b59e71b99 SHA512 59e9c43be6b92e6d10f40999e0902c350137e67a83c43bb15b273eca856a6eb39f24b625b02b40188a9365ce3101f03bfa9aa3dfff56c5c3b551533942183481
DIST msgpack-python-0.5.1.tar.gz 138953 BLAKE2B 1fb7e5be33992808319e1444ff7f84cc13f034e60ce0ef2f72161bd4ccd0cd1ede27382bc1f365f268557c8ffe503fd12de66eb5840e79760d818e7e2f67fdcd SHA512 e5172e20bb25d2e12ba34ad2805ba4ea0776397986e8bf8e26d21353f57a2dba59a9c6669c817e4e91d5801558a50f95d81e02343f8f0292a01ec5d822fba61c
diff --git a/dev-python/msgpack/msgpack-0.6.2.ebuild b/dev-python/msgpack/msgpack-0.6.2.ebuild
new file mode 100644
index 000000000000..f200f36c9166
--- /dev/null
+++ b/dev-python/msgpack/msgpack-0.6.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="MessagePack (de)serializer for Python"
+HOMEPAGE="https://msgpack.org
+ https://github.com/msgpack/msgpack-python/
+ https://pypi.org/project/msgpack/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
+IUSE="+native-extensions test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ native-extensions? (
+ $(python_gen_cond_dep '>=dev-python/cython-0.16[${PYTHON_USEDEP}]' 'python*')
+ )
+ test? ( dev-python/six[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # Remove pre-generated cython files
+ rm msgpack/{_packer,_unpacker,_cmsgpack}.pyx || die
+
+ if ! use native-extensions ; then
+ sed -i -e "/have_cython/s:True:False:" setup.py || die
+ fi
+ distutils-r1_python_prepare_all
+}