summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Koltsov <maksbotan@gentoo.org>2016-12-18 18:31:55 +0300
committerMaxim Koltsov <maksbotan@gentoo.org>2016-12-18 18:31:55 +0300
commitd6f0a17a7b358f26f8070ddaf6c0839076384254 (patch)
treee2303df5c3f174fbc13749e98cb1645ccf268d4e
parentdev-perl/File-Slurper: Bump to 0.9.0 (diff)
parentapp-text/wgetpaste: Add wget SSL support (diff)
downloadgentoo-d6f0a17a7b358f26f8070ddaf6c0839076384254.tar.gz
gentoo-d6f0a17a7b358f26f8070ddaf6c0839076384254.tar.bz2
gentoo-d6f0a17a7b358f26f8070ddaf6c0839076384254.zip
app-text/wgetpaste: merge "Add SSL support"
Pull-Request: https://github.com/gentoo/gentoo/pull/3143
-rw-r--r--app-text/wgetpaste/wgetpaste-2.28-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-text/wgetpaste/wgetpaste-2.28-r1.ebuild b/app-text/wgetpaste/wgetpaste-2.28-r1.ebuild
new file mode 100644
index 000000000000..6c3eff136a97
--- /dev/null
+++ b/app-text/wgetpaste/wgetpaste-2.28-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+
+DESCRIPTION="Command-line interface to various pastebins"
+HOMEPAGE="http://wgetpaste.zlin.dk/"
+SRC_URI="http://wgetpaste.zlin.dk/${P}.tar.bz2"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="+ssl"
+
+DEPEND=""
+RDEPEND="net-misc/wget[ssl?]"
+
+src_prepare() {
+ sed -i -e "s:/etc:\"${EPREFIX}\"/etc:g" wgetpaste || die
+ default
+}
+
+src_install() {
+ dobin ${PN}
+ insinto /usr/share/zsh/site-functions
+ doins _wgetpaste
+}