summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2017-05-28 11:48:49 +0200
committerPacho Ramos <pacho@gentoo.org>2017-05-28 12:17:10 +0200
commitd6f0b6f926fc8c15a5ce5b14565a03d1104572e4 (patch)
treeb7a55bac386e399674cc63d57a8cc9e1fc637ac6
parentapp-forensics/foremost: Uncompress man page before using doman. (diff)
downloadgentoo-d6f0b6f926fc8c15a5ce5b14565a03d1104572e4.tar.gz
gentoo-d6f0b6f926fc8c15a5ce5b14565a03d1104572e4.tar.bz2
gentoo-d6f0b6f926fc8c15a5ce5b14565a03d1104572e4.zip
dev-python/audioread: Support newer python and drop obsolete gstreamer:0.10 dependency.
Package-Manager: Portage-2.3.6, Repoman-2.3.2
-rw-r--r--dev-python/audioread/audioread-1.0.1-r1.ebuild (renamed from dev-python/audioread/audioread-1.0.1.ebuild)15
1 files changed, 7 insertions, 8 deletions
diff --git a/dev-python/audioread/audioread-1.0.1.ebuild b/dev-python/audioread/audioread-1.0.1-r1.ebuild
index 49eaebe577dd..5c8a480f88b7 100644
--- a/dev-python/audioread/audioread-1.0.1.ebuild
+++ b/dev-python/audioread/audioread-1.0.1-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
-PYTHON_COMPAT=( python{2_7,3_4} )
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
inherit distutils-r1
@@ -17,16 +17,15 @@ KEYWORDS="~amd64 ~x86"
IUSE=""
DEPEND=""
-RDEPEND="|| ( dev-python/gst-python:0.10[${PYTHON_USEDEP}] dev-python/pymad media-video/ffmpeg )"
+RDEPEND="|| ( dev-python/pymad media-video/ffmpeg )"
PATCHES=(
"${FILESDIR}/0001-Use-the-print-function-instead-of-the-print-keyword.patch"
)
pkg_postinst() {
- elog "You might need to enable additional USE flags in backends to"
- elog "decode some types of audio files. Priority of backends:"
- elog " * gstreamer"
- elog " * mad"
- elog " * ffmpeg"
+ einfo "You might need to enable additional USE flags in backends to"
+ einfo "decode some types of audio files. Priority of backends:"
+ einfo " * mad"
+ einfo " * ffmpeg"
}