summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Helmert III <jchelmert3@posteo.net>2020-06-06 12:16:58 -0500
committerThomas Deutschmann <whissi@gentoo.org>2020-06-17 23:57:23 +0200
commitd7353b73cff97ab511c027620d57fb44d8b0d661 (patch)
treebf7a1c7eaed6c485da6a7f9f910ef3113b51aa95
parentx11-wm/i3: Drop outdated versions 4.15, 4.16, 4.16.1 (diff)
downloadgentoo-d7353b73cff97ab511c027620d57fb44d8b0d661.tar.gz
gentoo-d7353b73cff97ab511c027620d57fb44d8b0d661.tar.bz2
gentoo-d7353b73cff97ab511c027620d57fb44d8b0d661.zip
x11-wm/i3-gaps: Add 4.18.1 (fixes GCC10 build)
Bug: https://bugs.gentoo.org/711546 Closes: https://bugs.gentoo.org/721274 Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: John Helmert III <jchelmert3@posteo.net> Closes: https://github.com/gentoo/gentoo/pull/16087 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
-rw-r--r--x11-wm/i3-gaps/Manifest1
-rw-r--r--x11-wm/i3-gaps/files/i3-gaps-4.18-musl.patch74
-rw-r--r--x11-wm/i3-gaps/i3-gaps-4.18.1.ebuild87
3 files changed, 162 insertions, 0 deletions
diff --git a/x11-wm/i3-gaps/Manifest b/x11-wm/i3-gaps/Manifest
index 652f73bdb1de..9f7fe3585149 100644
--- a/x11-wm/i3-gaps/Manifest
+++ b/x11-wm/i3-gaps/Manifest
@@ -1,2 +1,3 @@
DIST i3-gaps-4.16.1.tar.gz 3983420 BLAKE2B f0d5a85b06ce33e1cc177af6da29f9cdf42ed754bb767aa9eaa5ab52f3b9f4f688d251f2a16fb222fc8cf5052e79859891c4185b1325b2ef6c1a813aa220468c SHA512 904c2f63c6a35573f13fd216625c1349ac71de70ae8f0440667c9d76048cdaf30a398ab358f2366d5f46502d87e801713b625cb509a05f39dbca1371d2b8d0e9
DIST i3-gaps-4.17.1.tar.gz 3991747 BLAKE2B e5ff8293abf41ffbd15c35590a0594861d7c8b70c0f42886ef7f15fb34b8da57a92cf9bcae76576e7db6db9bacc2356722e5653b1cf35b8446716f8845468b4b SHA512 31e47487f6f662f27b2642925f4ddfc553f1fd075e612d0d2661db723897b12eeae0a2bcefa8a43e7f1d4c15aec2222d3a63e37c8f7e1f9fc96567faa380ebff
+DIST i3-gaps-4.18.1.tar.gz 3999609 BLAKE2B 1a7f0d83831505fb8b75c00efeff276d3a837166029ff6d63dec7aa746a0d9c31245fdcf075f27a43f8c7456f178e30c8c8ddc87e30fbc53b244cf141a41aa34 SHA512 63a37e5920b3945be58e54f86b75523499e6b3a8dd9a05a952118e5609c9bd50fedabe05160eef0ebc377020042508a552f2a32272afcf1c913efcf48ac3e460
diff --git a/x11-wm/i3-gaps/files/i3-gaps-4.18-musl.patch b/x11-wm/i3-gaps/files/i3-gaps-4.18-musl.patch
new file mode 100644
index 000000000000..bf59b32e3f70
--- /dev/null
+++ b/x11-wm/i3-gaps/files/i3-gaps-4.18-musl.patch
@@ -0,0 +1,74 @@
+--- a/i3bar/src/main.c
++++ b/i3bar/src/main.c
+@@ -45,14 +45,20 @@ void debuglog(char *fmt, ...) {
+ *
+ */
+ static char *expand_path(char *path) {
+- static glob_t globbuf;
+- if (glob(path, GLOB_NOCHECK | GLOB_TILDE, NULL, &globbuf) < 0) {
+- ELOG("glob() failed\n");
+- exit(EXIT_FAILURE);
++ char *home, *expanded;
++
++ if (strncmp(path, "~/", 2) == 0) {
++ home = getenv("HOME");
++ if (home != NULL) {
++ /* new length: sum - 1 (omit '~') + 1 (for '\0') */
++ expanded = scalloc(strlen(home)+strlen(path), 1);
++ strcpy(expanded, home);
++ strcat(expanded, path+1);
++ return expanded;
++ }
+ }
+- char *result = sstrdup(globbuf.gl_pathc > 0 ? globbuf.gl_pathv[0] : path);
+- globfree(&globbuf);
+- return result;
++
++ return sstrdup(path);
+ }
+
+ static void print_usage(char *elf_name) {
+--- a/libi3/resolve_tilde.c
++++ b/libi3/resolve_tilde.c
+@@ -19,28 +19,18 @@
+ *
+ */
+ char *resolve_tilde(const char *path) {
+- static glob_t globbuf;
+- char *head, *tail, *result;
++ char *home, *expanded;
+
+- tail = strchr(path, '/');
+- head = sstrndup(path, tail ? (size_t)(tail - path) : strlen(path));
+-
+- int res = glob(head, GLOB_TILDE, NULL, &globbuf);
+- free(head);
+- /* no match, or many wildcard matches are bad */
+- if (res == GLOB_NOMATCH || globbuf.gl_pathc != 1)
+- result = sstrdup(path);
+- else if (res != 0) {
+- err(EXIT_FAILURE, "glob() failed");
+- } else {
+- head = globbuf.gl_pathv[0];
+- result = scalloc(strlen(head) + (tail ? strlen(tail) : 0) + 1, 1);
+- strcpy(result, head);
+- if (tail) {
+- strcat(result, tail);
++ if (strncmp(path, "~/", 2) == 0) {
++ home = getenv("HOME");
++ if (home != NULL) {
++ /* new length: sum - 1 (omit '~') + 1 (for '\0') */
++ expanded = scalloc(strlen(home)+strlen(path), 1);
++ strcpy(expanded, home);
++ strcat(expanded, path+1);
++ return expanded;
+ }
+ }
+- globfree(&globbuf);
+
+- return result;
++ return sstrdup(path);
+ }
+--
+2.27.0
+
diff --git a/x11-wm/i3-gaps/i3-gaps-4.18.1.ebuild b/x11-wm/i3-gaps/i3-gaps-4.18.1.ebuild
new file mode 100644
index 000000000000..760a674fe049
--- /dev/null
+++ b/x11-wm/i3-gaps/i3-gaps-4.18.1.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools out-of-source
+
+DESCRIPTION="i3 fork with gaps and some more features"
+HOMEPAGE="https://github.com/Airblader/i3"
+SRC_URI="https://github.com/Airblader/i3/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE="doc"
+
+DEPEND="
+ dev-libs/glib:2
+ dev-libs/libev
+ dev-libs/libpcre
+ dev-libs/yajl
+ x11-libs/cairo[X,xcb(+)]
+ x11-libs/libxcb[xkb]
+ x11-libs/libxkbcommon[X]
+ x11-libs/pango[X]
+ x11-libs/startup-notification
+ x11-libs/xcb-util
+ x11-libs/xcb-util-cursor
+ x11-libs/xcb-util-keysyms
+ x11-libs/xcb-util-wm
+ x11-libs/xcb-util-xrm
+"
+BDEPEND="
+ app-text/asciidoc
+ app-text/xmlto
+ dev-lang/perl
+ virtual/pkgconfig
+"
+RDEPEND="${DEPEND}
+ dev-lang/perl
+ dev-perl/AnyEvent-I3
+ dev-perl/JSON-XS
+ !x11-wm/i3
+"
+
+S=${WORKDIR}/i3-${PV}
+
+DOCS=( RELEASE-NOTES-$(ver_cut 1-3) )
+
+PATCHES=( "${FILESDIR}/${PN}-$(ver_cut 1-2)-musl.patch" )
+
+src_prepare() {
+ default
+ eautoreconf
+ cat <<- EOF > "${T}"/i3wm
+ #!/bin/sh
+ exec /usr/bin/i3
+ EOF
+}
+
+my_src_configure() {
+ # disable sanitizer: otherwise injects -O0 -g
+ local myeconfargs=(
+ $(use_enable doc docs)
+ --enable-debug=no
+ --enable-mans
+ --disable-sanitizers
+ )
+ econf "${myeconfargs[@]}"
+}
+
+my_src_install_all() {
+ doman "${BUILD_DIR}"/man/*.1
+ einstalldocs
+
+ exeinto /etc/X11/Sessions
+ doexe "${T}"/i3wm
+}
+
+pkg_postinst() {
+ einfo "There are several packages that you may find useful with ${PN} and"
+ einfo "their usage is suggested by the upstream maintainers, namely:"
+ einfo " x11-misc/dmenu"
+ einfo " x11-misc/i3lock"
+ einfo " x11-misc/i3status"
+ einfo "Please refer to their description for additional info."
+}