summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2016-11-04 10:44:51 +0200
committerAlon Bar-Lev <alonbl@gentoo.org>2016-11-04 10:45:31 +0200
commitd9255064b4da1e238ccb36eddb4c2be232ccb303 (patch)
treec0ad393a9935a9c3eb9c311ef32b8ff19d644236
parentkde-frameworks/kcoreaddons: Remove vulnerable version (diff)
downloadgentoo-d9255064b4da1e238ccb36eddb4c2be232ccb303.tar.gz
gentoo-d9255064b4da1e238ccb36eddb4c2be232ccb303.tar.bz2
gentoo-d9255064b4da1e238ccb36eddb4c2be232ccb303.zip
net-libs/gnutls: version bump
Package-Manager: portage-2.3.0
-rw-r--r--net-libs/gnutls/Manifest1
-rw-r--r--net-libs/gnutls/gnutls-3.5.6.ebuild133
2 files changed, 134 insertions, 0 deletions
diff --git a/net-libs/gnutls/Manifest b/net-libs/gnutls/Manifest
index 9271102cc1f4..41939a35e869 100644
--- a/net-libs/gnutls/Manifest
+++ b/net-libs/gnutls/Manifest
@@ -2,3 +2,4 @@ DIST gnutls-3.3.24.tar.xz 6294532 SHA256 5b65fe2a91c8dfa32bedc78acffcb152e5426cd
DIST gnutls-3.3.25.tar.xz 6315372 SHA256 189d6c4e43465d2ec84f2cd66f0ef63657225926f56875e182743cfeef9f1f2e SHA512 6f9074f58250517287d183faac27afcc4318293b24b587b00494d40b6b5dae088fef993b5c2adf6842238adc1f694a747262b50bc602037626579b84401207f6 WHIRLPOOL 3d320378cd8e7330e2b399876bb8739dd35fe2dc1204b0ead561f214676583f2b2c1fa4c5a61b720e3af5c72769e804d9bc36f69f8659eb7a1d6e8a1a7012e2c
DIST gnutls-3.4.16.tar.xz 6677636 SHA256 d99abb1b320771b58c949bab85e4b654dd1e3e9d92e2572204b7dc479d923927 SHA512 4decbb35b47181e47e601fb40d21b9a6d1a5343cb711db63c816226a4a230b3b0b904da05a1e4c4222fc64014beeb7f62762699cad418004602c7b7b6f19112f WHIRLPOOL 75bc453acc49d96540a088fd50fadbeff008b4e534ffc550dbf170a1c9dd80da2d70e3c6ff5cba4b09946db4277aeeb72aa8dd2d69c0f22655fe0529566a351c
DIST gnutls-3.5.5.tar.xz 6974628 SHA256 86994fe7804ee16d2811e366b9bf2f75304f8e470ae0e3716d60ffeedac0e529 SHA512 d3065d62d1d1e3ed7079b108e2d71586a14d465886c623e0ec9d6b012645cd4dbe6760da1502ecf4a6a6efa233114ecfbe09a1c1d94688bd0386d55048f9cbef WHIRLPOOL b029d960937dd3a8ef1a3b9ba270b4003732d53f37246b162190813baab39d60c403d1d68ffe16d24efdabf212435bfa59d8fa58d9ca7e3a6029256ca3efe0a9
+DIST gnutls-3.5.6.tar.xz 7087388 SHA256 6338b715bf31c758606ffa489c7f87ee1beab947114fbd2ffefd73170a8c6b9a SHA512 8bad0f159bb605b732ea695dd6643edbd059364895e607332565dd5896db72fe93bf1fb264c98b59250f022c7dfed5e6cf3a941f1dac59b43ac09450c87c094d WHIRLPOOL ad806fb86be7d7cc8347585bb1de0f13d7f179776430530a09015d215a8bbebd311224aebc2abbdbb037866f2756e5fdfcf04d363cf5366eddfdc5e01671f3d1
diff --git a/net-libs/gnutls/gnutls-3.5.6.ebuild b/net-libs/gnutls/gnutls-3.5.6.ebuild
new file mode 100644
index 000000000000..d0c39fbfc4b7
--- /dev/null
+++ b/net-libs/gnutls/gnutls-3.5.6.ebuild
@@ -0,0 +1,133 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools libtool eutils multilib-minimal versionator
+
+DESCRIPTION="A TLS 1.2 and SSL 3.0 implementation for the GNU project"
+HOMEPAGE="http://www.gnutls.org/"
+SRC_URI="mirror://gnupg/gnutls/v$(get_version_component_range 1-2)/${P}.tar.xz"
+
+LICENSE="GPL-3 LGPL-2.1"
+SLOT="0/30" # libgnutls.so number
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE_LINGUAS=" en cs de fi fr it ms nl pl sv uk vi zh_CN"
+IUSE="+cxx dane doc examples guile idn nls +openssl pkcs11 sslv2 +sslv3 static-libs test +tls-heartbeat +tools zlib ${IUSE_LINGUAS// / linguas_}"
+
+# NOTICE: sys-devel/autogen is required at runtime as we
+# use system libopts
+RDEPEND=">=dev-libs/libtasn1-4.3:=[${MULTILIB_USEDEP}]
+ >=dev-libs/nettle-3.1:=[gmp,${MULTILIB_USEDEP}]
+ >=dev-libs/gmp-5.1.3-r1:=[${MULTILIB_USEDEP}]
+ tools? ( sys-devel/autogen )
+ dane? ( >=net-dns/unbound-1.4.20[${MULTILIB_USEDEP}] )
+ guile? ( >=dev-scheme/guile-1.8:=[networking] )
+ nls? ( >=virtual/libintl-0-r1[${MULTILIB_USEDEP}] )
+ pkcs11? ( >=app-crypt/p11-kit-0.23.1[${MULTILIB_USEDEP}] )
+ zlib? ( >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}] )
+ idn? ( net-dns/libidn[${MULTILIB_USEDEP}] )
+ abi_x86_32? (
+ !<=app-emulation/emul-linux-x86-baselibs-20140508
+ !app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)]
+ )"
+DEPEND="${RDEPEND}
+ >=sys-devel/automake-1.11.6
+ >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]
+ doc? (
+ sys-apps/texinfo
+ dev-util/gtk-doc
+ )
+ nls? ( sys-devel/gettext )
+ test? ( app-misc/datefudge )"
+
+pkg_setup() {
+ # bug#520818
+ export TZ=UTC
+}
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e 's/imagesdir = $(infodir)/imagesdir = $(htmldir)/' \
+ doc/Makefile.am || die
+
+ # force regeneration of autogen-ed files
+ local file
+ for file in $(grep -l AutoGen-ed src/*.c) ; do
+ rm src/$(basename ${file} .c).{c,h} || die
+ done
+
+ # force regeneration of makeinfo files
+ # have no idea why on some system these files are not
+ # accepted as-is, see bug#520818
+ for file in $(grep -l "produced by makeinfo" doc/*.info) ; do
+ rm "${file}" || die
+ done
+
+ eautoreconf
+
+ # Use sane .so versioning on FreeBSD.
+ elibtoolize
+
+ # bug 497472
+ use cxx || epunt_cxx
+}
+
+multilib_src_configure() {
+ LINGUAS="${LINGUAS//en/en@boldquot en@quot}"
+
+ # remove magic of library detection
+ # bug#438222
+ libconf=($("${S}/configure" --help | grep -- '--without-.*-prefix' | sed -e 's/^ *\([^ ]*\) .*/\1/g'))
+
+ # TPM needs to be tested before being enabled
+ # hardware-accell is disabled on OSX because the asm files force
+ # GNU-stack (as doesn't support that) and when that's removed ld
+ # complains about duplicate symbols
+ ECONF_SOURCE=${S} \
+ econf \
+ --disable-valgrind-tests \
+ --without-included-libtasn1 \
+ $(use_enable cxx) \
+ $(use_enable dane libdane) \
+ $(multilib_native_enable manpages) \
+ $(multilib_native_use_enable tools) \
+ $(multilib_native_use_enable doc) \
+ $(multilib_native_use_enable doc gtk-doc) \
+ $(multilib_native_use_enable guile) \
+ $(multilib_native_use_enable test tests) \
+ $(use_enable nls) \
+ $(use_enable openssl openssl-compatibility) \
+ $(use_enable tls-heartbeat heartbeat-support) \
+ $(use_enable sslv2 ssl2-support) \
+ $(use_enable sslv3 ssl3-support) \
+ $(use_enable static-libs static) \
+ $(use_with pkcs11 p11-kit) \
+ $(use_with zlib) \
+ $(use_with idn) \
+ --without-tpm \
+ --with-unbound-root-key-file=/etc/dnssec/root-anchors.txt \
+ "${libconf[@]}" \
+ $([[ ${CHOST} == *-darwin* ]] && echo --disable-hardware-acceleration)
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ prune_libtool_files --all
+
+ dodoc doc/certtool.cfg
+
+ if use doc; then
+ dohtml doc/gnutls.html
+ else
+ rm -fr "${ED}/usr/share/doc/${PF}/html"
+ fi
+
+ if use examples; then
+ docinto examples
+ dodoc doc/examples/*.c
+ fi
+}