summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2016-02-25 05:15:55 +0100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2016-02-25 05:15:55 +0100
commitd94a5a17806f3bb8b6f66d45d5ab06678dff320b (patch)
tree00dcbf1a03561a33dc4a0b506e31a3e837fd8979
parentdev-perl/HTTP-Body: Remove old (diff)
parentapp-text/libabw: Fix build with boost-1.59, bug 575524 (diff)
downloadgentoo-d94a5a17806f3bb8b6f66d45d5ab06678dff320b.tar.gz
gentoo-d94a5a17806f3bb8b6f66d45d5ab06678dff320b.tar.bz2
gentoo-d94a5a17806f3bb8b6f66d45d5ab06678dff320b.zip
Merge remote-tracking branch 'github/pr/917'
-rw-r--r--app-text/libabw/files/libabw-0.1.1-boost-1.59.patch22
-rw-r--r--app-text/libabw/libabw-0.1.1.ebuild1
-rw-r--r--dev-libs/libixion/files/libixion-0.9.1-python-optional.patch42
-rw-r--r--dev-libs/libixion/files/libixion-0.9.1-python-symbol.patch13
-rw-r--r--dev-libs/libixion/libixion-0.9.1-r1.ebuild (renamed from dev-libs/libixion/libixion-0.9.1.ebuild)12
5 files changed, 42 insertions, 48 deletions
diff --git a/app-text/libabw/files/libabw-0.1.1-boost-1.59.patch b/app-text/libabw/files/libabw-0.1.1-boost-1.59.patch
new file mode 100644
index 000000000000..f2e745a44d20
--- /dev/null
+++ b/app-text/libabw/files/libabw-0.1.1-boost-1.59.patch
@@ -0,0 +1,22 @@
+From: David Tardon <dtardon@redhat.com>
+Date: Sun, 30 Aug 2015 06:05:31 +0000 (+0200)
+Subject: fix build with boost 1.59
+X-Git-Url: https://gerrit.libreoffice.org/gitweb?p=libabw.git;a=commitdiff_plain;h=ee2d0729315888d1847587ad556470d2fdc883a7;hp=7ea0b5530cf321cd80231b84421e4c107d1cc479
+
+fix build with boost 1.59
+
+Change-Id: I5645629526a8d9d896e4faeb2c7b9ea88540fd23
+---
+
+diff --git a/src/lib/Makefile.am b/src/lib/Makefile.am
+index 5766f39..d12d8e2 100644
+--- a/src/lib/Makefile.am
++++ b/src/lib/Makefile.am
+@@ -26,6 +26,7 @@ generated_files = \
+ $(top_builddir)/src/lib/tokens.h \
+ $(top_builddir)/src/lib/tokenhash.h
+
++libabw_@ABW_MAJOR_VERSION@_@ABW_MINOR_VERSION@_la_CPPFLAGS = -DBOOST_ERROR_CODE_HEADER_ONLY -DBOOST_SYSTEM_NO_DEPRECATED
+ libabw_@ABW_MAJOR_VERSION@_@ABW_MINOR_VERSION@_la_LIBADD = $(REVENGE_LIBS) $(LIBXML_LIBS) $(ZLIB_LIBS) @LIBABW_WIN32_RESOURCE@
+ libabw_@ABW_MAJOR_VERSION@_@ABW_MINOR_VERSION@_la_DEPENDENCIES = @LIBABW_WIN32_RESOURCE@
+ libabw_@ABW_MAJOR_VERSION@_@ABW_MINOR_VERSION@_la_LDFLAGS = $(version_info) -export-dynamic $(no_undefined)
diff --git a/app-text/libabw/libabw-0.1.1.ebuild b/app-text/libabw/libabw-0.1.1.ebuild
index d51442b28cfc..e11dd9b388d0 100644
--- a/app-text/libabw/libabw-0.1.1.ebuild
+++ b/app-text/libabw/libabw-0.1.1.ebuild
@@ -31,6 +31,7 @@ PATCHES=(
# from git master
"${FILESDIR}/${PN}-0.1.1-dereference-before-null-check.patch"
"${FILESDIR}/${PN}-0.1.1-do-not-let-AbiDocument_parse-throw.patch"
+ "${FILESDIR}/${PN}-0.1.1-boost-1.59.patch"
)
src_configure() {
diff --git a/dev-libs/libixion/files/libixion-0.9.1-python-optional.patch b/dev-libs/libixion/files/libixion-0.9.1-python-optional.patch
index df945abc3928..632fa07e0f6e 100644
--- a/dev-libs/libixion/files/libixion-0.9.1-python-optional.patch
+++ b/dev-libs/libixion/files/libixion-0.9.1-python-optional.patch
@@ -1,21 +1,21 @@
--- a/configure.ac 2016-02-06 17:08:05.505990463 +0100
+++ b/configure.ac 2016-02-06 17:08:42.316530268 +0100
-@@ -15,18 +15,13 @@
+@@ -15,18 +15,22 @@
AC_INIT([libixion], [ixion_version])
AC_CONFIG_HEADERS([config.h])
AM_INIT_AUTOMAKE([1.11 foreign dist-bzip2 dist-xz])
-AM_PATH_PYTHON(2.7.0)
m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([yes])])
--AC_ARG_WITH(hash-container-compat,
--[
-- --with-hash-container-compat use std::hash_foo instead of boost::unordered_foo
--],
--,with_hash_container_compat=no)
--
--AC_ARG_WITH(mdds-include-path,
-- AS_HELP_STRING([--with-mdds-include-path], [specify include path for mdds headers.])
--,)
+ AC_ARG_WITH(hash-container-compat,
+ [
+ --with-hash-container-compat use std::hash_foo instead of boost::unordered_foo
+ ],
+ ,with_hash_container_compat=no)
+
+ AC_ARG_WITH(mdds-include-path,
+ AS_HELP_STRING([--with-mdds-include-path], [specify include path for mdds headers.])
+ ,)
+AC_ARG_ENABLE([python],
+ [AS_HELP_STRING([--disable-python], [Disable python bindings])],
+ [enable_python="$enableval"],
@@ -24,25 +24,7 @@
IXION_API_VERSION=ixion_api_version
IXION_MAJOR_VERSION=ixion_major_version
-@@ -66,23 +61,19 @@
- AC_FUNC_STRTOD
- AC_CHECK_FUNCS([gettimeofday])
-
--CPPFLAGS="$CPPFLAGS -D_REENTRANT -DMDDS_HASH_CONTAINER_BOOST"
-+CPPFLAGS="$CPPFLAGS -D_REENTRANT"
-
--AC_MSG_CHECKING([whether to turn on hash container compatibility])
--if test "z$with_hash_container_compat" = "zno"; then
-- AC_MSG_RESULT([no])
-- BOOST_REQUIRE([1.36])
-- BOOST_UNORDERED
--else
-- AC_MSG_RESULT([yes])
-- DEFINES="$DEFINES -D_IXION_HASH_CONTAINER_COMPAT"
--fi
-+BOOST_REQUIRE([1.36])
-
- # Check for mdds.
+@@ -70,7 +74,11 @@
PKG_CHECK_MODULES([MDDS],[mdds >= 0.12.0])
# Check for python.
@@ -55,7 +37,7 @@
CPPFLAGS="$CPPFLAGS -g -Os -fvisibility=hidden"
-@@ -101,3 +92,10 @@
+@@ -101,3 +109,10 @@
src/libixion/constants.inl
src/python/Makefile])
AC_OUTPUT
diff --git a/dev-libs/libixion/files/libixion-0.9.1-python-symbol.patch b/dev-libs/libixion/files/libixion-0.9.1-python-symbol.patch
deleted file mode 100644
index 1a62bbc9b55b..000000000000
--- a/dev-libs/libixion/files/libixion-0.9.1-python-symbol.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/src/python/Makefile.am b/src/python/Makefile.am
-index 0dfae54..094e0cf 100644
---- a/src/python/Makefile.am
-+++ b/src/python/Makefile.am
-@@ -10,7 +10,7 @@ ixion_la_SOURCES = \
- sheet.hpp \
- sheet.cpp
-
--ixion_la_LDFLAGS = -module -avoid-version -export-symbols-regex initixion
-+ixion_la_LDFLAGS = -module -avoid-version -export-symbols-regex PyInit_ixion
- ixion_la_CPPFLAGS = -I$(top_srcdir)/include $(PYTHON_CFLAGS) $(MDDS_CFLAGS)
- ixion_la_LIBADD = \
- ../libixion/libixion-@IXION_API_VERSION@.la \
diff --git a/dev-libs/libixion/libixion-0.9.1.ebuild b/dev-libs/libixion/libixion-0.9.1-r1.ebuild
index 9c993be33bd9..6dc3c0e382a6 100644
--- a/dev-libs/libixion/libixion-0.9.1.ebuild
+++ b/dev-libs/libixion/libixion-0.9.1-r1.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
EGIT_REPO_URI="https://gitlab.com/ixion/ixion.git"
@@ -17,7 +17,7 @@ HOMEPAGE="https://gitlab.com/ixion/ixion"
[[ ${PV} == 9999 ]] || SRC_URI="http://kohei.us/files/ixion/src/${P}.tar.xz"
LICENSE="MIT"
-SLOT="0/0.10"
+SLOT="0/0.10" # based on SONAME of libixion.so
[[ ${PV} == 9999 ]] || \
KEYWORDS="~amd64 ~arm ~ppc ~x86"
IUSE="python static-libs"
@@ -37,9 +37,11 @@ pkg_setup() {
}
src_prepare() {
- epatch "${FILESDIR}/${PN}-0.9.1-typo.patch" \
- "${FILESDIR}/${PN}-0.9.1-python-optional.patch" \
- "${FILESDIR}/${PN}-0.9.1-python-symbol.patch"
+ eapply_user
+
+ eapply "${FILESDIR}/${PN}-0.9.1-typo.patch" \
+ "${FILESDIR}/${PN}-0.9.1-python-optional.patch"
+
eautoreconf
}