summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-03-15 22:35:37 +0100
committerDavid Seifert <soap@gentoo.org>2020-03-15 22:35:37 +0100
commitda5dd26a142c51e5fa97c316e29302630e432de0 (patch)
treed305ee54a503849fb8da5df0880e77cbae8f2254
parentapp-emulation/wine-staging: Drop old (diff)
downloadgentoo-da5dd26a142c51e5fa97c316e29302630e432de0.tar.gz
gentoo-da5dd26a142c51e5fa97c316e29302630e432de0.tar.bz2
gentoo-da5dd26a142c51e5fa97c316e29302630e432de0.zip
dev-embedded/xa: Fix building with -fno-common
Closes: https://bugs.gentoo.org/710988 Package-Manager: Portage-2.3.94, Repoman-2.3.21 Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--dev-embedded/xa/files/xa-2.3.10-fix-gcc10-fno-common.patch12
-rw-r--r--dev-embedded/xa/xa-2.3.10.ebuild4
2 files changed, 15 insertions, 1 deletions
diff --git a/dev-embedded/xa/files/xa-2.3.10-fix-gcc10-fno-common.patch b/dev-embedded/xa/files/xa-2.3.10-fix-gcc10-fno-common.patch
new file mode 100644
index 000000000000..5b3486433885
--- /dev/null
+++ b/dev-embedded/xa/files/xa-2.3.10-fix-gcc10-fno-common.patch
@@ -0,0 +1,12 @@
+--- a/src/xap.h
++++ b/src/xap.h
+@@ -35,7 +35,7 @@
+ long gm_ppm(void);
+ long ga_ppm(void);
+
+-Datei *filep;
+-char s[MAXLINE];
++extern Datei *filep;
++extern char s[MAXLINE];
+
+ #endif /* __XA65_XAP_H__ */
diff --git a/dev-embedded/xa/xa-2.3.10.ebuild b/dev-embedded/xa/xa-2.3.10.ebuild
index 0b4aabb57139..4c062c20057d 100644
--- a/dev-embedded/xa/xa-2.3.10.ebuild
+++ b/dev-embedded/xa/xa-2.3.10.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -13,6 +13,8 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
+PATCHES=( "${FILESDIR}"/${PN}-2.3.10-fix-gcc10-fno-common.patch )
+
src_compile() {
emake \
CC="$(tc-getCC)" \