summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-01-30 16:41:43 +0100
committerJustin Lecher <jlec@gentoo.org>2016-01-30 16:47:05 +0100
commitda661fc9f247f8b46ab6ec86c92805eb12081cca (patch)
tree56950cfe1dce66819e8140bb0b0a0e06a3e5c0d8
parentdev-python/apsw: revbump to vn. -3.9.2_p1-r1 (diff)
downloadgentoo-da661fc9f247f8b46ab6ec86c92805eb12081cca.tar.gz
gentoo-da661fc9f247f8b46ab6ec86c92805eb12081cca.tar.bz2
gentoo-da661fc9f247f8b46ab6ec86c92805eb12081cca.zip
dev-python/sympy: Better doc building and update virtualx.eclas usage
Package-Manager: portage-2.2.27 Signed-off-by: Justin Lecher <jlec@gentoo.org>
-rw-r--r--dev-python/sympy/sympy-0.7.6.1-r1.ebuild18
-rw-r--r--dev-python/sympy/sympy-0.7.6.1.ebuild17
2 files changed, 24 insertions, 11 deletions
diff --git a/dev-python/sympy/sympy-0.7.6.1-r1.ebuild b/dev-python/sympy/sympy-0.7.6.1-r1.ebuild
index 6a0f6dd2d755..c69a9006e276 100644
--- a/dev-python/sympy/sympy-0.7.6.1-r1.ebuild
+++ b/dev-python/sympy/sympy-0.7.6.1-r1.ebuild
@@ -1,11 +1,10 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
PYTHON_COMPAT=( python{2_7,3_3,3_4} )
-DISTUTILS_ALL_SUBPHASE_IMPLS=( 'python2*' )
inherit distutils-r1 eutils virtualx
@@ -19,7 +18,7 @@ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-macos"
IUSE="doc examples gtk imaging ipython latex mathml opengl pdf png pyglet test texmacs theano"
REQUIRED_USE="${PYTHON_REQUIRED_USE}
- doc? ( python_targets_python2_7 )"
+ doc? ( || ( $(python_gen_useflags 'python2*') ) )"
RDEPEND="
$(python_gen_cond_dep '>=dev-python/pexpect-2.0[${PYTHON_USEDEP}]' python2_7)
@@ -46,6 +45,10 @@ DEPEND="${RDEPEND}
doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
test? ( ${RDEPEND} dev-python/pytest[${PYTHON_USEDEP}] )"
+pkg_setup() {
+ use doc && DISTUTILS_ALL_SUBPHASE_IMPLS=( 'python2*' )
+}
+
python_prepare_all() {
epatch "${FILESDIR}"/${PN}-0.7.6-doc-makefile.patch
epatch "${FILESDIR}"/${P}-sphinx-1.3.1.patch
@@ -67,7 +70,7 @@ python_compile_all() {
}
python_test() {
- VIRTUALX_COMMAND="./setup.py" virtualmake test
+ virtx "${PYTHON}" setup.py test
}
python_install() {
@@ -77,8 +80,11 @@ python_install() {
python_install_all() {
local DOCS=( AUTHORS README.rst )
use doc &&\
- DOCS=( ${DOCS[*]} doc/_build/cheatsheet/cheatsheet.pdf doc/_build/cheatsheet/combinatoric_cheatsheet.pdf ) &&\
- local HTML_DOCS=( doc/_build/html/. ) &&\
+ DOCS+=(
+ doc/_build/cheatsheet/cheatsheet.pdf
+ doc/_build/cheatsheet/combinatoric_cheatsheet.pdf
+ ) && \
+ local HTML_DOCS=( doc/_build/html/. ) && \
doinfo doc/_build/texinfo/${PN}.info
use examples && local EXAMPLES=( examples/. )
distutils-r1_python_install_all
diff --git a/dev-python/sympy/sympy-0.7.6.1.ebuild b/dev-python/sympy/sympy-0.7.6.1.ebuild
index 15a78b687fbf..6ae4e9fe1b84 100644
--- a/dev-python/sympy/sympy-0.7.6.1.ebuild
+++ b/dev-python/sympy/sympy-0.7.6.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -18,7 +18,7 @@ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-macos"
IUSE="doc examples gtk imaging ipython latex mathml opengl pdf png pyglet test texmacs theano"
REQUIRED_USE="${PYTHON_REQUIRED_USE}
- doc? ( python_targets_python2_7 )"
+ doc? ( || ( $(python_gen_useflags 'python2*') ) )"
RDEPEND="
$(python_gen_cond_dep '>=dev-python/pexpect-2.0[${PYTHON_USEDEP}]' python2_7)
@@ -45,6 +45,10 @@ DEPEND="${RDEPEND}
doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
test? ( ${RDEPEND} dev-python/pytest[${PYTHON_USEDEP}] )"
+pkg_setup() {
+ use doc && DISTUTILS_ALL_SUBPHASE_IMPLS=( 'python2*' )
+}
+
python_prepare_all() {
epatch "${FILESDIR}"/${PN}-0.7.6-doc-makefile.patch
epatch "${FILESDIR}"/${P}-sphinx-1.3.1.patch
@@ -65,7 +69,7 @@ python_compile_all() {
}
python_test() {
- VIRTUALX_COMMAND="./setup.py" virtualmake test
+ virtx "${PYTHON}" setup.py test
}
python_install() {
@@ -75,8 +79,11 @@ python_install() {
python_install_all() {
local DOCS=( AUTHORS README.rst )
use doc &&\
- DOCS=( ${DOCS[*]} doc/_build/cheatsheet/cheatsheet.pdf doc/_build/cheatsheet/combinatoric_cheatsheet.pdf ) &&\
- local HTML_DOCS=( doc/_build/html/. ) &&\
+ DOCS+=(
+ doc/_build/cheatsheet/cheatsheet.pdf
+ doc/_build/cheatsheet/combinatoric_cheatsheet.pdf
+ ) && \
+ local HTML_DOCS=( doc/_build/html/. ) && \
doinfo doc/_build/texinfo/${PN}.info
use examples && local EXAMPLES=( examples/. )
distutils-r1_python_install_all