summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2017-06-08 14:19:28 +0200
committerManuel Rüger <mrueg@gentoo.org>2017-06-08 14:19:28 +0200
commitdaa0cdd305b3845c038b9152b5798003b569e497 (patch)
treeddd4ebfcc31259088d45965e0de5a541fe7e89c3
parentdev-util/drone: Remove old (diff)
downloadgentoo-daa0cdd305b3845c038b9152b5798003b569e497.tar.gz
gentoo-daa0cdd305b3845c038b9152b5798003b569e497.tar.bz2
gentoo-daa0cdd305b3845c038b9152b5798003b569e497.zip
app-crypt/cfssl: Update snapshot
Package-Manager: Portage-2.3.6, Repoman-2.3.2
-rw-r--r--app-crypt/cfssl/Manifest1
-rw-r--r--app-crypt/cfssl/cfssl-1.2.0_p20170601.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/app-crypt/cfssl/Manifest b/app-crypt/cfssl/Manifest
index 858d654087c5..ddd36455f0a5 100644
--- a/app-crypt/cfssl/Manifest
+++ b/app-crypt/cfssl/Manifest
@@ -1,2 +1,3 @@
DIST cfssl-1.2.0_p20170322.tar.gz 8150942 SHA256 b1f70ecddc3f609ad2b12fd550b318e09119372130e978bfae8c3b6e04e2ed85 SHA512 69ef4418a485fe0317aec7d51f32670ff9603bb0fc8cce175ec4b98f79155538de0d3189a589c179d900ad1c4e486c3ad50b12c7345ba7771abf3f948f98a138 WHIRLPOOL da2bf58248a6cba0a004f71476f0c460dfe0fa2ea5da211343560faf9c7e295733de57bb7f22311af9be230ef96c5182777550473383550f6c6c401a1da881be
+DIST cfssl-1.2.0_p20170601.tar.gz 8025105 SHA256 4a9a1a801dd10c7cfbb1e98ce60f8bb0df407282dbbf1e8f75ff55a7909aba6e SHA512 f89d6b142eb5286b720c9d94534c474b15738c6a856999588392b37ffa753e0f0c9d663debee9cc216be765d8f39a71872401173a56293cdca2f2d1791c3d758 WHIRLPOOL 44019b727a66758d56c0ee9064a26b8b43d367bef0212f1a50aa8eeaf827a1f09590b4b6eb50ed5fff10b3ad72866526761a8522236fd82e1a5ff3850780254a
DIST github.com-juju-ratelimit-acf38b000a03e4ab89e40f20f1e548f4e6ac7f72.tar.gz 7980 SHA256 d3de61697c62b643d7b63b80d0eee853193f0379ea12b1371000c84c4dcdf0f1 SHA512 e26bbe1ba705718e919d99061a44de76ed6950666b07185e295860fb5f0e7d94f1be91d616737aecb4652e4e32b7066d94c0ffaaeb07e916cb09aac2b519754d WHIRLPOOL 89b621b810c00f6a7fa0468e7ca80556a3084f5e78d6afe6a44e9079fe3b56e4a472b9247470026300ed8c4ad3e1e652f69fa089e5efc47e41a74ffd55726b6f
diff --git a/app-crypt/cfssl/cfssl-1.2.0_p20170601.ebuild b/app-crypt/cfssl/cfssl-1.2.0_p20170601.ebuild
new file mode 100644
index 000000000000..febb491cd702
--- /dev/null
+++ b/app-crypt/cfssl/cfssl-1.2.0_p20170601.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+EGO_PN="github.com/cloudflare/${PN}"
+EGIT_COMMIT="9c06c53d4dfb9c0272c983a26ea10a6a2da12392"
+inherit golang-build golang-vcs-snapshot
+
+ARCHIVE_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+DESCRIPTION="Cloudflare's PKI and TLS toolkit"
+HOMEPAGE="https://github.com/cloudflare/cfssl"
+SRC_URI="${ARCHIVE_URI}"
+LICENSE="BSD-2"
+SLOT="0"
+IUSE="hardened"
+
+RESTRICT="test"
+
+src_compile() {
+ export CGO_LDFLAGS="$(usex hardened '-fno-PIC ' '')"
+ pushd src || die
+ GOPATH="${S}" go install github.com/cloudflare/cfssl/cmd/... || die
+ popd || die
+}
+
+src_install() {
+ dobin bin/*
+ pushd src/${EGO_PN} || die
+ dodoc CHANGELOG README.md
+ popd || die
+}