summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-10-16 18:06:08 +0200
committerPacho Ramos <pacho@gentoo.org>2016-10-16 18:09:58 +0200
commitdaa7ad30586be13d0ad1dc07bc64ab3fdb3e01be (patch)
treedfe8a6588ed417931fad36b059bc43c23dfba8cf
parentmedia-gfx/eog-plugins: Drop old (diff)
downloadgentoo-daa7ad30586be13d0ad1dc07bc64ab3fdb3e01be.tar.gz
gentoo-daa7ad30586be13d0ad1dc07bc64ab3fdb3e01be.tar.bz2
gentoo-daa7ad30586be13d0ad1dc07bc64ab3fdb3e01be.zip
media-gfx/eog-plugins: Version bump
Package-Manager: portage-2.3.1
-rw-r--r--media-gfx/eog-plugins/Manifest1
-rw-r--r--media-gfx/eog-plugins/eog-plugins-3.16.5.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/media-gfx/eog-plugins/Manifest b/media-gfx/eog-plugins/Manifest
index a9f523a40239..1f0afd7b91f9 100644
--- a/media-gfx/eog-plugins/Manifest
+++ b/media-gfx/eog-plugins/Manifest
@@ -1 +1,2 @@
DIST eog-plugins-3.16.4.tar.xz 394868 SHA256 4fcfe7df19cdf8e39f5fec599d7ff46bbd82842d49083274740fbbc51cf4d25e SHA512 bec368a2b23d2f0e270d1bebcfc52ec602a32fc1436478f115fe960dfbf73dafa4217589e1e49d2c299672f755a22aaae3a78a353bac698c9e9d88487c7d2d41 WHIRLPOOL 7f862dddcba84f4c50618e19424e4c140c3c83d26ed3c62667ff6f6beaf5ec2039add55448b4347121951bac3248dfad7e3d4ace3f1ea9417044cfb1ccbd05fe
+DIST eog-plugins-3.16.5.tar.xz 397044 SHA256 9de42235cc7dabc4e4b228c1a27ead4ee386cf5a3cc75fdb7ea12355d408108a SHA512 08a92cec37155fe4875de542865d583d2a1eca497af4caf94d21b38c7672685c27fcff23f18c50261b5f8012824931a531e62a8eb77167d6b3a5e375c83dfc40 WHIRLPOOL eccccce1b00495da09747866842cddbea044ef5320e05693c076d122bfd22457c8ea8099b31b5087c5e8836e9133a2c00df07ab243298a6035934269ef78dbdc
diff --git a/media-gfx/eog-plugins/eog-plugins-3.16.5.ebuild b/media-gfx/eog-plugins/eog-plugins-3.16.5.ebuild
new file mode 100644
index 000000000000..89c50ac7625c
--- /dev/null
+++ b/media-gfx/eog-plugins/eog-plugins-3.16.5.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python{3_3,3_4,3_5} )
+
+inherit gnome2 python-r1
+
+DESCRIPTION="Eye of GNOME plugins"
+HOMEPAGE="https://wiki.gnome.org/Apps/EyeOfGnome/Plugins"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="+exif +flickr map picasa +python"
+REQUIRED_USE="
+ map? ( exif )
+ python? ( ^^ ( $(python_gen_useflags '*') ) )
+"
+
+RDEPEND="
+ >=dev-libs/glib-2.38:2
+ >=dev-libs/libpeas-0.7.4:=
+ >=media-gfx/eog-3.15.90
+ >=x11-libs/gtk+-3.14:3
+ exif? ( >=media-libs/libexif-0.6.16 )
+ flickr? ( media-gfx/postr )
+ map? (
+ media-libs/libchamplain:0.12[gtk]
+ >=media-libs/clutter-1.9.4:1.0
+ >=media-libs/clutter-gtk-1.1.2:1.0 )
+ picasa? ( >=dev-libs/libgdata-0.9.1:= )
+ python? (
+ ${PYTHON_DEPS}
+ >=dev-libs/glib-2.32:2[dbus]
+ dev-libs/libpeas:=[gtk,python,${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ gnome-base/gsettings-desktop-schemas
+ media-gfx/eog[introspection]
+ x11-libs/gtk+:3[introspection]
+ x11-libs/pango[introspection] )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.50.1
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+pkg_setup() {
+ use python && [[ ${MERGE_TYPE} != binary ]] && python_setup
+}
+
+src_configure() {
+ local plugins="fit-to-width,send-by-mail,hide-titlebar,light-theme"
+ use exif && plugins="${plugins},exif-display"
+ use flickr && plugins="${plugins},postr"
+ use map && plugins="${plugins},map"
+ use picasa && plugins="${plugins},postasa"
+ use python && plugins="${plugins},slideshowshuffle,pythonconsole,fullscreenbg,export-to-folder,maximize-windows"
+ gnome2_src_configure \
+ $(use_enable python) \
+ --with-plugins=${plugins}
+}