summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-02-27 21:32:04 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-02-28 13:26:11 +0100
commitdb8ee6d88fb1f2838180c46ac326473a57ad517a (patch)
tree4e3d402a5132df8ecb78f37739e46edbc95c49e9
parentgames-sports/dustrac: Drop 1.11.0-r1 (diff)
downloadgentoo-db8ee6d88fb1f2838180c46ac326473a57ad517a.tar.gz
gentoo-db8ee6d88fb1f2838180c46ac326473a57ad517a.tar.bz2
gentoo-db8ee6d88fb1f2838180c46ac326473a57ad517a.zip
games-strategy/maxr: EAPI-7 bump, switch to cmake.eclass
Package-Manager: Portage-3.0.16, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--games-strategy/maxr/maxr-0.2.9.ebuild23
1 files changed, 11 insertions, 12 deletions
diff --git a/games-strategy/maxr/maxr-0.2.9.ebuild b/games-strategy/maxr/maxr-0.2.9.ebuild
index 4e1287280ad5..ad76a5a4f645 100644
--- a/games-strategy/maxr/maxr-0.2.9.ebuild
+++ b/games-strategy/maxr/maxr-0.2.9.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit cmake-utils desktop gnome2-utils
+inherit cmake desktop xdg-utils
DESCRIPTION="Mechanized Assault and Exploration Reloaded"
-HOMEPAGE="https://www.maxr.org"
+HOMEPAGE="https://www.maxr.org/"
SRC_URI="https://www.maxr.org/downloads/${P}.tar.gz"
LICENSE="GPL-2 FDL-1.2+"
@@ -14,26 +14,25 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="dedicated"
-RDEPEND="media-libs/libsdl2[video]
+RDEPEND="
+ media-libs/libsdl2[video]
media-libs/sdl2-mixer[vorbis]
media-libs/sdl2-net"
DEPEND="${RDEPEND}"
src_configure() {
- mycmakeargs=(
+ local mycmakeargs=(
-DMAXR_BUILD_DEDICATED_SERVER=$(usex dedicated)
-DCMAKE_BUILD_TYPE=Release
)
-
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
doicon -s 128 data/${PN}.png
make_desktop_entry ${PN} "Mechanized Assault and Exploration Reloaded"
}
-pkg_preinst() { gnome2_icon_savelist; }
-pkg_postinst() { gnome2_icon_cache_update; }
-pkg_postrm() { gnome2_icon_cache_update; }
+pkg_postinst() { xdg_icon_cache_update; }
+pkg_postrm() { xdg_icon_cache_update; }