summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-04-23 12:12:16 +0200
committerDavid Seifert <soap@gentoo.org>2017-04-23 13:26:42 +0200
commitdbe967cef57717cdfd95dd7efb9238666f887139 (patch)
tree8c5b2787e8e6ae5ed5f1ed2fd430b5667e8138e4
parentmedia-libs/libsub: [QA] Add missing python metadata variables (diff)
downloadgentoo-dbe967cef57717cdfd95dd7efb9238666f887139.tar.gz
gentoo-dbe967cef57717cdfd95dd7efb9238666f887139.tar.bz2
gentoo-dbe967cef57717cdfd95dd7efb9238666f887139.zip
media-libs/lv2: [QA] Add missing python metadata variables
Package-Manager: Portage-2.3.5, Repoman-2.3.2
-rw-r--r--media-libs/lv2/lv2-1.10.0-r1.ebuild8
-rw-r--r--media-libs/lv2/lv2-1.12.0.ebuild9
-rw-r--r--media-libs/lv2/lv2-1.14.0.ebuild9
3 files changed, 20 insertions, 6 deletions
diff --git a/media-libs/lv2/lv2-1.10.0-r1.ebuild b/media-libs/lv2/lv2-1.10.0-r1.ebuild
index 116d93599d42..36cb1851af50 100644
--- a/media-libs/lv2/lv2-1.10.0-r1.ebuild
+++ b/media-libs/lv2/lv2-1.10.0-r1.ebuild
@@ -1,10 +1,11 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
PYTHON_COMPAT=( python{2_7,3_4} )
PYTHON_REQ_USE='threads(+)'
+
inherit python-single-r1 waf-utils
DESCRIPTION="LV2 is a simple but extensible successor of LADSPA"
@@ -15,8 +16,11 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 ~ppc ~ppc64 x86"
IUSE="doc plugins"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-DEPEND="plugins? ( x11-libs/gtk+:2 media-libs/libsndfile )"
+DEPEND="
+ ${PYTHON_DEPS}
+ plugins? ( x11-libs/gtk+:2 media-libs/libsndfile )"
RDEPEND="${DEPEND}
dev-python/lxml[${PYTHON_USEDEP}]
dev-python/pygments[${PYTHON_USEDEP}]
diff --git a/media-libs/lv2/lv2-1.12.0.ebuild b/media-libs/lv2/lv2-1.12.0.ebuild
index c66968ce40b2..284d435f39c3 100644
--- a/media-libs/lv2/lv2-1.12.0.ebuild
+++ b/media-libs/lv2/lv2-1.12.0.ebuild
@@ -1,9 +1,11 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
+
PYTHON_COMPAT=( python{2_7,3_4} )
PYTHON_REQ_USE='threads(+)'
+
inherit python-single-r1 waf-utils multilib
DESCRIPTION="A simple but extensible successor of LADSPA"
@@ -14,8 +16,11 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
IUSE="doc plugins"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-DEPEND="plugins? ( x11-libs/gtk+:2 media-libs/libsndfile )"
+DEPEND="
+ ${PYTHON_DEPS}
+ plugins? ( x11-libs/gtk+:2 media-libs/libsndfile )"
RDEPEND="${DEPEND}
dev-python/lxml[${PYTHON_USEDEP}]
dev-python/pygments[${PYTHON_USEDEP}]
diff --git a/media-libs/lv2/lv2-1.14.0.ebuild b/media-libs/lv2/lv2-1.14.0.ebuild
index abcae4c123c7..284d435f39c3 100644
--- a/media-libs/lv2/lv2-1.14.0.ebuild
+++ b/media-libs/lv2/lv2-1.14.0.ebuild
@@ -1,9 +1,11 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
+
PYTHON_COMPAT=( python{2_7,3_4} )
PYTHON_REQ_USE='threads(+)'
+
inherit python-single-r1 waf-utils multilib
DESCRIPTION="A simple but extensible successor of LADSPA"
@@ -14,8 +16,11 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
IUSE="doc plugins"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-DEPEND="plugins? ( x11-libs/gtk+:2 media-libs/libsndfile )"
+DEPEND="
+ ${PYTHON_DEPS}
+ plugins? ( x11-libs/gtk+:2 media-libs/libsndfile )"
RDEPEND="${DEPEND}
dev-python/lxml[${PYTHON_USEDEP}]
dev-python/pygments[${PYTHON_USEDEP}]