summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2017-08-10 08:40:12 +0200
committerJeroen Roovers <jer@gentoo.org>2017-08-10 08:40:12 +0200
commitdbf1bf28aeed4bb0e50baaab4cc7b159599ff4ad (patch)
tree20fb30ea0db9db44c86cca160bb0d211c7482f36
parentnet-analyzer/cacti: Version bump. (diff)
downloadgentoo-dbf1bf28aeed4bb0e50baaab4cc7b159599ff4ad.tar.gz
gentoo-dbf1bf28aeed4bb0e50baaab4cc7b159599ff4ad.tar.bz2
gentoo-dbf1bf28aeed4bb0e50baaab4cc7b159599ff4ad.zip
net-analyzer/cacti-spine: Version bump.
Package-Manager: Portage-2.3.6, Repoman-2.3.3
-rw-r--r--net-analyzer/cacti-spine/Manifest1
-rw-r--r--net-analyzer/cacti-spine/cacti-spine-1.1.16.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/net-analyzer/cacti-spine/Manifest b/net-analyzer/cacti-spine/Manifest
index 1e0d1554b731..9b1d50078fc3 100644
--- a/net-analyzer/cacti-spine/Manifest
+++ b/net-analyzer/cacti-spine/Manifest
@@ -1,2 +1,3 @@
DIST cacti-spine-0.8.8h.tar.gz 804951 SHA256 a693136839bd7d03cae5b3ff4614a4d21a2153ffb14d09fc061b843ab0b2bb30 SHA512 6a7147ab645be44de0d330c7801e569705817da10bf6cedba82c712e1701ada8aa8924a6b3b063ea680e6af24f815d6767e8773ad7b8da212abfa082b4211bd4 WHIRLPOOL 36daed4986ca84883e51ab6b02ebb2ade00205c30705cfc94e73835bc2fc427a60a2dba9c7ca3665d0c0b2fca21afab77d94cde63b740f3734f9279c929cccaf
DIST cacti-spine-1.1.15.tar.gz 801706 SHA256 91de11faaa882cf8743defd252251b43bf8afad7680bae80e50290573547fd8c SHA512 2ea955748afa78e7e7802960ad5d888720838e3464df937cd1a258c191198a68b16fe58e56e2985855f3157fe4fdd2c1792ccc9d8e970419ec94c453588baf13 WHIRLPOOL 5c3d0fc8959d21482b28ed8c2258240e2cc7724927344900cadf70e701b8a335ab32ddc1d0728d0f20e9b7b83aff03c3d634e7001c21ec428c36144eb494aa4f
+DIST cacti-spine-1.1.16.tar.gz 801508 SHA256 9969d7b422d4c41fd6d7e9fb3d7907400601a394b16c4253202b3d4596f85d7f SHA512 01813864bd65229d7d1a54123de60579eeed652e962d0f78a4bc63c26de29e1402b7bbb4e7585c90cf37c9db412b539c8079b72c78fa026110c290632d63b205 WHIRLPOOL cd1bc344e38b826cce8a1b584ab8d8d2f8d1d91416d6939932a4c6eda59428b23aa7fc970faee93245b0967d18eaa280677acf0e9ee9add6e715121bda4d6c8c
diff --git a/net-analyzer/cacti-spine/cacti-spine-1.1.16.ebuild b/net-analyzer/cacti-spine/cacti-spine-1.1.16.ebuild
new file mode 100644
index 000000000000..34727025866f
--- /dev/null
+++ b/net-analyzer/cacti-spine/cacti-spine-1.1.16.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools eutils
+
+MY_P=${PN}-${PV/_p/-}
+
+DESCRIPTION="Spine is a fast poller for Cacti (formerly known as Cactid)"
+HOMEPAGE="http://cacti.net/spine_info.php"
+SRC_URI="http://www.cacti.net/downloads/spine/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+
+CDEPEND="
+ dev-libs/openssl:*
+ net-analyzer/net-snmp
+ virtual/mysql
+"
+DEPEND="
+ ${CDEPEND}
+ sys-apps/help2man
+"
+RDEPEND="
+ ${CDEPEND}
+ >net-analyzer/cacti-0.8.8
+"
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.8.8d-ping.patch
+ "${FILESDIR}"/${PN}-0.8.8g-net-snmp.patch
+)
+
+src_prepare() {
+ default
+
+ AT_M4DIR="config" eautoreconf
+}
+
+src_install() {
+ dosbin spine
+ insinto /etc/
+ insopts -m0640 -o root
+ newins spine.conf{.dist,}
+ dodoc ChangeLog
+}