summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2016-03-10 23:37:11 +0100
committerManuel Rüger <mrueg@gentoo.org>2016-03-10 23:37:11 +0100
commitdbfe008993550d22cc43c82833f0cc6afe0395bb (patch)
treecf10112de2c0afd68080a26ebae85658b0c8136c
parentnet-libs/nodejs: version bump to 0.12.10 (diff)
downloadgentoo-dbfe008993550d22cc43c82833f0cc6afe0395bb.tar.gz
gentoo-dbfe008993550d22cc43c82833f0cc6afe0395bb.tar.bz2
gentoo-dbfe008993550d22cc43c82833f0cc6afe0395bb.zip
app-admin/keepass: Version bump
Package-Manager: portage-2.2.27
-rw-r--r--app-admin/keepass/Manifest1
-rw-r--r--app-admin/keepass/keepass-2.32.ebuild113
2 files changed, 114 insertions, 0 deletions
diff --git a/app-admin/keepass/Manifest b/app-admin/keepass/Manifest
index d0bad8cbbcc1..a80ede3faac4 100644
--- a/app-admin/keepass/Manifest
+++ b/app-admin/keepass/Manifest
@@ -1,2 +1,3 @@
DIST KeePass-2.30-Source.zip 4767753 SHA256 4a3c3c217bc05b13bf903612b89a09b67ed1df68fdecd83324f2ef372313e9e4 SHA512 05404f273f6a7df33887b036aa0dba335124a7b2ae30b61957f8dc9c959cdd3342fdfa22a7d59ba5e9180f039fed5ecbac0a3154eb9d342a5a3a8a057d763182 WHIRLPOOL 4ddec9e592724b60724a2deaaf959dacc91f77d1ae97dd07af940f8efd882a008b4424ba68a4fcbd9ebe8d75c2b8a9a644ff7144ed593cfb3f0e361c0364a780
DIST KeePass-2.31-Source.zip 4714301 SHA256 555b1a30f374f7077bf15906b09ab36b40fd3fc5753673a3c0ee3f30f0ed7881 SHA512 e2e81e7d60bc58a18ea3b9a82741bdd6e5be88bcfcf447ae587f6177a8ff97e7c82c02fb0695142f8321c7b5f92aa982254629928dd0c12393d659380f46026d WHIRLPOOL b8b572bd7db7ce9bc67ae0a241c71cd30595753d06bfed85efafece2b3cce4893c5cc213ee44cabd81c6ff12fc2fc98234d845ed94d0068d8111d116ccc39333
+DIST KeePass-2.32-Source.zip 4721787 SHA256 7c49b62c8de758dee7e9c2d6108c169d468b4e65f21e297649d3dd8c2b757385 SHA512 6c6345cedc505eaaec28c6e89e225bdad5d5ac169c364a7e04b06bbdef4223829662f6e12a7432a3785f73cbc6798ba578468be04ab1063eb96135346570c7c3 WHIRLPOOL 6ba1bff9df311950068e34f9044f5b9e29e6e571e1928093f7ad6dc23c8b7ad26a89371fc425df0f5b41d3781aa29c0c6ad4d8c0c0f077248e4ee7f9022dabe3
diff --git a/app-admin/keepass/keepass-2.32.ebuild b/app-admin/keepass/keepass-2.32.ebuild
new file mode 100644
index 000000000000..d828fcf1d51a
--- /dev/null
+++ b/app-admin/keepass/keepass-2.32.ebuild
@@ -0,0 +1,113 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils fdo-mime gnome2-utils mono-env multilib
+
+MY_PN="KeePass"
+DESCRIPTION="A free, open source, light-weight and easy-to-use password manager"
+HOMEPAGE="http://keepass.info/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_PN}-${PV}-Source.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="aot"
+
+COMMON_DEPEND=">=dev-lang/mono-2.10.5"
+RDEPEND="${COMMON_DEPEND}
+ dev-dotnet/libgdiplus[cairo]"
+DEPEND="${COMMON_DEPEND}
+ app-arch/unzip"
+
+S=${WORKDIR}
+
+src_prepare() {
+ # Force text mode for >grep-2.21 (bug #574480)
+ epatch "${FILESDIR}/${PN}-2.31-force-text-grep.patch"
+
+ # Remove Windows-specific things
+ pushd Build > /dev/null || die
+ . PrepMonoDev.sh || die
+ popd > /dev/null || die
+
+ # KeePass looks for some XSL files in the same folder as the executable,
+ # we prefer to have it in /usr/share/KeePass
+ epatch "${FILESDIR}/${PN}-2.20-xsl-path-detection.patch"
+ # bug # 558094
+ if has_version ">=dev-lang/mono-4" ; then
+ sed -i -e 's! ToolsVersion="3.5"!!g' Translation/TrlUtil/TrlUtil.csproj || die
+ sed -i -e 's/Format Version 10.00/Format Version 11.00/' KeePass.sln || die
+ fi
+}
+
+src_compile() {
+ # Build with Release target
+ xbuild /target:KeePass /property:Configuration=Release || die
+
+ # Run Ahead Of Time compiler on the binary
+ if use aot; then
+ cp Ext/KeePass.exe.config Build/KeePass/Release/
+ mono --aot -O=all Build/KeePass/Release/KeePass.exe || die
+ fi
+}
+
+src_install() {
+ # Wrapper script to launch mono
+ make_wrapper ${PN} "mono /usr/$(get_libdir)/${PN}/KeePass.exe"
+
+ # Some XSL files
+ insinto /usr/share/${PN}/XSL
+ doins Ext/XSL/*
+
+ insinto /usr/$(get_libdir)/${PN}/
+ exeinto /usr/$(get_libdir)/${PN}/
+ doins Ext/KeePass.exe.config
+ # Default configuration, simply says to use user-specific configuration
+ doins Ext/KeePass.config.xml
+
+ # The actual executable
+ doexe Build/KeePass/Release/KeePass.exe
+
+ # Copy the AOT compilation result
+ if use aot; then
+ doexe Build/KeePass/Release/KeePass.exe.so
+ fi
+
+ # Prepare the icons
+ newicon -s 256 Ext/Icons_04_CB/Finals/plockb.png "${PN}.png"
+ newicon -s 256 -t gnome -c mimetypes Ext/Icons_04_CB/Finals/plockb.png "application-x-${PN}2.png"
+
+ # Create a desktop entry and associate it with the KeePass mime type
+ make_desktop_entry ${PN} ${MY_PN} ${PN} "System;Security" "MimeType=application/x-keepass2;"
+
+ # MIME descriptor for .kdbx files
+ insinto /usr/share/mime/packages/
+ doins "${FILESDIR}/${PN}.xml"
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ fdo-mime_mime_database_update
+ fdo-mime_desktop_database_update
+
+ if ! has_version x11-misc/xdotool ; then
+ elog "Optional dependencies:"
+ elog " x11-misc/xdotool (enables autotype)"
+ fi
+
+ elog "Some systems may experience issues with copy and paste operations."
+ elog "If you encounter this, please install x11-misc/xsel."
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ fdo-mime_mime_database_update
+ fdo-mime_desktop_database_update
+}