summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSlawomir Lis <slis@gentoo.org>2019-09-08 20:58:59 +0200
committerSlawomir Lis <slis@gentoo.org>2019-09-08 21:24:40 +0200
commitdc1b127212527643b0346fe711558136bfc25ad0 (patch)
treeca219ca5f70aacc0f3d1a17aab338cfaa4a88f2f
parentapp-vim/vimpython: x86 stable (bug #693126) (diff)
downloadgentoo-dc1b127212527643b0346fe711558136bfc25ad0.tar.gz
gentoo-dc1b127212527643b0346fe711558136bfc25ad0.tar.bz2
gentoo-dc1b127212527643b0346fe711558136bfc25ad0.zip
net-analyzer/suricata: fixed build error related with SIOCGSTAMP
Closes: https://bugs.gentoo.org/692546 Package-Manager: Portage-2.3.75, Repoman-2.3.17 Signed-off-by: Slawek Lis <slis@gentoo.org>
-rw-r--r--net-analyzer/suricata/files/suricata-4.0.4_sockios.patch13
-rw-r--r--net-analyzer/suricata/suricata-4.0.4.ebuild5
2 files changed, 16 insertions, 2 deletions
diff --git a/net-analyzer/suricata/files/suricata-4.0.4_sockios.patch b/net-analyzer/suricata/files/suricata-4.0.4_sockios.patch
new file mode 100644
index 000000000000..a341d9c159f1
--- /dev/null
+++ b/net-analyzer/suricata/files/suricata-4.0.4_sockios.patch
@@ -0,0 +1,13 @@
+--- src/source-af-packet.c.orig 2019-09-08 20:50:06.416466432 +0200
++++ src/source-af-packet.c 2019-09-08 20:53:26.144471385 +0200
+@@ -70,6 +70,10 @@
+
+ #ifdef HAVE_AF_PACKET
+
++#ifdef HAVE_LINUX_SOCKIOS_H
++#include <linux/sockios.h>
++#endif
++
+ #if HAVE_SYS_IOCTL_H
+ #include <sys/ioctl.h>
+ #endif
diff --git a/net-analyzer/suricata/suricata-4.0.4.ebuild b/net-analyzer/suricata/suricata-4.0.4.ebuild
index 2622dccdb3b7..f476bfe2ae24 100644
--- a/net-analyzer/suricata/suricata-4.0.4.ebuild
+++ b/net-analyzer/suricata/suricata-4.0.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -46,7 +46,8 @@ pkg_setup() {
}
src_prepare() {
- epatch "${FILESDIR}"/${P}_configure-lua-flags.patch
+ epatch "${FILESDIR}/${P}_configure-lua-flags.patch"
+ epatch "${FILESDIR}/${P}_sockios.patch"
eautoreconf
}