summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2018-10-09 11:29:24 +0200
committerThomas Deutschmann <whissi@gentoo.org>2018-10-09 14:16:59 +0200
commitdc976b4dcc5422f9291b9680f7b394981c76f970 (patch)
tree312fed1aefbb3ec5f64f4fb8def491de7af0f526
parentnet-libs/nghttp2: arm/s390 stable wrt bug #665798 (diff)
downloadgentoo-dc976b4dcc5422f9291b9680f7b394981c76f970.tar.gz
gentoo-dc976b4dcc5422f9291b9680f7b394981c76f970.tar.bz2
gentoo-dc976b4dcc5422f9291b9680f7b394981c76f970.zip
app-metrics/mysqld_exporter: bump to v0.11.0
Note: The format of the mysqld_exporter command line flags has changed. Instead of a single dash, all flags now use a double dash. Package-Manager: Portage-2.3.50, Repoman-2.3.11 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
-rw-r--r--app-metrics/mysqld_exporter/Manifest1
-rw-r--r--app-metrics/mysqld_exporter/files/mysqld_exporter-r1.confd26
-rw-r--r--app-metrics/mysqld_exporter/mysqld_exporter-0.11.0.ebuild71
3 files changed, 98 insertions, 0 deletions
diff --git a/app-metrics/mysqld_exporter/Manifest b/app-metrics/mysqld_exporter/Manifest
index e55c4730f1bb..e9ac6d5ab2d9 100644
--- a/app-metrics/mysqld_exporter/Manifest
+++ b/app-metrics/mysqld_exporter/Manifest
@@ -1 +1,2 @@
DIST mysqld_exporter-0.10.0.tar.gz 971604 BLAKE2B ec077b7b6a15f6173e5cc04e741c51c4d26a214601da8eb1aede49ee325f52bea2140b8e5b3bdbc2a1e527e40c95099dca2a57501d44a26e787cdc330f4aa8b8 SHA512 0a7b0ff537ad59a9b64aa18dfe1d1eb9253b12ae566d5c151555fbd4457b7e65890b6569632b452ae317b3acbfa94c12d96f6fb6e4f982b9b2161fc4747330f5
+DIST mysqld_exporter-0.11.0.tar.gz 1393809 BLAKE2B ac6b04d2ad24f1c083c411f10bbb6724c2458be357ff60e1950aa624955497432295726e7f739dff03aa1ed8290d852a9511e01893f5a2b293e79b3214270578 SHA512 69f39ecc1b17bfcfd3acdad9d92a70c1daf3f0c9690770fa390a818bd29f43a98bfe4856f22b48e9d2d9945ce98ded0ea54c95010755a85ebc3ebfdc353d0c24
diff --git a/app-metrics/mysqld_exporter/files/mysqld_exporter-r1.confd b/app-metrics/mysqld_exporter/files/mysqld_exporter-r1.confd
new file mode 100644
index 000000000000..2b7f9bf17a3d
--- /dev/null
+++ b/app-metrics/mysqld_exporter/files/mysqld_exporter-r1.confd
@@ -0,0 +1,26 @@
+# /etc/conf.d/mysqld_exporter
+
+# PID file
+#EXPORTER_PIDFILE="/run/${RC_SVCNAME}.pid"
+
+# The termination timeout (start-stop-daemon parameter "retry") ensures
+# that the service will be terminated within a given time (60 + 5 seconds
+# per default) when you are stopping the service.
+#EXPORTER_TERMTIMEOUT="TERM/60/KILL/5"
+
+# User to run exporter as
+#EXPORTER_USER="mysqld_exporter"
+
+# User group to run exporter as
+#EXPORTER_GROUP="mysqld_exporter"
+
+# You can use this configuration option to pass additional options to the
+# start-stop-daemon, see start-stop-daemon(8) for more details.
+# Per default we wait 1000ms after we have started the service to ensure
+# that the daemon is really up and running.
+#EXPORTER_SSDARGS="--wait 1000"
+
+# Exporter flags
+# See `mysqld_exporter --help` for more details
+EXPORTER_FLAGS="--log.level=info"
+#EXPORTER_FLAGS="${EXPORTER_FLAGS} --yourAdditionalFlag"
diff --git a/app-metrics/mysqld_exporter/mysqld_exporter-0.11.0.ebuild b/app-metrics/mysqld_exporter/mysqld_exporter-0.11.0.ebuild
new file mode 100644
index 000000000000..3571c885d167
--- /dev/null
+++ b/app-metrics/mysqld_exporter/mysqld_exporter-0.11.0.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+inherit eapi7-ver user golang-build golang-vcs-snapshot
+
+EGO_PN="github.com/prometheus/mysqld_exporter"
+EGIT_COMMIT="v${PV/_rc/-rc.}"
+MYSQLD_EXPORTER_COMMIT="8068006"
+ARCHIVE_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+DESCRIPTION="Prometheus exporter for MySQL server metrics"
+HOMEPAGE="https://github.com/prometheus/mysqld_exporter"
+SRC_URI="${ARCHIVE_URI}"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-util/promu"
+
+pkg_setup() {
+ enewgroup ${PN}
+ enewuser ${PN} -1 -1 /var/lib/mysqld_exporter ${PN}
+}
+
+src_prepare() {
+ default
+ sed -i -e "s/{{.Revision}}/${MYSQLD_EXPORTER_COMMIT}/" src/${EGO_PN}/.promu.yml || die
+}
+
+src_compile() {
+ pushd src/${EGO_PN} || die
+ mkdir -p bin || die
+ GOPATH="${S}" promu build -v --prefix bin || die
+ popd || die
+}
+
+src_install() {
+ pushd src/${EGO_PN} || die
+ dobin bin/mysqld_exporter
+ dodoc {README,CHANGELOG,CONTRIBUTING}.md
+ popd || die
+
+ keepdir /var/lib/mysqld_exporter /var/log/mysqld_exporter
+ fowners ${PN}:${PN} /var/lib/mysqld_exporter /var/log/mysqld_exporter
+ fperms 0770 /var/lib/mysqld_exporter
+
+ newinitd "${FILESDIR}"/${PN}-r1.initd ${PN}
+ newconfd "${FILESDIR}"/${PN}-r1.confd ${PN}
+
+ insinto /etc/logrotate.d/
+ newins "${FILESDIR}"/${PN}.logrotate ${PN}
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ # This is a new installation
+ elog "Create \"${EROOT%/}/var/lib/mysqld_exporter/.my.cnf\" to read MySQL credentials from file."
+ else
+ local _replacing_version=
+ for _replacing_version in ${REPLACING_VERSIONS}; do
+ if ! ver_test "${_replacing_version}" -ge "0.11.0"; then
+ elog "Starting with ${PN}-0.11.0, command-line flags will require double dashes (--)."
+ elog "You must update your configuration or ${PN} won't start."
+
+ break
+ fi
+ done
+ fi
+}