summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRonny (tastytea) Gutbrod <gentoo@tastytea.de>2022-11-04 04:57:24 +0100
committerJoonas Niilola <juippis@gentoo.org>2022-11-18 10:17:54 +0200
commitdcdc19f7ff6b4dd60cdab580d0b443675693baeb (patch)
tree0e8b340c028fa969d2536297af7a8e69eb423598
parentsci-calculators/bc-gh: bump to 6.1.1 (diff)
downloadgentoo-dcdc19f7ff6b4dd60cdab580d0b443675693baeb.tar.gz
gentoo-dcdc19f7ff6b4dd60cdab580d0b443675693baeb.tar.bz2
gentoo-dcdc19f7ff6b4dd60cdab580d0b443675693baeb.zip
www-apps/hugo: add 0.105.0
Signed-off-by: Ronny (tastytea) Gutbrod <gentoo@tastytea.de> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--www-apps/hugo/Manifest2
-rw-r--r--www-apps/hugo/hugo-0.105.0.ebuild95
2 files changed, 97 insertions, 0 deletions
diff --git a/www-apps/hugo/Manifest b/www-apps/hugo/Manifest
index 2376d0c78f71..639340fd2f8f 100644
--- a/www-apps/hugo/Manifest
+++ b/www-apps/hugo/Manifest
@@ -3,3 +3,5 @@ DIST hugo-0.101.0-vendor.tar.xz 5682852 BLAKE2B 130cf9fda4d857e69144147e408a90fd
DIST hugo-0.101.0.tar.gz 28130925 BLAKE2B ff35c48c39dac61abe56ba4f75bfddcdda700b71157dc4ed75f1c3724b11b8a9f4546e94d3105a724a5493b3baa73056a55d9d90e87ce4237e39213995db636d SHA512 541d0e04e868845119f2b488fd53b92929ea4dc08685d438a2914b41586e204588b193522013e8eed908dc0c3fbc2714aefb1afad0beae875d57d71aadc59c70
DIST hugo-0.104.3-vendor.tar.xz 5785560 BLAKE2B ac96f75bb267cab751e908225654bcf46defe08726087d4959fff5aa66833312ab97448b1cced965f15861d9a5779c55854fd64e3ec618a442680502d9d95c32 SHA512 9d2a8f1adb90ff83a5dd2e21e4ab3ccb398389acfa39da91aa6f320bd390db716c04082c31d26fcc77261a0cb4eff4b4f86b2c6aa9f30fcab452578b48badc50
DIST hugo-0.104.3.tar.gz 27639976 BLAKE2B a299c7ea5bbdfc819ceba3bbc83646f705f553546fd7c4e18bba26e09f6bc16216cafecabd9e4bdd6f685fe5102394ba205b8d39c873567e8b5bad931062a9c5 SHA512 feb5b610f5c4080c968e5d5f861c4976553d6bcbcca951824f2c14dcf2510e5d9d3a680ef274470d5599f0a270d931b4a4e5dc4c39830226e15c2b2091f8c8f5
+DIST hugo-0.105.0-vendor.tar.xz 5727760 BLAKE2B 0295adf688650292531ed250e793ef2914e8eab8cdf60c3aaf4278e26174a63c2bab0fe2ea5e95c6d543a3828c1d500240585e584bd7015e59dc78b42bc09332 SHA512 c2196922f8ac233ee9a2962168fa584aed594d89292dff93ad772f4d2ecef3b2b76f72eff05d0f508e776fabbe18fec108bd64e23ec9e478dbbb3ceb9976e5b2
+DIST hugo-0.105.0.tar.gz 27645900 BLAKE2B f9dbbc6d1dd2408736a688e6fb782f03bf1675559562e44cdb002fbf55afc4a56fc111240232ddca2bcbd80438f25ef2dfbebaaeb42ebc46f728399449ae449f SHA512 0cc9011ef30caf469d0e3aceb97ea988e4eb099d1b3e39d67ae9d4809e585025d5ed6e7dce498eb28b757217acc1ac668fcd3d4f625c02e341329def92112be3
diff --git a/www-apps/hugo/hugo-0.105.0.ebuild b/www-apps/hugo/hugo-0.105.0.ebuild
new file mode 100644
index 000000000000..d3c3a18137bd
--- /dev/null
+++ b/www-apps/hugo/hugo-0.105.0.ebuild
@@ -0,0 +1,95 @@
+# Copyright 2018-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module bash-completion-r1
+
+DESCRIPTION="Fast static HTML and CSS website generator"
+HOMEPAGE="https://gohugo.io https://github.com/gohugoio/hugo"
+SRC_URI="
+ https://github.com/gohugoio/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://tastytea.de/files/gentoo/${P}-vendor.tar.xz
+ https://tastytea.de/files/gentoo/${PN}-0.101.0-libwebp-1.2.3.patch
+"
+
+# NOTE: To create the vendor tarball, run:
+# `go mod vendor && cd .. && tar -caf ${P}-vendor.tar.xz ${P}/vendor`
+
+LICENSE="Apache-2.0 BSD BSD-2 MIT Unlicense"
+SLOT="0"
+KEYWORDS="~amd64 ~loong ~x86"
+IUSE="doc +sass test"
+
+BDEPEND="
+ >=dev-lang/go-1.18
+ test? (
+ dev-python/docutils
+ dev-ruby/asciidoctor
+ virtual/pandoc
+ )
+"
+RDEPEND="
+ >=media-libs/libwebp-1.2.3-r1:=
+ sass? ( dev-libs/libsass:= )
+"
+DEPEND="${RDEPEND}"
+
+RESTRICT="!test? ( test )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.96.0-unbundle-libwebp-and-libsass.patch
+ "${FILESDIR}"/${PN}-0.104.3-skip-some-tests.patch
+ "${FILESDIR}"/${PN}-0.99.1-test-timeout.patch
+ "${DISTDIR}"/${PN}-0.101.0-libwebp-1.2.3.patch
+)
+
+src_configure() {
+ export CGO_ENABLED=1
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+
+ MY_BUILDFLAGS="$(usev sass "-tags extended")"
+
+ default
+}
+
+src_compile() {
+ mkdir -pv bin || die
+ ego build -ldflags "-X github.com/gohugoio/hugo/common/hugo.vendorInfo=gentoo:${PVR}" \
+ ${MY_BUILDFLAGS} -o "${S}/bin/hugo"
+
+ bin/hugo gen man --dir man || die
+
+ mkdir -pv completions || die
+ bin/hugo completion bash > completions/hugo || die
+ bin/hugo completion fish > completions/hugo.fish || die
+ bin/hugo completion zsh > completions/_hugo || die
+
+ if use doc ; then
+ bin/hugo gen doc --dir doc || die
+ fi
+}
+
+src_test() {
+ ego test -race "./..." ${MY_BUILDFLAGS}
+}
+
+src_install() {
+ dobin bin/*
+ doman man/*
+
+ dobashcomp completions/${PN}
+
+ insinto /usr/share/fish/vendor_completions.d
+ doins completions/${PN}.fish
+
+ insinto /usr/share/zsh/site-functions
+ doins completions/_${PN}
+
+ if use doc ; then
+ dodoc -r doc/*
+ fi
+}