summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-24 08:30:00 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-24 08:35:18 +0100
commitdcf692e597cc779df77a75f92c1f33363ee1d321 (patch)
tree8a3145251b4ad138aed9ceecb4bbd09c70d95c30
parentdev-python/google-auth-oauthlib: Bump to 0.5.0 (diff)
downloadgentoo-dcf692e597cc779df77a75f92c1f33363ee1d321.tar.gz
gentoo-dcf692e597cc779df77a75f92c1f33363ee1d321.tar.bz2
gentoo-dcf692e597cc779df77a75f92c1f33363ee1d321.zip
dev-python/pytest-console-scripts: Bump to 1.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pytest-console-scripts/Manifest1
-rw-r--r--dev-python/pytest-console-scripts/pytest-console-scripts-1.3.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/pytest-console-scripts/Manifest b/dev-python/pytest-console-scripts/Manifest
index 2985f085d292..0b5135c63573 100644
--- a/dev-python/pytest-console-scripts/Manifest
+++ b/dev-python/pytest-console-scripts/Manifest
@@ -1,2 +1,3 @@
DIST pytest-console-scripts-1.2.0.tar.gz 13976 BLAKE2B 1452ecfdc47d3341d8f3f30d49f371ae89d6138d56e4dc3a230f6a3803c6c36f542df40e2785c99c3cfd5080fa03b5b3d4926bb742dc99bd2127d47305fbf788 SHA512 07c9baab85035265ab6a21cc0c754b076dba87f08e1ab51319ef47a0a8af0b44f7d42422014c68cf93ed28b508138a70e14b968707cc831682885b3ca8106aa7
DIST pytest-console-scripts-1.2.2.tar.gz 14314 BLAKE2B 1e4c210fe9fa6a4e9dbe308cf3d6c1a1829f2155185fe3911ee0a299c0292db6bceeeeb7efd5ace9a166c90ae8376d3cdfec8b0c0b585467f157e175709afe6d SHA512 c749b76c8370734f9ab7fe93284f9ac25a38e4bef61181a3b61b3b0d229532f1876e668e5a6e1449dcb939d9cb53527e021f79fd9132f3a28bdf45d95bdcb40e
+DIST pytest-console-scripts-1.3.tar.gz 14365 BLAKE2B 7a9b83f53ef9911e5f336375389e6c6311e64e7b4880ea2cb1f996221d4dbf119bf6fc487f7bb7bfda4355df8f797981e99ac9db2fff3e4871173a878a4fbd64 SHA512 8b66df3a8ff700817f8ec34aa95385ff82c4df47fd67974e91cf4d2fdae578d4683032b0a8162723adfcd461e5da7f1c5bb99339d62ed9cbdca4fd1be001b0f6
diff --git a/dev-python/pytest-console-scripts/pytest-console-scripts-1.3.ebuild b/dev-python/pytest-console-scripts/pytest-console-scripts-1.3.ebuild
new file mode 100644
index 000000000000..ecebac91b445
--- /dev/null
+++ b/dev-python/pytest-console-scripts/pytest-console-scripts-1.3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Pytest plugin for testing console scripts"
+HOMEPAGE="https://github.com/kvas-it/pytest-console-scripts"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/pytest-4.0.0[${PYTHON_USEDEP}]
+ >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest