summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-05-07 10:24:50 +0200
committerLars Wendler <polynomial-c@gentoo.org>2018-05-07 10:24:50 +0200
commitdd0204b722226cc131f7ed94ccd8470cfc7709c6 (patch)
treebf8b28a814cded37f9b3fca8179f256b7a1b96e0
parentgames-rpg/adonthell: Fixed HOMEPAGE. (diff)
downloadgentoo-dd0204b722226cc131f7ed94ccd8470cfc7709c6.tar.gz
gentoo-dd0204b722226cc131f7ed94ccd8470cfc7709c6.tar.bz2
gentoo-dd0204b722226cc131f7ed94ccd8470cfc7709c6.zip
games-arcade/tuxpuck: Use pkg-config to find freetype
Closes: https://bugs.gentoo.org/654894 Package-Manager: Portage-2.3.36, Repoman-2.3.9
-rw-r--r--games-arcade/tuxpuck/files/tuxpuck-0.8.2-freetype_pkgconfig.patch11
-rw-r--r--games-arcade/tuxpuck/tuxpuck-0.8.2-r2.ebuild4
2 files changed, 14 insertions, 1 deletions
diff --git a/games-arcade/tuxpuck/files/tuxpuck-0.8.2-freetype_pkgconfig.patch b/games-arcade/tuxpuck/files/tuxpuck-0.8.2-freetype_pkgconfig.patch
new file mode 100644
index 000000000000..410024e48dcd
--- /dev/null
+++ b/games-arcade/tuxpuck/files/tuxpuck-0.8.2-freetype_pkgconfig.patch
@@ -0,0 +1,11 @@
+--- tuxpuck-0.8.2/utils/Makefile
++++ tuxpuck-0.8.2/utils/Makefile
+@@ -6,7 +6,7 @@
+ all : ttf2font data2c anim
+
+ ttf2font : ttf2font.c
+- $(CC) $(CFLAGS) ttf2font.c `freetype-config --cflags --libs` -o ttf2font
++ $(CC) $(CFLAGS) ttf2font.c `pkg-config --cflags --libs freetype2` -o ttf2font
+
+ data2c : data2c.c
+ $(CC) $(CFLAGS) data2c.c `sdl-config --cflags --libs` -o data2c
diff --git a/games-arcade/tuxpuck/tuxpuck-0.8.2-r2.ebuild b/games-arcade/tuxpuck/tuxpuck-0.8.2-r2.ebuild
index b1df215d59d0..092a49327277 100644
--- a/games-arcade/tuxpuck/tuxpuck-0.8.2-r2.ebuild
+++ b/games-arcade/tuxpuck/tuxpuck-0.8.2-r2.ebuild
@@ -21,6 +21,7 @@ RDEPEND="
"
DEPEND="${RDEPEND}
media-libs/freetype:2
+ virtual/pkgconfig
"
src_prepare() {
@@ -40,7 +41,8 @@ src_prepare() {
eapply "${FILESDIR}"/${P}-ldflags.patch \
"${FILESDIR}"/${P}-png15.patch \
- "${FILESDIR}"/${P}-parallel.patch
+ "${FILESDIR}"/${P}-parallel.patch \
+ "${FILESDIR}"/${P}-freetype_pkgconfig.patch
}
src_compile() {