summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAgostino Sarubbo <ago@gentoo.org>2016-07-11 08:53:15 +0200
committerAgostino Sarubbo <ago@gentoo.org>2016-07-11 08:53:15 +0200
commitdd4cc119afc8f599c8b39818364891d8f4356540 (patch)
treeb19df760654977275779dba1fac028a4be4e6ba2
parentdev-perl/XML-LibXML: Bump to version 2.12.600 (diff)
downloadgentoo-dd4cc119afc8f599c8b39818364891d8f4356540.tar.gz
gentoo-dd4cc119afc8f599c8b39818364891d8f4356540.tar.bz2
gentoo-dd4cc119afc8f599c8b39818364891d8f4356540.zip
sys-kernel/git-sources: Automated version bump to 4.7_rc7
Package-Manager: portage-2.2.28 Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
-rw-r--r--sys-kernel/git-sources/Manifest1
-rw-r--r--sys-kernel/git-sources/git-sources-4.7_rc7.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/sys-kernel/git-sources/Manifest b/sys-kernel/git-sources/Manifest
index 1de56bf0e389..4ce1ba3a238b 100644
--- a/sys-kernel/git-sources/Manifest
+++ b/sys-kernel/git-sources/Manifest
@@ -5,3 +5,4 @@ DIST patch-4.7-rc3.xz 5479492 SHA256 28302761d18747f9b81e61de6a30f7cde3f818b3b26
DIST patch-4.7-rc4.xz 5524308 SHA256 fc7dd4593658bd667ac4088522b6c357d93ee667e2a04c87a72e0c026c5fe8b7 SHA512 bf4be16500078b567f35b2e6a23b1f4857a548904b17960acf91fc2ea62c3f5cd266e75f42f6fcbef5845ba8d06891a8ffdb30c4da92b18f6d85abf340d15051 WHIRLPOOL 4f031a34e5a4d4e252cd97ab6f038e1d111f6e5e0e5e6256e5d86792793bb8248bb8a77b7828969318ed092e9f321b66a651dc0f6a31cc4b64aa45127434e1bc
DIST patch-4.7-rc5.xz 5556940 SHA256 331a73d6dfe217046ac8ac2669d3775113cbbdca8321c09d1a54223f3b9a0843 SHA512 614dde04eb5883bce1fa834e4a2a7533046dfc78313bd919d83eb35f32a3c27481776e629738db4923675f4ae07d312da0eb9095492f042d3050f02aa2930aa8 WHIRLPOOL 5b6517ca8e8976573d3c79e8a8ec4517eb21a9292d1c18c6b822410ebc850e592ea4546748a382155bceea0342a71ef33b40df55fb3628438cad5f4a2b0ff909
DIST patch-4.7-rc6.xz 5603480 SHA256 25c11cc3164145d622391bf80c09ffdc74a7e83f5688add3841e502586ce0e75 SHA512 4809b177d6ab55db4db10554f9048d1ece069f123443b01f2dcc00fca91aea88f7e84a85cca4a1f75b6514f71ab3f8cc479800b75a3ee1d29684e2f1b857cbe3 WHIRLPOOL b9193fc8110a35988edf59feefc1af188fbd34c92493c61af044c1085a9eef2370c778a2456965845710b7d74d376b8982850d338bc3eac4909c80c3fed43205
+DIST patch-4.7-rc7.xz 5623024 SHA256 2a90ccceed8ba0caed42c00dd8be8e6735637548c7fea5ce73c4ee996eafc6cf SHA512 143891ac4b716f46f0ec7ab0ea2d78b492e01c15d0bbfee8dbbc60c59013d4de5ea00027920e763a8235307b0ba60c877a73a7c1f517dda466f9491ace764182 WHIRLPOOL 8ae9d4655c60c11407f6657914f09a155442717c7bbee822d1006fa9f24e07b4a687700a68b1d5bdfc9c0cfc19db665910f35e8c7eac663f77a78c3d8147cb86
diff --git a/sys-kernel/git-sources/git-sources-4.7_rc7.ebuild b/sys-kernel/git-sources/git-sources-4.7_rc7.ebuild
new file mode 100644
index 000000000000..d666eac10267
--- /dev/null
+++ b/sys-kernel/git-sources/git-sources-4.7_rc7.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+UNIPATCH_STRICTORDER="yes"
+K_NOUSENAME="yes"
+K_NOSETEXTRAVERSION="yes"
+K_NOUSEPR="yes"
+K_SECURITY_UNSUPPORTED="yes"
+K_BASE_VER="4.6"
+K_EXP_GENPATCHES_NOUSE="1"
+ETYPE="sources"
+CKV="${PVR/-r/-git}"
+
+# only use this if it's not an _rc/_pre release
+[ "${PV/_pre}" == "${PV}" ] && [ "${PV/_rc}" == "${PV}" ] && OKV="${PV}"
+inherit kernel-2
+detect_version
+
+DESCRIPTION="The very latest -git version of the Linux kernel"
+HOMEPAGE="https://www.kernel.org"
+SRC_URI="${KERNEL_URI}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+K_EXTRAEINFO="This kernel is not supported by Gentoo due to its unstable and
+experimental nature. If you have any issues, try a matching vanilla-sources
+ebuild -- if the problem is not there, please contact the upstream kernel
+developers at https://bugzilla.kernel.org and on the linux-kernel mailing list to
+report the problem so it can be fixed in time for the next kernel release."
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=sys-devel/patch-2.7.4"
+
+pkg_postinst() {
+ postinst_sources
+}