summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-04-20 16:51:10 +0200
committerDavid Seifert <soap@gentoo.org>2017-04-20 18:37:19 +0200
commitdd4d990ba9c3d69a89f5e784f3b1230eee0f37f1 (patch)
treebe8f83f5ef1456655606757079e0be5beedf3740
parentsci-biology/seqan: [QA] Add missing python metadata variables (diff)
downloadgentoo-dd4d990ba9c3d69a89f5e784f3b1230eee0f37f1.tar.gz
gentoo-dd4d990ba9c3d69a89f5e784f3b1230eee0f37f1.tar.bz2
gentoo-dd4d990ba9c3d69a89f5e784f3b1230eee0f37f1.zip
sci-calculators/units: [QA] Add missing python metadata variables
Package-Manager: Portage-2.3.5, Repoman-2.3.2
-rw-r--r--sci-calculators/units/units-2.13.ebuild13
-rw-r--r--sci-calculators/units/units-2.14-r1.ebuild3
-rw-r--r--sci-calculators/units/units-2.14.ebuild13
3 files changed, 9 insertions, 20 deletions
diff --git a/sci-calculators/units/units-2.13.ebuild b/sci-calculators/units/units-2.13.ebuild
index afe012c7e4ed..50f5c4487c71 100644
--- a/sci-calculators/units/units-2.13.ebuild
+++ b/sci-calculators/units/units-2.13.ebuild
@@ -14,20 +14,15 @@ LICENSE="FDL-1.3 GPL-3"
SLOT="0"
KEYWORDS="alpha amd64 ~arm hppa ppc ppc64 sparc x86 ~amd64-linux ~x86-linux"
IUSE="+units_cur"
+REQUIRED_USE="units_cur? ( ${PYTHON_REQUIRED_USE} )"
-DEPEND="
- sys-libs/readline:=
- units_cur? (
- dev-lang/python-exec:2
- )
-"
RDEPEND="
- ${DEPEND}
+ sys-libs/readline:=
units_cur? (
dev-python/unidecode[${PYTHON_USEDEP}]
${PYTHON_DEPS}
- )
-"
+ )"
+DEPEND=${RDEPEND}
units_cur_prepare() {
local UNITS_PYTHON_MAJOR
diff --git a/sci-calculators/units/units-2.14-r1.ebuild b/sci-calculators/units/units-2.14-r1.ebuild
index 7050f31710f1..e49ef8fd68ee 100644
--- a/sci-calculators/units/units-2.14-r1.ebuild
+++ b/sci-calculators/units/units-2.14-r1.ebuild
@@ -14,6 +14,7 @@ LICENSE="FDL-1.3 GPL-3"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
IUSE="+units_cur"
+REQUIRED_USE="units_cur? ( ${PYTHON_REQUIRED_USE} )"
RDEPEND="
sys-libs/readline:=
@@ -23,8 +24,6 @@ RDEPEND="
)"
DEPEND=${RDEPEND}
-REQUIRED_USE="units_cur? ( ${PYTHON_REQUIRED_USE} )"
-
pkg_setup() {
use units_cur && python-single-r1_pkg_setup
}
diff --git a/sci-calculators/units/units-2.14.ebuild b/sci-calculators/units/units-2.14.ebuild
index 907add868515..8050ca85d339 100644
--- a/sci-calculators/units/units-2.14.ebuild
+++ b/sci-calculators/units/units-2.14.ebuild
@@ -14,20 +14,15 @@ LICENSE="FDL-1.3 GPL-3"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
IUSE="+units_cur"
+REQUIRED_USE="units_cur? ( ${PYTHON_REQUIRED_USE} )"
-DEPEND="
- sys-libs/readline:=
- units_cur? (
- dev-lang/python-exec:2
- )
-"
RDEPEND="
- ${DEPEND}
+ sys-libs/readline:=
units_cur? (
dev-python/unidecode[${PYTHON_USEDEP}]
${PYTHON_DEPS}
- )
-"
+ )"
+DEPEND=${RDEPEND}
units_cur_prepare() {
local UNITS_PYTHON_MAJOR