summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Roman <davidroman96@gmail.com>2017-03-11 13:52:00 +0000
committerAmy Liffey <amynka@gentoo.org>2017-03-15 22:30:18 +0100
commitdda54494010a7f7dc026fb43e80879a7e6ac2089 (patch)
treecf024f21a67609091042141c3e893140f40754db
parentapp-emulation/vagrant: bump to 1.9.2, drop old (diff)
downloadgentoo-dda54494010a7f7dc026fb43e80879a7e6ac2089.tar.gz
gentoo-dda54494010a7f7dc026fb43e80879a7e6ac2089.tar.bz2
gentoo-dda54494010a7f7dc026fb43e80879a7e6ac2089.zip
app-backup/restic: bump to 0.5.0
Closes: #4183
-rw-r--r--app-backup/restic/Manifest1
-rw-r--r--app-backup/restic/restic-0.5.0.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/app-backup/restic/Manifest b/app-backup/restic/Manifest
index 95e41794e4b4..3e5d02e3d77a 100644
--- a/app-backup/restic/Manifest
+++ b/app-backup/restic/Manifest
@@ -1 +1,2 @@
DIST restic-0.4.0.tar.gz 22926188 SHA256 746dbc7b73f5a542be57b71714b243266a011f1d750f56f5100c08a59df1aeac SHA512 ccd15f010f8da3bae3d33698e70ff1d9565f52fb56991b78d35f95493417a4ab050021153d81c424947233255d9553d050f7a66e1c709843fe3b2d323a81f85b WHIRLPOOL 94e6b9ed777a86cb6e46cf734b9280e68cc2ce1ea061c8a94409dca594add1ec24fb736a56e35571302ff5043a60bef7f60ff3b39b038ee128bc815f7d3d48cd
+DIST restic-0.5.0.tar.gz 22937327 SHA256 a8e99087478a076b8a9c7c74d37cd23a56224d8c9b242c171756784ade024fda SHA512 571e4b0aa92a6cd9320f48c46a4b2190576d9328169d54762747dfa024ab280fb41ee377b59f0114d89ebd50bc54488a8cb5e2b36c57959202e848394107bb3c WHIRLPOOL 19fef25a6e2dff3145a6700abb581e7cae3abe5522ee0197f56a572d499824e84ba25a3111c5e71856ffac18d75622766c74c585a44b6db489468050e1c8d59a
diff --git a/app-backup/restic/restic-0.5.0.ebuild b/app-backup/restic/restic-0.5.0.ebuild
new file mode 100644
index 000000000000..1d246f69ba32
--- /dev/null
+++ b/app-backup/restic/restic-0.5.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="restic is a backup program that is fast, efficient and secure"
+HOMEPAGE="https://restic.github.io/"
+SRC_URI="https://github.com/restic/restic/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DOCS=( README.md CONTRIBUTING.md doc/Design.md doc/FAQ.md doc/index.md doc/Manual.md doc/REST_backend.md )
+
+DEPEND="dev-lang/go
+ test? ( sys-fs/fuse )"
+
+RDEPEND="sys-fs/fuse"
+
+src_compile() {
+ local mygoargs=(
+ -v
+ -work
+ -x
+ -tags release
+ -ldflags "-w -X main.version=${PV}"
+ -o "${S}"/restic cmds/restic
+ )
+
+ GOPATH="${S}:${S}/vendor" go build "${mygoargs[@]}" || die
+}
+
+src_test() {
+ GOPATH="${S}:${S}/vendor" go test -v -work -x restic/... cmds/... || die
+}
+
+src_install() {
+ dobin restic
+ einstalldocs
+}