summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGioacchino Mazzurco <gio@eigenlab.org>2019-02-11 15:20:53 -0300
committerAndreas Sturmlechner <asturm@gentoo.org>2019-05-15 14:46:33 +0200
commitde94a2f07ced4c0020367e75a447acddd382b7a8 (patch)
treec5ac7adf41413850d2dabd0df95aa7546238d3ae
parentmedia-gfx/rawtherapee: bump to EAPI=7 (diff)
downloadgentoo-de94a2f07ced4c0020367e75a447acddd382b7a8.tar.gz
gentoo-de94a2f07ced4c0020367e75a447acddd382b7a8.tar.bz2
gentoo-de94a2f07ced4c0020367e75a447acddd382b7a8.zip
net-p2p/retroshare: Drop 0.6.9999 ebuild
Remove un-maintainable ebuild Signed-off-by: Gioacchino Mazzurco <gio@eigenlab.org> Closes: https://github.com/gentoo/gentoo/pull/11029 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--net-p2p/retroshare/metadata.xml4
-rw-r--r--net-p2p/retroshare/retroshare-0.6.9999.ebuild120
2 files changed, 3 insertions, 121 deletions
diff --git a/net-p2p/retroshare/metadata.xml b/net-p2p/retroshare/metadata.xml
index 1e20d558f6ee..51ddf9dc82ee 100644
--- a/net-p2p/retroshare/metadata.xml
+++ b/net-p2p/retroshare/metadata.xml
@@ -23,10 +23,12 @@
<flag name="feedreader">Enables the Feedreader plugin</flag>
<flag name="gnome-keyring">Enables potentially insecure autologin capability via Gnome Keyring</flag>
<flag name="gui">Enables the GUI version of RetroShare</flag>
- <flag name="settings-api">Enables settings control via API</flag>
+ <flag name="jsonapi">Enables the new RetroShare JSON API</flag>
+ <flag name="service">Enables the new RetroShare service controllable only trough JSON API</flag>
<flag name="sqlcipher">Enables GXS database encryption via SQLCipher</flag>
<flag name="voip">Enables VOIP plugin</flag>
<flag name="webui">Enables Web interface and API support</flag>
+ <flag name="xapian">Enables GXS content indexing and search trough Xapian</flag>
</use>
<upstream>
<bugs-to>https://github.com/RetroShare/RetroShare/issues</bugs-to>
diff --git a/net-p2p/retroshare/retroshare-0.6.9999.ebuild b/net-p2p/retroshare/retroshare-0.6.9999.ebuild
deleted file mode 100644
index a7718e73f904..000000000000
--- a/net-p2p/retroshare/retroshare-0.6.9999.ebuild
+++ /dev/null
@@ -1,120 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-EGIT_REPO_URI="https://github.com/RetroShare/RetroShare.git"
-inherit desktop git-r3 gnome2-utils qmake-utils versionator
-
-DESCRIPTION="P2P private sharing application"
-HOMEPAGE="http://retroshare.net"
-
-# pegmarkdown can also be used with MIT
-LICENSE="AGPL-3 GPL-2 GPL-3 Apache-2.0 LGPL-2.1"
-SLOT="0"
-KEYWORDS=""
-
-IUSE="cli control-socket gnome-keyring +gui settings-api +sqlcipher +webui"
-REQUIRED_USE="
- || ( cli gui )
- settings-api? ( || ( control-socket webui ) )"
-
-RDEPEND="
- app-arch/bzip2
- dev-libs/openssl:0=
- >=dev-libs/rapidjson-1.1.0
- net-libs/libupnp:0=
- sys-libs/zlib
- control-socket? ( dev-qt/qtnetwork:5 )
- gnome-keyring? ( gnome-base/libgnome-keyring )
- gui? (
- dev-qt/qtcore:5
- dev-qt/qtmultimedia:5
- dev-qt/qtnetwork:5
- dev-qt/qtprintsupport:5
- dev-qt/qtscript:5
- dev-qt/qtxml:5
- dev-qt/qtgui:5
- dev-qt/qtwidgets:5
- dev-qt/qtx11extras:5
- x11-libs/libX11
- x11-libs/libXScrnSaver
- )
- settings-api? ( dev-qt/qtcore:5 )
- sqlcipher? ( dev-db/sqlcipher )
- !sqlcipher? ( dev-db/sqlite:3 )
- webui? ( net-libs/libmicrohttpd )"
-
-DEPEND="${RDEPEND}
- gui? ( dev-qt/designer:5 )
- dev-qt/qtcore:5
- virtual/pkgconfig
-"
-
-src_configure() {
- local qConfigs=()
-
- qConfigs+=( $(usex cli '' 'no_')retroshare_nogui )
- qConfigs+=( $(usex control-socket '' 'no_')libresapilocalserver )
- qConfigs+=( $(usex gnome-keyring '' 'no_')rs_autologin )
- qConfigs+=( $(usex gui '' 'no_')retroshare_gui )
- qConfigs+=( $(usex settings-api '' 'no_')libresapi_settings )
- qConfigs+=( $(usex sqlcipher '' 'no_')sqlcipher )
- qConfigs+=( $(usex webui '' 'no_')libresapihttpserver )
-
- eqmake5 CONFIG+="${qConfigs[*]}"
-}
-
-src_install() {
- use cli && dobin retroshare-nogui/src/retroshare-nogui
- use gui && dobin retroshare-gui/src/retroshare
-
- insinto /usr/share/retroshare
- doins libbitdht/src/bitdht/bdboot.txt
-
- use webui && doins -r libresapi/src/webui
-
- dodoc README.md
- make_desktop_entry retroshare
-
- for i in 24 48 64 128 ; do
- doicon -s ${i} "data/${i}x${i}/apps/retroshare.png"
- done
-}
-
-pkg_pretend() {
- if ! use sqlcipher; then
- ewarn "You have disabled GXS database encryption, ${PN} will use SQLite"
- ewarn "instead of SQLCipher for GXS databases."
- ewarn "Builds using SQLite and builds using SQLCipher have incompatible"
- ewarn "database format, so you will need to manually delete GXS"
- ewarn "database (loosing all your GXS data and identities) when you"
- ewarn "toggle sqlcipher USE flag."
- fi
-}
-
-pkg_preinst() {
- local ver
- for ver in ${REPLACING_VERSIONS}; do
- if ! version_is_at_least 0.5.9999 ${ver}; then
- ewarn "You are upgrading from Retroshare 0.5.* to ${PV}"
- ewarn "Version 0.6.* is backward-incompatible with 0.5 branch"
- ewarn "and clients with 0.6.* can not connect to clients that have 0.5.*"
- ewarn "It's recommended to drop all your configuration and either"
- ewarn "generate a new certificate or import existing from a backup"
- break
- fi
- if version_is_at_least 0.6.0 ${ver} && ! version_is_at_least 0.6.4 ${ver}; then
- elog "Main executable has been renamed upstream from RetroShare06 to retroshare"
- break
- fi
- done
-}
-
-pkg_postinst() {
- gnome2_icon_cache_update
-}
-
-pkg_postrm() {
- gnome2_icon_cache_update
-}