summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2019-05-22 13:32:52 +0200
committerAlexis Ballier <aballier@gentoo.org>2019-05-23 13:03:38 +0200
commitdeb74b91a6a63ca52146942b8d0b4118a5c4e167 (patch)
tree8a92ad8a81193095979242866521c749ab20f8c7
parentnet-mail/qmail-autoresponder: bump version to 2.0 (diff)
downloadgentoo-deb74b91a6a63ca52146942b8d0b4118a5c4e167.tar.gz
gentoo-deb74b91a6a63ca52146942b8d0b4118a5c4e167.tar.bz2
gentoo-deb74b91a6a63ca52146942b8d0b4118a5c4e167.zip
media-libs/zimg: bump to 2.8
Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
-rw-r--r--media-libs/zimg/Manifest1
-rw-r--r--media-libs/zimg/zimg-2.8.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/media-libs/zimg/Manifest b/media-libs/zimg/Manifest
index 2545c19d8587..71b6acd6d38e 100644
--- a/media-libs/zimg/Manifest
+++ b/media-libs/zimg/Manifest
@@ -1,3 +1,4 @@
DIST zimg-2.5.tar.gz 213054 BLAKE2B 0532693c11c1b2bcc0d5bde3a0bc16bf4f736ceff5fcda5d9bf491fcebe7e8be538041cc536e40bc110e438370c8599ce0be35f71cea00429b16c6eeb680cb86 SHA512 7fc48c704b434d837c36d4bafc51b35789eaf90fc81a68dcd7ec546f1e82a3e41c53263f8d381541d5c0ce58e25dddf0adaf1c3575512842ae633b5581778938
DIST zimg-2.7.4.tar.gz 246376 BLAKE2B b6a21a1f7ca5106810485a69bb4e8f1d59d67fe3a619fd0ac412b1e441fe2d8892f64826666fbdfa48ae441fa5a21512b5ba0977eeaca7dcb7e0fcc43447f6e4 SHA512 adbb525b2611ef5267a4c0d4e8c6dd164c2814241c4d58d5356545b23dcf0cbeabb140141ae6ff0e70ef8e0741e351cbfadbadd60923061ddd693a2c3d9e5fde
DIST zimg-2.7.5.tar.gz 246416 BLAKE2B a0ce1497356238aee5d3965a7ec57f1591d51c5df2475fb05d208a07f1431f073f8caaac110775fb17c6df8f887ed974b53f262e01f5532de13dc4c539958c1b SHA512 600139f86b074f2ed9614daa58d969465fa3d1578d8165bd2f841193f7b793c4b36389064dd4eee8e01e66a745d1c71c62e5bdb0b5283e54c435ed4a130a5b3b
+DIST zimg-2.8.tar.gz 265363 BLAKE2B a8982c64325e0089617136fcd5d6ee429ab861e3b9445b9cc0292bd3bbd3abb5783e94983e3e802fd9e59c2c7089eeea176d1eda4f3a850379cfc4fb36cbc408 SHA512 1e89087a756798a7ae3bfae3bc8244b29ae8ae7f04f53bdf6c4d4de3cb11412dc1eecd95a4a121bb9077437e633f8fbb665522ff8112ade806d9191ea4b5f7bf
diff --git a/media-libs/zimg/zimg-2.8.ebuild b/media-libs/zimg/zimg-2.8.ebuild
new file mode 100644
index 000000000000..d20d4bf58406
--- /dev/null
+++ b/media-libs/zimg/zimg-2.8.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} = *9999* ]] ; then
+ EGIT_REPO_URI="https://github.com/sekrit-twc/zimg"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/sekrit-twc/zimg/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+ S="${WORKDIR}/${PN}-release-${PV}/"
+fi
+inherit autotools multilib-minimal
+
+DESCRIPTION="Scaling, colorspace conversion, and dithering library"
+HOMEPAGE="https://github.com/sekrit-twc/zimg"
+
+LICENSE="WTFPL-2"
+SLOT="0"
+IUSE="static-libs cpu_flags_x86_sse"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ $(use_enable cpu_flags_x86_sse x86simd)
+}