summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2021-10-26 12:10:51 +0200
committerPatrick McLean <chutzpah@gentoo.org>2021-10-26 10:49:32 -0700
commitdf0ed7469531e64f44cd332ca179e72acf0ef402 (patch)
tree5aed9a6b246bfac0ccbd33210bfe2fc220acf0b1
parentnet-wireless/hackrf-tools: git repo move (diff)
downloadgentoo-df0ed7469531e64f44cd332ca179e72acf0ef402.tar.gz
gentoo-df0ed7469531e64f44cd332ca179e72acf0ef402.tar.bz2
gentoo-df0ed7469531e64f44cd332ca179e72acf0ef402.zip
sys-cluster/ceph: remove unused patches
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Closes: https://github.com/gentoo/gentoo/pull/22710 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
-rw-r--r--sys-cluster/ceph/files/ceph-14.2.10-build-without-mgr.patch111
-rw-r--r--sys-cluster/ceph/files/ceph-14.2.5-no-virtualenvs.patch39
-rw-r--r--sys-cluster/ceph/files/ceph-15.2.0-no-virtualenvs.patch73
-rw-r--r--sys-cluster/ceph/files/ceph-15.2.5-missing-includes.patch12
4 files changed, 0 insertions, 235 deletions
diff --git a/sys-cluster/ceph/files/ceph-14.2.10-build-without-mgr.patch b/sys-cluster/ceph/files/ceph-14.2.10-build-without-mgr.patch
deleted file mode 100644
index 0742945c0184..000000000000
--- a/sys-cluster/ceph/files/ceph-14.2.10-build-without-mgr.patch
+++ /dev/null
@@ -1,111 +0,0 @@
-commit 41c1cee88b38bc43002b232ede42dc157364f61a
-Author: Casey Bodley <cbodley@redhat.com>
-Date: Fri Nov 1 16:04:37 2019 -0400
-
- cmake: define mgr_cap_obj library when WITH_MGR=OFF
-
- resolves the cmake error when WITH_MGR=OFF:
-
- Error evaluating generator expression:
-
- $<TARGET_OBJECTS:mgr_cap_obj>
-
- Objects of target "mgr_cap_obj" referenced but no such target exists.
- Call Stack (most recent call first):
- src/mon/CMakeLists.txt:34 (add_library)
-
- Signed-off-by: Casey Bodley <cbodley@redhat.com>
-
-diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
-index 275a8ebd17..c2a9d7a669 100644
---- a/src/CMakeLists.txt
-+++ b/src/CMakeLists.txt
-@@ -473,9 +473,7 @@ if(WITH_LIBRADOSSTRIPER)
- add_subdirectory(libradosstriper)
- endif()
-
--if(WITH_MGR)
-- add_subdirectory(mgr)
--endif()
-+add_subdirectory(mgr)
-
- set(librados_config_srcs
- librados-config.cc)
-diff --git a/src/mgr/CMakeLists.txt b/src/mgr/CMakeLists.txt
-index 79227bcc1d..e69335eb69 100644
---- a/src/mgr/CMakeLists.txt
-+++ b/src/mgr/CMakeLists.txt
-@@ -1,37 +1,39 @@
- add_library(mgr_cap_obj OBJECT
- MgrCap.cc)
-
--set(mgr_srcs
-- ${CMAKE_SOURCE_DIR}/src/ceph_mgr.cc
-- ${CMAKE_SOURCE_DIR}/src/mon/PGMap.cc
-- ActivePyModule.cc
-- ActivePyModules.cc
-- BaseMgrModule.cc
-- BaseMgrStandbyModule.cc
-- ClusterState.cc
-- DaemonHealthMetricCollector.cc
-- DaemonServer.cc
-- DaemonState.cc
-- Gil.cc
-- Mgr.cc
-- MgrStandby.cc
-- OSDPerfMetricTypes.cc
-- OSDPerfMetricCollector.cc
-- PyFormatter.cc
-- PyModule.cc
-- PyModuleRegistry.cc
-- PyModuleRunner.cc
-- PyOSDMap.cc
-- StandbyPyModules.cc
-- mgr_commands.cc
-- $<TARGET_OBJECTS:mgr_cap_obj>)
--add_executable(ceph-mgr ${mgr_srcs})
--target_include_directories(ceph-mgr SYSTEM PRIVATE "${PYTHON_INCLUDE_DIRS}")
--target_link_libraries(ceph-mgr
-- osdc client heap_profiler
-- global-static ceph-common
-- Boost::python${MGR_PYTHON_VERSION_MAJOR}${MGR_PYTHON_VERSION_MINOR}
-- ${MGR_PYTHON_LIBRARIES} ${CMAKE_DL_LIBS} ${GSSAPI_LIBRARIES})
--set_target_properties(ceph-mgr PROPERTIES
-- POSITION_INDEPENDENT_CODE ${EXE_LINKER_USE_PIE})
--install(TARGETS ceph-mgr DESTINATION bin)
-+if(WITH_MGR)
-+ set(mgr_srcs
-+ ${CMAKE_SOURCE_DIR}/src/ceph_mgr.cc
-+ ${CMAKE_SOURCE_DIR}/src/mon/PGMap.cc
-+ ActivePyModule.cc
-+ ActivePyModules.cc
-+ BaseMgrModule.cc
-+ BaseMgrStandbyModule.cc
-+ ClusterState.cc
-+ DaemonHealthMetricCollector.cc
-+ DaemonServer.cc
-+ DaemonState.cc
-+ Gil.cc
-+ Mgr.cc
-+ MgrStandby.cc
-+ OSDPerfMetricTypes.cc
-+ OSDPerfMetricCollector.cc
-+ PyFormatter.cc
-+ PyModule.cc
-+ PyModuleRegistry.cc
-+ PyModuleRunner.cc
-+ PyOSDMap.cc
-+ StandbyPyModules.cc
-+ mgr_commands.cc
-+ $<TARGET_OBJECTS:mgr_cap_obj>)
-+ add_executable(ceph-mgr ${mgr_srcs})
-+ target_include_directories(ceph-mgr SYSTEM PRIVATE "${PYTHON_INCLUDE_DIRS}")
-+ target_link_libraries(ceph-mgr
-+ osdc client heap_profiler
-+ global-static ceph-common
-+ Boost::python${MGR_PYTHON_VERSION_MAJOR}${MGR_PYTHON_VERSION_MINOR}
-+ ${MGR_PYTHON_LIBRARIES} ${CMAKE_DL_LIBS} ${GSSAPI_LIBRARIES})
-+ set_target_properties(ceph-mgr PROPERTIES
-+ POSITION_INDEPENDENT_CODE ${EXE_LINKER_USE_PIE})
-+ install(TARGETS ceph-mgr DESTINATION bin)
-+endif()
diff --git a/sys-cluster/ceph/files/ceph-14.2.5-no-virtualenvs.patch b/sys-cluster/ceph/files/ceph-14.2.5-no-virtualenvs.patch
deleted file mode 100644
index 5b7cb41c87ad..000000000000
--- a/sys-cluster/ceph/files/ceph-14.2.5-no-virtualenvs.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-diff --git a/src/pybind/mgr/dashboard/CMakeLists.txt b/src/pybind/mgr/dashboard/CMakeLists.txt
-index b6c7861838..8ce95a93a5 100644
---- a/src/pybind/mgr/dashboard/CMakeLists.txt
-+++ b/src/pybind/mgr/dashboard/CMakeLists.txt
-@@ -2,7 +2,7 @@ set(MGR_DASHBOARD_VIRTUALENV ${CEPH_BUILD_VIRTUALENV}/mgr-dashboard-virtualenv)
-
- add_custom_target(mgr-dashboard-test-venv
- COMMAND
-- ${CMAKE_SOURCE_DIR}/src/tools/setup-virtualenv.sh --python=${MGR_PYTHON_EXECUTABLE} ${MGR_DASHBOARD_VIRTUALENV}
-+ #${CMAKE_SOURCE_DIR}/src/tools/setup-virtualenv.sh --python=${MGR_PYTHON_EXECUTABLE} ${MGR_DASHBOARD_VIRTUALENV}
- WORKING_DIRECTORY ${CMAKE_SOURCE_DIR}/src/pybind/mgr/dashboard
- COMMENT "dashboard tests virtualenv is being created")
- add_dependencies(tests mgr-dashboard-test-venv)
-@@ -14,9 +14,9 @@ function(add_npm_command)
- set(multi_kw COMMAND DEPENDS)
- cmake_parse_arguments(NC "${options}" "${single_kw}" "${multi_kw}" ${ARGN})
- string(REPLACE ";" " " command "${NC_COMMAND}")
-- if(NC_NODEENV)
-- string(REGEX REPLACE "^(.*(npm|npx) .*)$" ". ${mgr-dashboard-nodeenv-dir}/bin/activate && \\1 && deactivate" command ${command})
-- endif()
-+ #if(NC_NODEENV)
-+ # string(REGEX REPLACE "^(.*(npm|npx) .*)$" ". ${mgr-dashboard-nodeenv-dir}/bin/activate && \\1 && deactivate" command ${command})
-+ #endif()
- string(REPLACE " " ";" command "${command}")
- add_custom_command(
- OUTPUT "${NC_OUTPUT}"
-@@ -41,9 +41,9 @@ else()
-
- add_custom_command(
- OUTPUT "${mgr-dashboard-nodeenv-dir}/bin/npm"
-- COMMAND ${CMAKE_SOURCE_DIR}/src/tools/setup-virtualenv.sh --python=${MGR_PYTHON_EXECUTABLE} ${mgr-dashboard-nodeenv-dir}
-- COMMAND ${mgr-dashboard-nodeenv-dir}/bin/pip install nodeenv
-- COMMAND ${mgr-dashboard-nodeenv-dir}/bin/nodeenv -p --node=10.13.0
-+ #COMMAND ${CMAKE_SOURCE_DIR}/src/tools/setup-virtualenv.sh --python=${MGR_PYTHON_EXECUTABLE} ${mgr-dashboard-nodeenv-dir}
-+ #COMMAND ${mgr-dashboard-nodeenv-dir}/bin/pip install nodeenv
-+ #COMMAND ${mgr-dashboard-nodeenv-dir}/bin/nodeenv -p --node=10.13.0
- WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}
- COMMENT "dashboard nodeenv is being installed"
- )
diff --git a/sys-cluster/ceph/files/ceph-15.2.0-no-virtualenvs.patch b/sys-cluster/ceph/files/ceph-15.2.0-no-virtualenvs.patch
deleted file mode 100644
index 097639c1bb79..000000000000
--- a/sys-cluster/ceph/files/ceph-15.2.0-no-virtualenvs.patch
+++ /dev/null
@@ -1,73 +0,0 @@
-diff --git a/cmake/modules/AddCephTest.cmake b/cmake/modules/AddCephTest.cmake
-index c9ee8c1b8f..09f75543da 100644
---- a/cmake/modules/AddCephTest.cmake
-+++ b/cmake/modules/AddCephTest.cmake
-@@ -68,14 +68,6 @@ function(add_tox_test name)
- endif()
- string(REPLACE ";" "," tox_envs "${tox_envs}")
- find_package(Python3 QUIET REQUIRED)
-- add_custom_command(
-- OUTPUT ${venv_path}/bin/activate
-- COMMAND ${CMAKE_SOURCE_DIR}/src/tools/setup-virtualenv.sh --python="${Python3_EXECUTABLE}" ${venv_path}
-- WORKING_DIRECTORY ${tox_path}
-- COMMENT "preparing venv for ${name}")
-- add_custom_target(${name}-venv
-- DEPENDS ${venv_path}/bin/activate)
-- add_dependencies(tests ${name}-venv)
- add_test(
- NAME ${test_name}
- COMMAND ${CMAKE_SOURCE_DIR}/src/script/run_tox.sh
-diff --git a/src/ceph-volume/CMakeLists.txt b/src/ceph-volume/CMakeLists.txt
-index 4224499c47..9a6c87595b 100644
---- a/src/ceph-volume/CMakeLists.txt
-+++ b/src/ceph-volume/CMakeLists.txt
-@@ -8,22 +8,6 @@ if(FREEBSD)
- add_subdirectory(plugin/zfs)
- endif()
-
--# Required for running ceph-volume inventory in a vstart environment
--set(CEPH_VOLUME_VIRTUALENV ${CEPH_BUILD_VIRTUALENV}/ceph-volume-virtualenv)
--
--add_custom_command(
-- OUTPUT ${CEPH_VOLUME_VIRTUALENV}/bin/python
-- COMMAND ${CMAKE_SOURCE_DIR}/src/tools/setup-virtualenv.sh --python=${Python_EXECUTABLE} ${CEPH_VOLUME_VIRTUALENV}
-- WORKING_DIRECTORY ${CMAKE_SOURCE_DIR}/src/ceph-volume
-- COMMENT "ceph-volume venv is being created")
--
--add_custom_command(
-- OUTPUT ${CEPH_VOLUME_VIRTUALENV}/bin/ceph-volume
-- DEPENDS ${CEPH_VOLUME_VIRTUALENV}/bin/python
-- COMMAND . ${CEPH_VOLUME_VIRTUALENV}/bin/activate && ${CEPH_VOLUME_VIRTUALENV}/bin/python setup.py develop && deactivate
-- WORKING_DIRECTORY ${CMAKE_SOURCE_DIR}/src/ceph-volume
-- COMMENT "${CMAKE_SOURCE_DIR}/src/ceph-volume")
--
- add_custom_target(ceph-volume-venv-setup
- DEPENDS ${CEPH_VOLUME_VIRTUALENV}/bin/ceph-volume)
-
-diff --git a/src/pybind/mgr/dashboard/CMakeLists.txt b/src/pybind/mgr/dashboard/CMakeLists.txt
-index 9a8a03f0a8..8fbf65988e 100644
---- a/src/pybind/mgr/dashboard/CMakeLists.txt
-+++ b/src/pybind/mgr/dashboard/CMakeLists.txt
-@@ -5,9 +5,6 @@ function(add_npm_command)
- set(multi_kw COMMAND DEPENDS)
- cmake_parse_arguments(NC "${options}" "${single_kw}" "${multi_kw}" ${ARGN})
- string(REPLACE ";" " " command "${NC_COMMAND}")
-- if(NC_NODEENV)
-- string(REGEX REPLACE "^(.*(npm|npx) .*)$" ". ${mgr-dashboard-nodeenv-dir}/bin/activate && \\1 && deactivate" command ${command})
-- endif()
- string(REPLACE " " ";" command "${command}")
- add_custom_command(
- OUTPUT "${NC_OUTPUT}"
-@@ -29,10 +26,8 @@ else()
- set(nodeenv NODEENV)
-
- add_custom_command(
-- OUTPUT "${mgr-dashboard-nodeenv-dir}/bin/npm"
-- COMMAND ${CMAKE_SOURCE_DIR}/src/tools/setup-virtualenv.sh --python=${MGR_PYTHON_EXECUTABLE} ${mgr-dashboard-nodeenv-dir}
-- COMMAND ${mgr-dashboard-nodeenv-dir}/bin/pip install nodeenv
-- COMMAND ${mgr-dashboard-nodeenv-dir}/bin/nodeenv -p --node=10.18.1
-+ OUTPUT "/bin/npm"
-+ COMMAND /bin/nodeenv -p --node=10.18.1
- WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}
- COMMENT "dashboard nodeenv is being installed"
- )
diff --git a/sys-cluster/ceph/files/ceph-15.2.5-missing-includes.patch b/sys-cluster/ceph/files/ceph-15.2.5-missing-includes.patch
deleted file mode 100644
index 5f4ed843ddc3..000000000000
--- a/sys-cluster/ceph/files/ceph-15.2.5-missing-includes.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff --git a/src/tools/rbd/action/Bench.cc b/src/tools/rbd/action/Bench.cc
-index aa6edbc18b..90c551c179 100644
---- a/src/tools/rbd/action/Bench.cc
-+++ b/src/tools/rbd/action/Bench.cc
-@@ -9,6 +9,7 @@
- #include "common/ceph_mutex.h"
- #include "include/types.h"
- #include "global/signal_handler.h"
-+#include <atomic>
- #include <iostream>
- #include <boost/accumulators/accumulators.hpp>
- #include <boost/accumulators/statistics/stats.hpp>