summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>2017-09-27 11:57:55 +0200
committerMike Gilbert <floppym@gentoo.org>2017-09-27 15:57:01 -0400
commitdf512ab44cead49b030609ace0e9f09f486c2a7e (patch)
treee32e91c96642f2b972260717d75da6c12448b9be
parentapp-i18n/fcitx-sayura: Call gnome2_icon_cache_update(). (diff)
downloadgentoo-df512ab44cead49b030609ace0e9f09f486c2a7e.tar.gz
gentoo-df512ab44cead49b030609ace0e9f09f486c2a7e.tar.bz2
gentoo-df512ab44cead49b030609ace0e9f09f486c2a7e.zip
app-i18n/fcitx-sayura: Version bump (0.1.2).
-rw-r--r--app-i18n/fcitx-sayura/Manifest1
-rw-r--r--app-i18n/fcitx-sayura/fcitx-sayura-0.1.2.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/app-i18n/fcitx-sayura/Manifest b/app-i18n/fcitx-sayura/Manifest
index 37d605791ef3..4f29836bbb2f 100644
--- a/app-i18n/fcitx-sayura/Manifest
+++ b/app-i18n/fcitx-sayura/Manifest
@@ -1 +1,2 @@
DIST fcitx-sayura-0.1.1.tar.xz 18756 SHA256 36b5d79fed0cefaff7832c82473404e96d68cc8560b1d626884604b0aad7bea6 SHA512 1eda91ae985df65982cf6f4e67b676bb8eb7117cd1aad7c2a90e81c13fa2a806bbff5eda7bb7e797cb26cb46bbda51931ecffd50384a89ead24ad90777183dc3 WHIRLPOOL ddcec7ba970868795df0ccf4eb3ebacb9a9ec29f6f05762fb5253ca6cc59fab78459fc11cb715bcc53856e5093378fb99f572ccd615fe84bbe053574efa1b69f
+DIST fcitx-sayura-0.1.2.tar.xz 25400 SHA256 4cf1c26625efbcae05e6a741b6f955d85c4d4970ab0642fd9ecdb1ac6d757f74 SHA512 2118c95d4f831e5f4e0af0549ae3eb4f16bff8b30b03452837bd14f35fcb524f730b27ceb7c14cf6a4db7400a67070929a75465195b5524187e97c7ca02de466 WHIRLPOOL 1fb0146a639ae74b51185c2eef86bf7a5e5e424d5d3d4cb0c6c21357ca55c0ad527aade5a161d9cbcfadde3dee721fb444f6adf5cdc5ea8603bb33c3de948e66
diff --git a/app-i18n/fcitx-sayura/fcitx-sayura-0.1.2.ebuild b/app-i18n/fcitx-sayura/fcitx-sayura-0.1.2.ebuild
new file mode 100644
index 000000000000..725a094c5115
--- /dev/null
+++ b/app-i18n/fcitx-sayura/fcitx-sayura-0.1.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit cmake-utils gnome2-utils
+
+if [[ "${PV}" =~ (^|\.)9999$ ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/fcitx/fcitx-sayura"
+fi
+
+DESCRIPTION="Sinhala Sayura input method for Fcitx"
+HOMEPAGE="https://fcitx-im.org/ https://github.com/fcitx/fcitx-sayura"
+if [[ "${PV}" =~ (^|\.)9999$ ]]; then
+ SRC_URI=""
+else
+ SRC_URI="https://download.fcitx-im.org/${PN}/${P}.tar.xz"
+fi
+
+LICENSE="GPL-2+"
+SLOT="4"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND=">=app-i18n/fcitx-4.2.9:4
+ virtual/libiconv
+ virtual/libintl"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=()
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}