summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-17 13:15:20 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-17 13:22:45 +0200
commitdf52e18311bd53a7f72d041e370bb5ebbae617a4 (patch)
tree445968ebe11402da3a243ec5f56d95768f6268d6
parentsci-physics/lammps: Removing old packages. (diff)
downloadgentoo-df52e18311bd53a7f72d041e370bb5ebbae617a4.tar.gz
gentoo-df52e18311bd53a7f72d041e370bb5ebbae617a4.tar.bz2
gentoo-df52e18311bd53a7f72d041e370bb5ebbae617a4.zip
dev-util/wstool: initial import. ebuild by me.
Package-Manager: portage-2.2.20.1
-rw-r--r--dev-util/wstool/Manifest1
-rw-r--r--dev-util/wstool/files/prefix.patch22
-rw-r--r--dev-util/wstool/metadata.xml5
-rw-r--r--dev-util/wstool/wstool-0.1.10.ebuild62
-rw-r--r--dev-util/wstool/wstool-9999.ebuild62
5 files changed, 152 insertions, 0 deletions
diff --git a/dev-util/wstool/Manifest b/dev-util/wstool/Manifest
new file mode 100644
index 000000000000..cbac4c0955d3
--- /dev/null
+++ b/dev-util/wstool/Manifest
@@ -0,0 +1 @@
+DIST wstool-0.1.10.tar.gz 73404 SHA256 2810f7f384b45bc653e006e0d473ed66a3ba88e237792a92955bc61fcef61b7c SHA512 8b5924844e8ff0ddcce3302b550493a9bbe525c7c7d7f5a23e49d4734649f50893ca0f2e5dbd05b20ee73d31666d61a4c3035e7d30e6053bfe8ff5c6aa9aafde WHIRLPOOL b9a6399e0dfb894685b7ed83210fe2920bdcfb2a426684829c65fec33b3963eb6cde3f7c35f9f16194306731bb366ba54ce48ba10805ff70c7eaf0a094d7f15c
diff --git a/dev-util/wstool/files/prefix.patch b/dev-util/wstool/files/prefix.patch
new file mode 100644
index 000000000000..8737a58f0cff
--- /dev/null
+++ b/dev-util/wstool/files/prefix.patch
@@ -0,0 +1,22 @@
+Index: wstool-0.1.10/setup.py
+===================================================================
+--- wstool-0.1.10.orig/setup.py
++++ wstool-0.1.10/setup.py
+@@ -23,15 +23,9 @@ def get_version():
+ def _resolve_prefix(prefix, type):
+ osx_system_prefix = '/System/Library/Frameworks/Python.framework/Versions'
+ if type == 'man':
+- if prefix == '/usr':
+- return '/usr/share'
+- if sys.prefix.startswith(osx_system_prefix):
+- return '/usr/share'
++ return os.path.join(prefix, 'share')
+ elif type == 'bash_comp':
+- if prefix == '/usr':
+- return '/'
+- if sys.prefix.startswith(osx_system_prefix):
+- return '/'
++ return os.path.join(prefix, '../')
+ elif type == 'zsh_comp':
+ if sys.prefix.startswith(osx_system_prefix):
+ return '/usr'
diff --git a/dev-util/wstool/metadata.xml b/dev-util/wstool/metadata.xml
new file mode 100644
index 000000000000..c42ea5b15cf6
--- /dev/null
+++ b/dev-util/wstool/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ros</herd>
+</pkgmetadata>
diff --git a/dev-util/wstool/wstool-0.1.10.ebuild b/dev-util/wstool/wstool-0.1.10.ebuild
new file mode 100644
index 000000000000..962d9993ae9e
--- /dev/null
+++ b/dev-util/wstool/wstool-0.1.10.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+SCM=""
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SCM="git-r3"
+ EGIT_REPO_URI="https://github.com/vcstools/wstool"
+fi
+
+inherit ${SCM} distutils-r1
+
+DESCRIPTION="Commands to manage several local SCM repositories for ROS"
+HOMEPAGE="http://wiki.ros.org/wstool"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="http://download.ros.org/downloads/${PN}/${P}.tar.gz
+ http://github.com/vcstools/wstool/archive/${PV}.tar.gz -> ${P}.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/vcstools[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/sphinx
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-vcs/git
+ dev-vcs/bzr
+ dev-vcs/mercurial
+ dev-vcs/subversion
+ )
+"
+
+PATCHES=( "${FILESDIR}/prefix.patch" )
+DISTUTILS_IN_SOURCE_BUILD="yes"
+
+python_test() {
+ # From travis.yml
+ # Set git config to silence some stuff in the tests
+ git config --global user.email "foo@example.com"
+ git config --global user.name "Foo Bar"
+ # Set the hg user
+ echo -e "[ui]\nusername = Your Name <your@mail.com>" >> ~/.hgrc
+ # Set the bzr user
+ bzr whoami "Your Name <name@example.com>"
+ # command to run tests
+ nosetests --with-coverage --cover-package=wstool || die
+}
diff --git a/dev-util/wstool/wstool-9999.ebuild b/dev-util/wstool/wstool-9999.ebuild
new file mode 100644
index 000000000000..962d9993ae9e
--- /dev/null
+++ b/dev-util/wstool/wstool-9999.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+SCM=""
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SCM="git-r3"
+ EGIT_REPO_URI="https://github.com/vcstools/wstool"
+fi
+
+inherit ${SCM} distutils-r1
+
+DESCRIPTION="Commands to manage several local SCM repositories for ROS"
+HOMEPAGE="http://wiki.ros.org/wstool"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="http://download.ros.org/downloads/${PN}/${P}.tar.gz
+ http://github.com/vcstools/wstool/archive/${PV}.tar.gz -> ${P}.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/vcstools[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/sphinx
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-vcs/git
+ dev-vcs/bzr
+ dev-vcs/mercurial
+ dev-vcs/subversion
+ )
+"
+
+PATCHES=( "${FILESDIR}/prefix.patch" )
+DISTUTILS_IN_SOURCE_BUILD="yes"
+
+python_test() {
+ # From travis.yml
+ # Set git config to silence some stuff in the tests
+ git config --global user.email "foo@example.com"
+ git config --global user.name "Foo Bar"
+ # Set the hg user
+ echo -e "[ui]\nusername = Your Name <your@mail.com>" >> ~/.hgrc
+ # Set the bzr user
+ bzr whoami "Your Name <name@example.com>"
+ # command to run tests
+ nosetests --with-coverage --cover-package=wstool || die
+}