summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger (asterix) <m.mairkeimberger@gmail.com>2017-01-12 19:07:04 +0100
committerDavid Seifert <soap@gentoo.org>2017-01-15 11:25:02 +0100
commitdfb55082bbfd20eef1036e327d3bd9ff56b3b2d4 (patch)
tree9d02f70227c274594c466e10f080166cc2fe10b4
parentnet-wireless/iw: remove unused patch (diff)
downloadgentoo-dfb55082bbfd20eef1036e327d3bd9ff56b3b2d4.tar.gz
gentoo-dfb55082bbfd20eef1036e327d3bd9ff56b3b2d4.tar.bz2
gentoo-dfb55082bbfd20eef1036e327d3bd9ff56b3b2d4.zip
net-wireless/kismet: remove unused patches
Closes: https://github.com/gentoo/gentoo/pull/3447
-rw-r--r--net-wireless/kismet/files/bluechanfix_r3184.patch15
-rw-r--r--net-wireless/kismet/files/header_alignment_r3326.patch58
-rw-r--r--net-wireless/kismet/files/kismet-2011.03.2-cflags-backport.patch115
-rw-r--r--net-wireless/kismet/files/kismet-2016.01.1-tinfo.patch397
-rw-r--r--net-wireless/kismet/files/kismet-console-scrolling-backport.patch12
-rw-r--r--net-wireless/kismet/files/makefile.patch119
-rw-r--r--net-wireless/kismet/files/plugins-ldflags.patch10
-rw-r--r--net-wireless/kismet/files/use-hostname-by-default.patch29
8 files changed, 0 insertions, 755 deletions
diff --git a/net-wireless/kismet/files/bluechanfix_r3184.patch b/net-wireless/kismet/files/bluechanfix_r3184.patch
deleted file mode 100644
index bdc05cb0b51f..000000000000
--- a/net-wireless/kismet/files/bluechanfix_r3184.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-Index: packetsourcetracker.cc
-===================================================================
---- packetsourcetracker.cc (revision 3183)
-+++ packetsourcetracker.cc (working copy)
-@@ -151,7 +151,10 @@
- break;
-
- case SOURCE_channel:
-- osstr << psrc->channel;
-+ if (psrc->strong_source != NULL)
-+ osstr << psrc->strong_source->FetchChannel();
-+ else
-+ osstr << psrc->channel;
- cache->Cache(fnum, osstr.str());
- break;
diff --git a/net-wireless/kismet/files/header_alignment_r3326.patch b/net-wireless/kismet/files/header_alignment_r3326.patch
deleted file mode 100644
index 408456ecafec..000000000000
--- a/net-wireless/kismet/files/header_alignment_r3326.patch
+++ /dev/null
@@ -1,58 +0,0 @@
-diff -Naur kismet-2011-03-R2-orig/packetsource_pcap.cc kismet-2011-03-R2/packetsource_pcap.cc
---- kismet-2011-03-R2-orig/packetsource_pcap.cc 2011-01-05 16:52:51.000000000 -0500
-+++ kismet-2011-03-R2/packetsource_pcap.cc 2012-02-20 22:37:17.973526919 -0500
-@@ -553,6 +553,9 @@
- }
- #endif
-
-+#define ALIGN_OFFSET(offset, width) \
-+ ( (((offset) + ((width) - 1)) & (~((width) - 1))) - offset )
-+
- /*
- * Useful combinations of channel characteristics.
- */
-@@ -617,6 +620,8 @@
- enum ieee80211_radiotap_type bit;
- int bit0;
- const u_char *iter;
-+ const u_char *iter_start;
-+ unsigned int iter_align;
- int fcs_cut = 0; // Is the FCS bit set?
- char errstr[STATUS_MAX];
-
-@@ -658,7 +663,7 @@
-
- eight11chunk->dlt = KDLT_IEEE802_11;
-
-- iter = (u_char*)(last_presentp + 1);
-+ iter_start = iter = (u_char*)(last_presentp + 1);
-
- for (bit0 = 0, presentp = &hdr->it_present; presentp <= last_presentp;
- presentp++, bit0 += 32) {
-@@ -686,6 +691,9 @@
- u.i8 = *iter++;
- break;
- case IEEE80211_RADIOTAP_CHANNEL:
-+ iter_align = ALIGN_OFFSET((unsigned int) (iter - iter_start), 2);
-+ iter += iter_align;
-+
- u.u16 = EXTRACT_LE_16BITS(iter);
- iter += sizeof(u.u16);
- u2.u16 = EXTRACT_LE_16BITS(iter);
-@@ -695,10 +703,16 @@
- case IEEE80211_RADIOTAP_LOCK_QUALITY:
- case IEEE80211_RADIOTAP_TX_ATTENUATION:
- case IEEE80211_RADIOTAP_DB_TX_ATTENUATION:
-+ iter_align = ALIGN_OFFSET((unsigned int) (iter - iter_start), 2);
-+ iter += iter_align;
-+
- u.u16 = EXTRACT_LE_16BITS(iter);
- iter += sizeof(u.u16);
- break;
- case IEEE80211_RADIOTAP_TSFT:
-+ iter_align = ALIGN_OFFSET((unsigned int) (iter - iter_start), 8);
-+ iter += iter_align;
-+
- u.u64 = EXTRACT_LE_64BITS(iter);
- iter += sizeof(u.u64);
- break;
diff --git a/net-wireless/kismet/files/kismet-2011.03.2-cflags-backport.patch b/net-wireless/kismet/files/kismet-2011.03.2-cflags-backport.patch
deleted file mode 100644
index 2ef2a6b59df6..000000000000
--- a/net-wireless/kismet/files/kismet-2011.03.2-cflags-backport.patch
+++ /dev/null
@@ -1,115 +0,0 @@
-diff -Naur kismet-2011-03-R2/plugin-autowep/Makefile kismet-2011-03-R2-cflags/plugin-autowep/Makefile
---- kismet-2011-03-R2/plugin-autowep/Makefile 2012-07-23 12:58:09.961131948 -0400
-+++ kismet-2011-03-R2-cflags/plugin-autowep/Makefile 2012-07-23 13:00:04.544135017 -0400
-@@ -12,6 +12,7 @@
- PLUGINLDFLAGS += -shared -rdynamic
- LIBS += -lstdc++
- CFLAGS += -I/usr/include -I$(KIS_INC_DIR) -g -fPIC
-+CXXFLAGS += -I/usr/include -I$(KIS_INC_DIR) -g -fPIC
-
- PLUGOBJS = autowep-kismet.o
- PLUGOUT = autowep-kismet.so
-@@ -34,9 +35,9 @@
- @-rm -f *.so
-
- .c.o:
-- $(CC) $(CFLAGS) -c $*.c -o $@
-+ $(CC) $(CPPFLAGS) $(CFLAGS) -c $*.c -o $@
-
- .cc.o:
-- $(CXX) $(CFLAGS) -c $*.cc -o $@
-+ $(CXX) $(CPPFLAGS) $(CXXFLAGS) -c $*.cc -o $@
-
- .SUFFIXES: .c .cc .o
-diff -Naur kismet-2011-03-R2/plugin-btscan/Makefile kismet-2011-03-R2-cflags/plugin-btscan/Makefile
---- kismet-2011-03-R2/plugin-btscan/Makefile 2012-07-23 12:58:09.962131948 -0400
-+++ kismet-2011-03-R2-cflags/plugin-btscan/Makefile 2012-07-23 13:02:33.016138993 -0400
-@@ -12,6 +12,7 @@
- PLUGINLDFLAGS += -shared -rdynamic
- LIBS += -lstdc++ -lbluetooth -lpthread -lncurses -lpanel
- CFLAGS += -I/usr/include -I$(KIS_INC_DIR) -g -fPIC
-+CXXFLAGS += -I/usr/include -I$(KIS_INC_DIR) -g -fPIC
-
- SRVOBJS = packetsource_linuxbt.o tracker_btscan.o dumpfile_btscantxt.o kismet_btscan.o
- SRVOUT = btscan.so
-@@ -44,9 +45,9 @@
- @-rm -f *.so
-
- .c.o:
-- $(CC) $(CFLAGS) -c $*.c -o $@
-+ $(CC) $(CPPFLAGS) $(CFLAGS) -c $*.c -o $@
-
- .cc.o:
-- $(CXX) $(CFLAGS) -c $*.cc -o $@
-+ $(CXX) $(CPPFLAGS) $(CXXFLAGS) -c $*.cc -o $@
-
- .SUFFIXES: .c .cc .o
-diff -Naur kismet-2011-03-R2/plugin-dot15d4/Makefile kismet-2011-03-R2-cflags/plugin-dot15d4/Makefile
---- kismet-2011-03-R2/plugin-dot15d4/Makefile 2012-07-23 12:58:09.962131948 -0400
-+++ kismet-2011-03-R2-cflags/plugin-dot15d4/Makefile 2012-07-23 13:03:17.209140176 -0400
-@@ -12,6 +12,7 @@
- PLUGINLDFLAGS += -shared -rdynamic
- LIBS += -lstdc++ -lusb -lpthread
- CFLAGS += -I/usr/include -I$(KIS_INC_DIR) -g -fPIC
-+CXXFLAGS += -I/usr/include -I$(KIS_INC_DIR) -g -fPIC
-
- SRVOBJS = packetsource_raven.o packetsource_serialdev.o \
- packet_dot15d4.o packet_dot15d4_types.o \
-@@ -39,9 +40,9 @@
- @-rm -f *.so
-
- .c.o:
-- $(CC) $(CFLAGS) -c $*.c -o $@
-+ $(CC) $(CPPFLAGS) $(CFLAGS) -c $*.c -o $@
-
- .cc.o:
-- $(CXX) $(CFLAGS) -c $*.cc -o $@
-+ $(CXX) $(CPPFLAGS) $(CXXFLAGS) -c $*.cc -o $@
-
- .SUFFIXES: .c .cc .o
-diff -Naur kismet-2011-03-R2/plugin-ptw/Makefile kismet-2011-03-R2-cflags/plugin-ptw/Makefile
---- kismet-2011-03-R2/plugin-ptw/Makefile 2012-07-23 12:58:09.963131948 -0400
-+++ kismet-2011-03-R2-cflags/plugin-ptw/Makefile 2012-07-23 13:04:25.764142014 -0400
-@@ -12,6 +12,7 @@
- PLUGINLDFLAGS += -shared -rdynamic
- LIBS += -lstdc++ -lssl -lpthread -lcrypto
- CFLAGS += -I/usr/include -I$(KIS_INC_DIR) -g -fPIC
-+CXXFLAGS += -I/usr/include -I$(KIS_INC_DIR) -g -fPIC
-
- PLUGOBJS = aircrack-crypto.o aircrack-ptw2-lib.o aircrack-kismet.o
- PLUGOUT = aircrack-kismet.so
-@@ -34,9 +35,9 @@
- @-rm -f *.so
-
- .c.o:
-- $(CC) $(CFLAGS) -c $*.c -o $@
-+ $(CC) $(CPPFLAGS) $(CFLAGS) -c $*.c -o $@
-
- .cc.o:
-- $(CXX) $(CFLAGS) -c $*.cc -o $@
-+ $(CXX) $(CPPFLAGS) $(CXXFLAGS) -c $*.cc -o $@
-
- .SUFFIXES: .c .cc .o
-diff -Naur kismet-2011-03-R2/plugin-spectools/Makefile kismet-2011-03-R2-cflags/plugin-spectools/Makefile
---- kismet-2011-03-R2/plugin-spectools/Makefile 2012-07-23 12:58:09.963131948 -0400
-+++ kismet-2011-03-R2-cflags/plugin-spectools/Makefile 2012-07-23 13:05:12.121143257 -0400
-@@ -12,6 +12,7 @@
- PLUGINLDFLAGS += -shared -rdynamic
- LIBS += -lstdc++
- CFLAGS += -I/usr/include -I$(KIS_INC_DIR) -g -fPIC
-+CXXFLAGS += -I/usr/include -I$(KIS_INC_DIR) -g -fPIC
-
- CLIOBJS = spectools_ui.o
- CLIOUT = spectools_ui.so
-@@ -44,9 +45,9 @@
- @-rm -f *.so
-
- .c.o:
-- $(CC) $(CFLAGS) -c $*.c -o $@
-+ $(CC) $(CPPFLAGS) $(CFLAGS) -c $*.c -o $@
-
- .cc.o:
-- $(CXX) $(CFLAGS) -c $*.cc -o $@
-+ $(CXX) $(CPPFLAGS) $(CXXFLAGS) -c $*.cc -o $@
-
- .SUFFIXES: .c .cc .o
diff --git a/net-wireless/kismet/files/kismet-2016.01.1-tinfo.patch b/net-wireless/kismet/files/kismet-2016.01.1-tinfo.patch
deleted file mode 100644
index cd09037bb638..000000000000
--- a/net-wireless/kismet/files/kismet-2016.01.1-tinfo.patch
+++ /dev/null
@@ -1,397 +0,0 @@
---- kismet-2016-01-R1/configure.ac
-+++ kismet-2016-01-R1/configure.ac
-@@ -416,48 +416,21 @@
- AC_SUBST(wantclient)
-
- # Add additional cflags since some distros bury panel.h
--CPPFLAGS="$CPPFLAGS -I/usr/include/ncurses"
-
- termcontrol="none";
-
- if test "$wantclient" = "yes"; then
-- OLIBS="$LIBS"
-- AC_CHECK_LIB([ncurses], [initscr],
-- AC_DEFINE(HAVE_LIBNCURSES, 1, NCurses terminal lib) \
-- foundlcurses=yes curseaux="-lncurses" termcontrol="ncurses" )
--
-- if test "$foundlcurses" != "yes"; then
-- AC_CHECK_LIB([curses], [initscr],
-- AC_DEFINE(HAVE_LIBCURSES, 1, Curses terminal lib) \
-- foundlcurses=yes curseaux="-lcurses" termcontrol="curses" )
-- fi
--
-- if test "$foundlcurses" != "yes"; then
-- AC_MSG_ERROR(Failed to find libcurses or libncurses. Install them or disable building the Kismet client with --disable-client. Disabling the client is probably not something you want to do normally.)
-- fi
--
-- if test "$termcontrol" = "ncurses"; then
-- AC_CHECK_HEADER([ncurses.h], [foundhcurses=yes])
-- else
-- AC_CHECK_HEADER([curses.h], [foundhcurses=yes])
-- fi
--
-- if test "$foundhcurses" != "yes"; then
-- AC_MSG_ERROR(Failed to find curses.h or ncurses.h. You probably need to install the curses-devel package from your distribution)
-- fi
--
-- LIBS="$LIBS $curseaux"
-- AC_CHECK_LIB([panel], [new_panel],
-- AC_DEFINE(HAVE_LIBPANEL, 1, Panel terminal lib)
-- curseaux="$curseaux -lpanel",
-- AC_MSG_ERROR(Failed to find libpanel extension to curses/ncurses. Install it, or disable building the Kismet client with --disable-client. Disabling the client is probably not something you want to do normally.))
--
-- AC_CHECK_HEADER([panel.h], [foundhpanel=yes])
-- if test "$foundhpanel" != "yes"; then
-- AC_MSG_ERROR(Failed to find panel.h curses extension header. You probably need to install the curses-devel or panel-devel package from your distribution.)
-- fi
--
-- LIBS="$OLIBS"
-+ PKG_CHECK_MODULES([NCURSES],[ncurses],[AC_DEFINE([HAVE_LIBNCURSES],[1],[Ncurses terminal library])])
-+ foundlcurses=yes
-+ curseaux="${NCURSES_LIBS}"
-+ termcontrol="ncurses"
-+ foundhcurses=yes
-+ CPPFLAGS="$CPPFLAGS ${NCURSES_CFLAGS}"
-+
-+ PKG_CHECK_MODULES([PANEL],[panel],[AC_DEFINE([HAVE_LIBPANEL],[1],[Panel terminal lib])])
-+ curseaux="$curseaux ${PANEL_LIBS}"
-+ foundhpanel=yes
-+ CPPFLAGS="$CPPFLAGS ${PANEL_CFLAGS}"
-
- CLIENTCLIBS="$CLIENTCLIBS $curseaux"
- fi
---- kismet-2016-01-R1/m4/ax_pthread.m4
-+++ kismet-2016-01-R1/m4/ax_pthread.m4
-@@ -0,0 +1,332 @@
-+# ===========================================================================
-+# http://www.gnu.org/software/autoconf-archive/ax_pthread.html
-+# ===========================================================================
-+#
-+# SYNOPSIS
-+#
-+# AX_PTHREAD([ACTION-IF-FOUND[, ACTION-IF-NOT-FOUND]])
-+#
-+# DESCRIPTION
-+#
-+# This macro figures out how to build C programs using POSIX threads. It
-+# sets the PTHREAD_LIBS output variable to the threads library and linker
-+# flags, and the PTHREAD_CFLAGS output variable to any special C compiler
-+# flags that are needed. (The user can also force certain compiler
-+# flags/libs to be tested by setting these environment variables.)
-+#
-+# Also sets PTHREAD_CC to any special C compiler that is needed for
-+# multi-threaded programs (defaults to the value of CC otherwise). (This
-+# is necessary on AIX to use the special cc_r compiler alias.)
-+#
-+# NOTE: You are assumed to not only compile your program with these flags,
-+# but also link it with them as well. e.g. you should link with
-+# $PTHREAD_CC $CFLAGS $PTHREAD_CFLAGS $LDFLAGS ... $PTHREAD_LIBS $LIBS
-+#
-+# If you are only building threads programs, you may wish to use these
-+# variables in your default LIBS, CFLAGS, and CC:
-+#
-+# LIBS="$PTHREAD_LIBS $LIBS"
-+# CFLAGS="$CFLAGS $PTHREAD_CFLAGS"
-+# CC="$PTHREAD_CC"
-+#
-+# In addition, if the PTHREAD_CREATE_JOINABLE thread-attribute constant
-+# has a nonstandard name, defines PTHREAD_CREATE_JOINABLE to that name
-+# (e.g. PTHREAD_CREATE_UNDETACHED on AIX).
-+#
-+# Also HAVE_PTHREAD_PRIO_INHERIT is defined if pthread is found and the
-+# PTHREAD_PRIO_INHERIT symbol is defined when compiling with
-+# PTHREAD_CFLAGS.
-+#
-+# ACTION-IF-FOUND is a list of shell commands to run if a threads library
-+# is found, and ACTION-IF-NOT-FOUND is a list of commands to run it if it
-+# is not found. If ACTION-IF-FOUND is not specified, the default action
-+# will define HAVE_PTHREAD.
-+#
-+# Please let the authors know if this macro fails on any platform, or if
-+# you have any other suggestions or comments. This macro was based on work
-+# by SGJ on autoconf scripts for FFTW (http://www.fftw.org/) (with help
-+# from M. Frigo), as well as ac_pthread and hb_pthread macros posted by
-+# Alejandro Forero Cuervo to the autoconf macro repository. We are also
-+# grateful for the helpful feedback of numerous users.
-+#
-+# Updated for Autoconf 2.68 by Daniel Richard G.
-+#
-+# LICENSE
-+#
-+# Copyright (c) 2008 Steven G. Johnson <stevenj@alum.mit.edu>
-+# Copyright (c) 2011 Daniel Richard G. <skunk@iSKUNK.ORG>
-+#
-+# This program is free software: you can redistribute it and/or modify it
-+# under the terms of the GNU General Public License as published by the
-+# Free Software Foundation, either version 3 of the License, or (at your
-+# option) any later version.
-+#
-+# This program is distributed in the hope that it will be useful, but
-+# WITHOUT ANY WARRANTY; without even the implied warranty of
-+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU General
-+# Public License for more details.
-+#
-+# You should have received a copy of the GNU General Public License along
-+# with this program. If not, see <http://www.gnu.org/licenses/>.
-+#
-+# As a special exception, the respective Autoconf Macro's copyright owner
-+# gives unlimited permission to copy, distribute and modify the configure
-+# scripts that are the output of Autoconf when processing the Macro. You
-+# need not follow the terms of the GNU General Public License when using
-+# or distributing such scripts, even though portions of the text of the
-+# Macro appear in them. The GNU General Public License (GPL) does govern
-+# all other use of the material that constitutes the Autoconf Macro.
-+#
-+# This special exception to the GPL applies to versions of the Autoconf
-+# Macro released by the Autoconf Archive. When you make and distribute a
-+# modified version of the Autoconf Macro, you may extend this special
-+# exception to the GPL to apply to your modified version as well.
-+
-+#serial 21
-+
-+AU_ALIAS([ACX_PTHREAD], [AX_PTHREAD])
-+AC_DEFUN([AX_PTHREAD], [
-+AC_REQUIRE([AC_CANONICAL_HOST])
-+AC_LANG_PUSH([C])
-+ax_pthread_ok=no
-+
-+# We used to check for pthread.h first, but this fails if pthread.h
-+# requires special compiler flags (e.g. on True64 or Sequent).
-+# It gets checked for in the link test anyway.
-+
-+# First of all, check if the user has set any of the PTHREAD_LIBS,
-+# etcetera environment variables, and if threads linking works using
-+# them:
-+if test x"$PTHREAD_LIBS$PTHREAD_CFLAGS" != x; then
-+ save_CFLAGS="$CFLAGS"
-+ CFLAGS="$CFLAGS $PTHREAD_CFLAGS"
-+ save_LIBS="$LIBS"
-+ LIBS="$PTHREAD_LIBS $LIBS"
-+ AC_MSG_CHECKING([for pthread_join in LIBS=$PTHREAD_LIBS with CFLAGS=$PTHREAD_CFLAGS])
-+ AC_TRY_LINK_FUNC([pthread_join], [ax_pthread_ok=yes])
-+ AC_MSG_RESULT([$ax_pthread_ok])
-+ if test x"$ax_pthread_ok" = xno; then
-+ PTHREAD_LIBS=""
-+ PTHREAD_CFLAGS=""
-+ fi
-+ LIBS="$save_LIBS"
-+ CFLAGS="$save_CFLAGS"
-+fi
-+
-+# We must check for the threads library under a number of different
-+# names; the ordering is very important because some systems
-+# (e.g. DEC) have both -lpthread and -lpthreads, where one of the
-+# libraries is broken (non-POSIX).
-+
-+# Create a list of thread flags to try. Items starting with a "-" are
-+# C compiler flags, and other items are library names, except for "none"
-+# which indicates that we try without any flags at all, and "pthread-config"
-+# which is a program returning the flags for the Pth emulation library.
-+
-+ax_pthread_flags="pthreads none -Kthread -kthread lthread -pthread -pthreads -mthreads pthread --thread-safe -mt pthread-config"
-+
-+# The ordering *is* (sometimes) important. Some notes on the
-+# individual items follow:
-+
-+# pthreads: AIX (must check this before -lpthread)
-+# none: in case threads are in libc; should be tried before -Kthread and
-+# other compiler flags to prevent continual compiler warnings
-+# -Kthread: Sequent (threads in libc, but -Kthread needed for pthread.h)
-+# -kthread: FreeBSD kernel threads (preferred to -pthread since SMP-able)
-+# lthread: LinuxThreads port on FreeBSD (also preferred to -pthread)
-+# -pthread: Linux/gcc (kernel threads), BSD/gcc (userland threads)
-+# -pthreads: Solaris/gcc
-+# -mthreads: Mingw32/gcc, Lynx/gcc
-+# -mt: Sun Workshop C (may only link SunOS threads [-lthread], but it
-+# doesn't hurt to check since this sometimes defines pthreads too;
-+# also defines -D_REENTRANT)
-+# ... -mt is also the pthreads flag for HP/aCC
-+# pthread: Linux, etcetera
-+# --thread-safe: KAI C++
-+# pthread-config: use pthread-config program (for GNU Pth library)
-+
-+case ${host_os} in
-+ solaris*)
-+
-+ # On Solaris (at least, for some versions), libc contains stubbed
-+ # (non-functional) versions of the pthreads routines, so link-based
-+ # tests will erroneously succeed. (We need to link with -pthreads/-mt/
-+ # -lpthread.) (The stubs are missing pthread_cleanup_push, or rather
-+ # a function called by this macro, so we could check for that, but
-+ # who knows whether they'll stub that too in a future libc.) So,
-+ # we'll just look for -pthreads and -lpthread first:
-+
-+ ax_pthread_flags="-pthreads pthread -mt -pthread $ax_pthread_flags"
-+ ;;
-+
-+ darwin*)
-+ ax_pthread_flags="-pthread $ax_pthread_flags"
-+ ;;
-+esac
-+
-+# Clang doesn't consider unrecognized options an error unless we specify
-+# -Werror. We throw in some extra Clang-specific options to ensure that
-+# this doesn't happen for GCC, which also accepts -Werror.
-+
-+AC_MSG_CHECKING([if compiler needs -Werror to reject unknown flags])
-+save_CFLAGS="$CFLAGS"
-+ax_pthread_extra_flags="-Werror"
-+CFLAGS="$CFLAGS $ax_pthread_extra_flags -Wunknown-warning-option -Wsizeof-array-argument"
-+AC_COMPILE_IFELSE([AC_LANG_PROGRAM([int foo(void);],[foo()])],
-+ [AC_MSG_RESULT([yes])],
-+ [ax_pthread_extra_flags=
-+ AC_MSG_RESULT([no])])
-+CFLAGS="$save_CFLAGS"
-+
-+if test x"$ax_pthread_ok" = xno; then
-+for flag in $ax_pthread_flags; do
-+
-+ case $flag in
-+ none)
-+ AC_MSG_CHECKING([whether pthreads work without any flags])
-+ ;;
-+
-+ -*)
-+ AC_MSG_CHECKING([whether pthreads work with $flag])
-+ PTHREAD_CFLAGS="$flag"
-+ ;;
-+
-+ pthread-config)
-+ AC_CHECK_PROG([ax_pthread_config], [pthread-config], [yes], [no])
-+ if test x"$ax_pthread_config" = xno; then continue; fi
-+ PTHREAD_CFLAGS="`pthread-config --cflags`"
-+ PTHREAD_LIBS="`pthread-config --ldflags` `pthread-config --libs`"
-+ ;;
-+
-+ *)
-+ AC_MSG_CHECKING([for the pthreads library -l$flag])
-+ PTHREAD_LIBS="-l$flag"
-+ ;;
-+ esac
-+
-+ save_LIBS="$LIBS"
-+ save_CFLAGS="$CFLAGS"
-+ LIBS="$PTHREAD_LIBS $LIBS"
-+ CFLAGS="$CFLAGS $PTHREAD_CFLAGS $ax_pthread_extra_flags"
-+
-+ # Check for various functions. We must include pthread.h,
-+ # since some functions may be macros. (On the Sequent, we
-+ # need a special flag -Kthread to make this header compile.)
-+ # We check for pthread_join because it is in -lpthread on IRIX
-+ # while pthread_create is in libc. We check for pthread_attr_init
-+ # due to DEC craziness with -lpthreads. We check for
-+ # pthread_cleanup_push because it is one of the few pthread
-+ # functions on Solaris that doesn't have a non-functional libc stub.
-+ # We try pthread_create on general principles.
-+ AC_LINK_IFELSE([AC_LANG_PROGRAM([#include <pthread.h>
-+ static void routine(void *a) { a = 0; }
-+ static void *start_routine(void *a) { return a; }],
-+ [pthread_t th; pthread_attr_t attr;
-+ pthread_create(&th, 0, start_routine, 0);
-+ pthread_join(th, 0);
-+ pthread_attr_init(&attr);
-+ pthread_cleanup_push(routine, 0);
-+ pthread_cleanup_pop(0) /* ; */])],
-+ [ax_pthread_ok=yes],
-+ [])
-+
-+ LIBS="$save_LIBS"
-+ CFLAGS="$save_CFLAGS"
-+
-+ AC_MSG_RESULT([$ax_pthread_ok])
-+ if test "x$ax_pthread_ok" = xyes; then
-+ break;
-+ fi
-+
-+ PTHREAD_LIBS=""
-+ PTHREAD_CFLAGS=""
-+done
-+fi
-+
-+# Various other checks:
-+if test "x$ax_pthread_ok" = xyes; then
-+ save_LIBS="$LIBS"
-+ LIBS="$PTHREAD_LIBS $LIBS"
-+ save_CFLAGS="$CFLAGS"
-+ CFLAGS="$CFLAGS $PTHREAD_CFLAGS"
-+
-+ # Detect AIX lossage: JOINABLE attribute is called UNDETACHED.
-+ AC_MSG_CHECKING([for joinable pthread attribute])
-+ attr_name=unknown
-+ for attr in PTHREAD_CREATE_JOINABLE PTHREAD_CREATE_UNDETACHED; do
-+ AC_LINK_IFELSE([AC_LANG_PROGRAM([#include <pthread.h>],
-+ [int attr = $attr; return attr /* ; */])],
-+ [attr_name=$attr; break],
-+ [])
-+ done
-+ AC_MSG_RESULT([$attr_name])
-+ if test "$attr_name" != PTHREAD_CREATE_JOINABLE; then
-+ AC_DEFINE_UNQUOTED([PTHREAD_CREATE_JOINABLE], [$attr_name],
-+ [Define to necessary symbol if this constant
-+ uses a non-standard name on your system.])
-+ fi
-+
-+ AC_MSG_CHECKING([if more special flags are required for pthreads])
-+ flag=no
-+ case ${host_os} in
-+ aix* | freebsd* | darwin*) flag="-D_THREAD_SAFE";;
-+ osf* | hpux*) flag="-D_REENTRANT";;
-+ solaris*)
-+ if test "$GCC" = "yes"; then
-+ flag="-D_REENTRANT"
-+ else
-+ # TODO: What about Clang on Solaris?
-+ flag="-mt -D_REENTRANT"
-+ fi
-+ ;;
-+ esac
-+ AC_MSG_RESULT([$flag])
-+ if test "x$flag" != xno; then
-+ PTHREAD_CFLAGS="$flag $PTHREAD_CFLAGS"
-+ fi
-+
-+ AC_CACHE_CHECK([for PTHREAD_PRIO_INHERIT],
-+ [ax_cv_PTHREAD_PRIO_INHERIT], [
-+ AC_LINK_IFELSE([AC_LANG_PROGRAM([[#include <pthread.h>]],
-+ [[int i = PTHREAD_PRIO_INHERIT;]])],
-+ [ax_cv_PTHREAD_PRIO_INHERIT=yes],
-+ [ax_cv_PTHREAD_PRIO_INHERIT=no])
-+ ])
-+ AS_IF([test "x$ax_cv_PTHREAD_PRIO_INHERIT" = "xyes"],
-+ [AC_DEFINE([HAVE_PTHREAD_PRIO_INHERIT], [1], [Have PTHREAD_PRIO_INHERIT.])])
-+
-+ LIBS="$save_LIBS"
-+ CFLAGS="$save_CFLAGS"
-+
-+ # More AIX lossage: compile with *_r variant
-+ if test "x$GCC" != xyes; then
-+ case $host_os in
-+ aix*)
-+ AS_CASE(["x/$CC"],
-+ [x*/c89|x*/c89_128|x*/c99|x*/c99_128|x*/cc|x*/cc128|x*/xlc|x*/xlc_v6|x*/xlc128|x*/xlc128_v6],
-+ [#handle absolute path differently from PATH based program lookup
-+ AS_CASE(["x$CC"],
-+ [x/*],
-+ [AS_IF([AS_EXECUTABLE_P([${CC}_r])],[PTHREAD_CC="${CC}_r"])],
-+ [AC_CHECK_PROGS([PTHREAD_CC],[${CC}_r],[$CC])])])
-+ ;;
-+ esac
-+ fi
-+fi
-+
-+test -n "$PTHREAD_CC" || PTHREAD_CC="$CC"
-+
-+AC_SUBST([PTHREAD_LIBS])
-+AC_SUBST([PTHREAD_CFLAGS])
-+AC_SUBST([PTHREAD_CC])
-+
-+# Finally, execute ACTION-IF-FOUND/ACTION-IF-NOT-FOUND:
-+if test x"$ax_pthread_ok" = xyes; then
-+ ifelse([$1],,[AC_DEFINE([HAVE_PTHREAD],[1],[Define if you have POSIX threads libraries and header files.])],[$1])
-+ :
-+else
-+ ax_pthread_ok=no
-+ $2
-+fi
-+AC_LANG_POP
-+])dnl AX_PTHREAD
diff --git a/net-wireless/kismet/files/kismet-console-scrolling-backport.patch b/net-wireless/kismet/files/kismet-console-scrolling-backport.patch
deleted file mode 100644
index 01baea0bb735..000000000000
--- a/net-wireless/kismet/files/kismet-console-scrolling-backport.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -Naur kismet-2011-03-R2-orig/kis_panel_windows.cc kismet-2011-03-R2/kis_panel_windows.cc
---- kismet-2011-03-R2-orig/kis_panel_windows.cc 2011-03-02 17:04:05.000000000 -0500
-+++ kismet-2011-03-R2/kis_panel_windows.cc 2012-02-07 11:53:39.634360668 -0500
-@@ -1936,7 +1936,7 @@
-
- // Import the existing console
- constext->SetFollowTail(1);
-- constext->SetMaxText(50);
-+ constext->SetMaxText(250);
- if (kpinterface->FetchServerFramework() == NULL) {
- constext->SetText("Kismet server not started (or not started via this client)");
- textcb = -1;
diff --git a/net-wireless/kismet/files/makefile.patch b/net-wireless/kismet/files/makefile.patch
deleted file mode 100644
index 5580c58346f8..000000000000
--- a/net-wireless/kismet/files/makefile.patch
+++ /dev/null
@@ -1,119 +0,0 @@
-diff -Naur kismet-2011-03-R2-orig/plugin-autowep/Makefile kismet-2011-03-R2/plugin-autowep/Makefile
---- kismet-2011-03-R2-orig/plugin-autowep/Makefile 2009-11-05 21:50:32.000000000 -0500
-+++ kismet-2011-03-R2/plugin-autowep/Makefile 2011-05-31 21:15:06.000000000 -0400
-@@ -1,6 +1,7 @@
- # You will need kismet newcore sources
- KIS_SRC_DIR ?= /usr/src/kismet
- KIS_INC_DIR ?= $(KIS_SRC_DIR)
-+LIBDIR ?= /lib
-
- include $(KIS_SRC_DIR)/Makefile.inc
-
-@@ -21,8 +22,8 @@
- $(LD) $(PLUGINLDFLAGS) $(PLUGOBJS) -o $(PLUGOUT) $(LIBS)
-
- install: $(PLUGOUT)
-- mkdir -p $(DESTDIR)$(prefix)/lib/kismet/
-- install -o $(INSTUSR) -g $(INSTGRP) -m 644 $^ $(DESTDIR)$(prefix)/lib/kismet/$^
-+ mkdir -p $(DESTDIR)$(prefix)/$(LIBDIR)/kismet/
-+ install -o $(INSTUSR) -g $(INSTGRP) -m 644 $^ $(DESTDIR)$(prefix)/$(LIBDIR)/kismet/$^
-
- userinstall: $(PLUGOUT)
- mkdir -p ${HOME}/.kismet/plugins/
-diff -Naur kismet-2011-03-R2-orig/plugin-btscan/Makefile kismet-2011-03-R2/plugin-btscan/Makefile
---- kismet-2011-03-R2-orig/plugin-btscan/Makefile 2010-04-28 15:31:26.000000000 -0400
-+++ kismet-2011-03-R2/plugin-btscan/Makefile 2011-05-31 21:23:55.000000000 -0400
-@@ -1,6 +1,7 @@
- # You will need kismet newcore sources
- KIS_SRC_DIR ?= /usr/src/kismet
- KIS_INC_DIR ?= $(KIS_SRC_DIR)
-+LIBDIR ?= /lib
-
- include $(KIS_SRC_DIR)/Makefile.inc
-
-@@ -27,10 +28,10 @@
- $(LD) $(PLUGINLDFLAGS) $(SRVOBJS) -o $(SRVOUT) $(LIBS)
-
- install: $(SRVOUT) $(CLIOUT)
-- mkdir -p $(DESTDIR)$(prefix)/lib/kismet/
-- install -o $(INSTUSR) -g $(INSTGRP) -m 644 $(SRVOUT) $(DESTDIR)$(prefix)/lib/kismet/$(SRVOUT)
-- mkdir -p $(DESTDIR)$(prefix)/lib/kismet_client/
-- install -o $(INSTUSR) -g $(INSTGRP) -m 644 $(CLIOUT) $(DESTDIR)$(prefix)/lib/kismet_client/$(CLIOUT)
-+ mkdir -p $(DESTDIR)$(prefix)/$(LIBDIR)/kismet/
-+ install -o $(INSTUSR) -g $(INSTGRP) -m 644 $(SRVOUT) $(DESTDIR)$(prefix)/$(LIBDIR)/kismet/$(SRVOUT)
-+ mkdir -p $(DESTDIR)$(prefix)/$(LIBDIR)/kismet_client/
-+ install -o $(INSTUSR) -g $(INSTGRP) -m 644 $(CLIOUT) $(DESTDIR)$(prefix)/$(LIBDIR)/kismet_client/$(CLIOUT)
-
- userinstall: $(SRVOUT) $(CLIOUT)
- mkdir -p ${HOME}/.kismet/plugins/
-diff -Naur kismet-2011-03-R2-orig/plugin-dot15d4/Makefile kismet-2011-03-R2/plugin-dot15d4/Makefile
---- kismet-2011-03-R2-orig/plugin-dot15d4/Makefile 2010-07-29 20:59:16.000000000 -0400
-+++ kismet-2011-03-R2/plugin-dot15d4/Makefile 2011-05-31 21:17:25.000000000 -0400
-@@ -1,6 +1,7 @@
- # You will need kismet newcore sources
- KIS_SRC_DIR ?= /usr/src/kismet
- KIS_INC_DIR ?= $(KIS_SRC_DIR)
-+LIBDIR ?= /lib
-
- include $(KIS_SRC_DIR)/Makefile.inc
-
-@@ -26,8 +27,8 @@
- $(LD) $(PLUGINLDFLAGS) $(SRVOBJS) -o $(SRVOUT) $(LIBS)
-
- install: $(SRVOUT) $(CLIOUT)
-- mkdir -p $(DESTDIR)$(prefix)/lib/kismet/
-- install -o $(INSTUSR) -g $(INSTGRP) -m 644 $(SRVOUT) $(DESTDIR)$(prefix)/lib/kismet/$(SRVOUT)
-+ mkdir -p $(DESTDIR)$(prefix)/$(LIBDIR)/kismet/
-+ install -o $(INSTUSR) -g $(INSTGRP) -m 644 $(SRVOUT) $(DESTDIR)$(prefix)/$(LIBDIR)/kismet/$(SRVOUT)
-
- userinstall: $(SRVOUT) $(CLIOUT)
- mkdir -p ${HOME}/.kismet/plugins/
-diff -Naur kismet-2011-03-R2-orig/plugin-ptw/Makefile kismet-2011-03-R2/plugin-ptw/Makefile
---- kismet-2011-03-R2-orig/plugin-ptw/Makefile 2010-04-28 15:31:26.000000000 -0400
-+++ kismet-2011-03-R2/plugin-ptw/Makefile 2011-05-31 21:18:14.000000000 -0400
-@@ -1,6 +1,7 @@
- # You will need kismet newcore sources
- KIS_SRC_DIR ?= /usr/src/kismet
- KIS_INC_DIR ?= $(KIS_SRC_DIR)
-+LIBDIR ?= /lib
-
- include $(KIS_SRC_DIR)/Makefile.inc
-
-@@ -21,9 +22,8 @@
- $(LD) $(PLUGINLDFLAGS) $(PLUGOBJS) -o $(PLUGOUT) $(LIBS)
-
- install: $(PLUGOUT)
-- mkdir -p $(DESTDIR)$(prefix)/lib/kismet/
--
-- install -o $(INSTUSR) -g $(INSTGRP) -m 644 $^ $(DESTDIR)$(prefix)/lib/kismet/$^
-+ mkdir -p $(DESTDIR)$(prefix)/$(LIBDIR)/kismet/
-+ install -o $(INSTUSR) -g $(INSTGRP) -m 644 $^ $(DESTDIR)$(prefix)/$(LIBDIR)/kismet/$^
-
- userinstall: $(PLUGOUT)
- mkdir -p ${HOME}/.kismet/plugins/
-diff -Naur kismet-2011-03-R2-orig/plugin-spectools/Makefile kismet-2011-03-R2/plugin-spectools/Makefile
---- kismet-2011-03-R2-orig/plugin-spectools/Makefile 2010-01-07 18:33:30.000000000 -0500
-+++ kismet-2011-03-R2/plugin-spectools/Makefile 2011-05-31 21:19:09.000000000 -0400
-@@ -1,6 +1,7 @@
- # You will need kismet newcore sources
- KIS_SRC_DIR ?= /usr/src/kismet
- KIS_INC_DIR ?= $(KIS_SRC_DIR)
-+LIBDIR ?= /lib
-
- include $(KIS_SRC_DIR)/Makefile.inc
-
-@@ -27,10 +28,10 @@
- $(LD) $(PLUGINLDFLAGS) $(SRVOBJS) -o $(SRVOUT) $(LIBS)
-
- install: $(SRVOUT) $(CLIOUT)
-- mkdir -p $(DESTDIR)$(prefix)/lib/kismet/
-- install -o $(INSTUSR) -g $(INSTGRP) -m 644 $(SRVOUT) $(DESTDIR)$(prefix)/lib/kismet/$(SRVOUT)
-- mkdir -p $(DESTDIR)$(prefix)/lib/kismet_client/
-- install -o $(INSTUSR) -g $(INSTGRP) -m 644 $(CLIOUT) $(DESTDIR)$(prefix)/lib/kismet_client/$(CLIOUT)
-+ mkdir -p $(DESTDIR)$(prefix)/$(LIBDIR)/kismet/
-+ install -o $(INSTUSR) -g $(INSTGRP) -m 644 $(SRVOUT) $(DESTDIR)$(prefix)/$(LIBDIR)/kismet/$(SRVOUT)
-+ mkdir -p $(DESTDIR)$(prefix)/$(LIBDIR)/kismet_client/
-+ install -o $(INSTUSR) -g $(INSTGRP) -m 644 $(CLIOUT) $(DESTDIR)$(prefix)/$(LIBDIR)/kismet_client/$(CLIOUT)
-
- userinstall: $(SRVOUT) $(CLIOUT)
- mkdir -p ${HOME}/.kismet/plugins/
diff --git a/net-wireless/kismet/files/plugins-ldflags.patch b/net-wireless/kismet/files/plugins-ldflags.patch
deleted file mode 100644
index 001ab78dab06..000000000000
--- a/net-wireless/kismet/files/plugins-ldflags.patch
+++ /dev/null
@@ -1,10 +0,0 @@
-diff -Naur kismet-2011-03-R2-orig/Makefile.inc.in kismet-2011-03-R2/Makefile.inc.in
---- kismet-2011-03-R2-orig/Makefile.inc.in 2009-11-05 21:43:30.000000000 -0500
-+++ kismet-2011-03-R2/Makefile.inc.in 2011-06-01 00:13:13.000000000 -0400
-@@ -38,5 +38,5 @@
- MAN = ${DESTDIR}@mandir@
- WAV = ${SHARE}/wav/
-
--PLUGINLDFLAGS = @PLUGINLDFLAGS@
-+PLUGINLDFLAGS = @LDFLAGS@ @PLUGINLDFLAGS@
-
diff --git a/net-wireless/kismet/files/use-hostname-by-default.patch b/net-wireless/kismet/files/use-hostname-by-default.patch
deleted file mode 100644
index 0f867da10d27..000000000000
--- a/net-wireless/kismet/files/use-hostname-by-default.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-diff -ruN kismet-2011-03-R2.orig/conf/kismet.conf.in kismet-2011-03-R2/conf/kismet.conf.in
---- kismet-2011-03-R2.orig/conf/kismet.conf.in 2012-05-22 21:33:23.371718460 -0500
-+++ kismet-2011-03-R2/conf/kismet.conf.in 2012-05-22 21:43:08.641691490 -0500
-@@ -7,7 +7,8 @@
- version=2009-newcore
-
- # Name of server (Purely for organizational purposes)
--servername=Kismet_2009
-+# If commented out, defaults to host name of system
-+#servername=Kismet_Server
-
- # Prefix of where we log (as used in the logtemplate later)
- # logprefix=/some/path/to/logs
-diff -ruN kismet-2011-03-R2.orig/kismet_server.cc kismet-2011-03-R2/kismet_server.cc
---- kismet-2011-03-R2.orig/kismet_server.cc 2011-03-03 23:34:42.000000000 -0600
-+++ kismet-2011-03-R2/kismet_server.cc 2012-05-22 21:42:31.319693185 -0500
-@@ -897,7 +897,11 @@
- }
-
- if (conf->FetchOpt("servername") == "") {
-- globalregistry->servername = "Kismet";
-+ char hostname[64];
-+ if (gethostname(hostname, 64) < 0)
-+ globalregistry->servername = "Kismet";
-+ else
-+ globalregistry->servername = string(hostname);
- } else {
- globalregistry->servername = MungeToPrintable(conf->FetchOpt("servername"));
- }