summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2015-10-06 09:35:58 +0000
committerPatrice Clement <monsieurp@gentoo.org>2015-10-06 09:56:44 +0000
commitdff68e10e37810ee5bb0c806c8912f13f3cbd47f (patch)
treebda029a03c50c5a48e457e7bc2b7a4295b47ae74
parentmedia-video/mkvtoolnix: bump to 8.4.0. (diff)
downloadgentoo-dff68e10e37810ee5bb0c806c8912f13f3cbd47f.tar.gz
gentoo-dff68e10e37810ee5bb0c806c8912f13f3cbd47f.tar.bz2
gentoo-dff68e10e37810ee5bb0c806c8912f13f3cbd47f.zip
dev-java/commons-graph: Version bump.
Package-Manager: portage-2.2.18 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
-rw-r--r--dev-java/commons-graph/Manifest1
-rw-r--r--dev-java/commons-graph/commons-graph-0.1.ebuild49
-rw-r--r--dev-java/commons-graph/files/commons-graph-0.1-build.xml258
3 files changed, 308 insertions, 0 deletions
diff --git a/dev-java/commons-graph/Manifest b/dev-java/commons-graph/Manifest
index e8bbd79bd05a..d17ed63ff64e 100644
--- a/dev-java/commons-graph/Manifest
+++ b/dev-java/commons-graph/Manifest
@@ -1 +1,2 @@
+DIST commons-graph-0.1.tar.gz 96009 SHA256 b68f5c7132e9eea4872dfc0d5fd74c138d2489355540dff752a91311cbac040d SHA512 7214fd60eb348a7feee9c194f562e5a7cf1f211ba589d2a85eaae52ed3ced7089842405dfbd99413b1f06f87ea1a19d244989daa1e0f6fb857fa752647d52b16 WHIRLPOOL 90c014761b2a1f8572eba4339f2ea81ec34666a83c21ea27326b366f0089cc5f20a5d6bc53aefa1d09019114b34f424496af95a604c1b55b5bdfec879ab51a0b
DIST graph2-0.8.1.cvs20040118.tar.gz 42653 SHA256 916e3ca83376acd9ca64ee87988c8a19dc86c6468d087ede82d1e05c14a5a142 SHA512 110f2365b9568a4059233c6c6e75aec1a52b4fdd9110d55f0a6b79df324f047bde87d49134d8ba73417223919ddce972dd4a3c86841f843dd0109ebb17177083 WHIRLPOOL e3cd70bc98187a4f581bfa60125cfbfd0490264582d8fe4f536f7ecfd12a2f8228b1ff64db5414f8fa95ea976be5db08a054eecbb86e098cba62cc8cedd6f4c1
diff --git a/dev-java/commons-graph/commons-graph-0.1.ebuild b/dev-java/commons-graph/commons-graph-0.1.ebuild
new file mode 100644
index 000000000000..2d7af9bab4a2
--- /dev/null
+++ b/dev-java/commons-graph/commons-graph-0.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+JAVA_PKG_IUSE="doc source test"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="A toolkit for managing graphs and graph based data structures"
+HOMEPAGE="https://commons.apache.org/sandbox/commons-graph/"
+SRC_URI="http://dev.gentoo.org/~monsieurp/packages/${P}.tar.gz"
+
+DEPEND=">=virtual/jdk-1.6
+ test? (
+ dev-java/ant-junit:0
+ )"
+
+RDEPEND=">=virtual/jre-1.6
+ ${CDEPEND}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+JAVA_ANT_REWRITE_CLASSPATH="yes"
+EANT_TEST_TARGET="test"
+
+# Dubious tests.
+JAVA_RM_FILES=(
+ src/test/java/org/apache/commons/graph/coloring/GraphColoringTestCase.java
+ src/test/java/org/apache/commons/graph/spanning/KruskalTestCase.java
+ src/test/java/org/apache/commons/graph/scc/TarjanTestCase.java
+)
+
+java_prepare() {
+ cp "${FILESDIR}"/"${P}-build.xml" build.xml || die
+}
+
+src_test() {
+ java-pkg-2_src_test
+}
+
+src_install() {
+ java-pkg_newjar target/${P}.jar
+ use doc && java-pkg_dojavadoc target/site/apidocs
+ use source && java-pkg_dosrc src/main/java
+}
diff --git a/dev-java/commons-graph/files/commons-graph-0.1-build.xml b/dev-java/commons-graph/files/commons-graph-0.1-build.xml
new file mode 100644
index 000000000000..5c3a9c19cdd4
--- /dev/null
+++ b/dev-java/commons-graph/files/commons-graph-0.1-build.xml
@@ -0,0 +1,258 @@
+<?xml version="1.0" encoding="UTF-8"?>
+
+<!-- ====================================================================== -->
+<!-- Ant build file (http://ant.apache.org/) for Ant 1.6.2 or above. -->
+<!-- ====================================================================== -->
+
+<!-- ====================================================================== -->
+<!-- ===================== - DO NOT EDIT THIS FILE! - ===================== -->
+<!-- ====================================================================== -->
+<!-- -->
+<!-- Any modifications will be overwritten. -->
+<!-- -->
+<!-- Generated by Maven Ant Plugin on 10/6/15 9:24 AM -->
+<!-- See: http://maven.apache.org/plugins/maven-ant-plugin/ -->
+<!-- -->
+<!-- ====================================================================== -->
+
+<project name="commons-graph-from-maven" default="package" basedir=".">
+
+ <!-- ====================================================================== -->
+ <!-- Build environment properties -->
+ <!-- ====================================================================== -->
+
+ <property file="${user.home}/.m2/maven.properties"/>
+ <property file="maven-build.properties"/>
+
+ <property name="maven.build.finalName" value="commons-graph-0.1"/>
+ <property name="maven.build.dir" value="target"/>
+ <property name="maven.build.outputDir" value="${maven.build.dir}/classes"/>
+ <property name="maven.build.srcDir.0" value="src/main/java"/>
+ <property name="maven.build.resourceDir.0" value="."/>
+ <property name="maven.build.testOutputDir" value="${maven.build.dir}/test-classes"/>
+ <property name="maven.build.testDir.0" value="src/test/java"/>
+ <property name="maven.build.testResourceDir.0" value="src/test/resources"/>
+ <property name="maven.build.testResourceDir.1" value="."/>
+ <property name="maven.test.reports" value="${maven.build.dir}/test-reports"/>
+ <property name="maven.reporting.outputDirectory" value="${maven.build.dir}/site"/>
+
+ <property name="maven.repo.local" value="${user.home}/.m2/repository"/>
+ <property name="maven.settings.offline" value="false"/>
+ <property name="maven.settings.interactiveMode" value="true"/>
+
+ <!-- ====================================================================== -->
+ <!-- Defining classpaths -->
+ <!-- ====================================================================== -->
+
+ <path id="build.classpath"/>
+ <path id="build.test.classpath">
+ <pathelement location="${maven.repo.local}/junit/junit/4.10/junit-4.10.jar"/>
+ <pathelement location="${maven.repo.local}/org/hamcrest/hamcrest-core/1.1/hamcrest-core-1.1.jar"/>
+ <pathelement location="${maven.repo.local}/com/carrotsearch/junit-benchmarks/0.3.0/junit-benchmarks-0.3.0-jdk15.jar"/>
+ <pathelement location="${maven.repo.local}/org/slf4j/slf4j-api/1.6.1/slf4j-api-1.6.1.jar"/>
+ <pathelement location="${maven.repo.local}/com/h2database/h2/1.3.158/h2-1.3.158.jar"/>
+ </path>
+
+ <!-- ====================================================================== -->
+ <!-- Cleaning up target -->
+ <!-- ====================================================================== -->
+
+ <target name="clean" description="Clean the output directory">
+ <delete dir="${maven.build.dir}"/>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Compilation target -->
+ <!-- ====================================================================== -->
+
+ <target name="compile" description="Compile the code">
+ <mkdir dir="${maven.build.outputDir}"/>
+ <javac destdir="${maven.build.outputDir}"
+ encoding="iso-8859-1"
+ nowarn="false"
+ debug="true"
+ optimize="false"
+ deprecation="true"
+ target="1.6"
+ verbose="false"
+ fork="false"
+ source="1.6">
+ <src>
+ <pathelement location="${maven.build.srcDir.0}"/>
+ </src>
+ <classpath refid="build.classpath"/>
+ </javac>
+ <mkdir dir="${maven.build.outputDir}/META-INF"/>
+ <copy todir="${maven.build.outputDir}/META-INF">
+ <fileset dir="${maven.build.resourceDir.0}">
+ <include name="NOTICE.txt"/>
+ <include name="LICENSE.txt"/>
+ </fileset>
+ </copy>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Test-compilation target -->
+ <!-- ====================================================================== -->
+
+ <target name="compile-tests"
+ depends="compile"
+ description="Compile the test code"
+ unless="maven.test.skip">
+ <mkdir dir="${maven.build.testOutputDir}"/>
+ <javac destdir="${maven.build.testOutputDir}"
+ encoding="iso-8859-1"
+ nowarn="false"
+ debug="true"
+ optimize="false"
+ deprecation="true"
+ target="1.6"
+ verbose="false"
+ fork="false"
+ source="1.6">
+ <src>
+ <pathelement location="${maven.build.testDir.0}"/>
+ </src>
+ <classpath>
+ <path refid="build.test.classpath"/>
+ <pathelement location="${maven.build.outputDir}"/>
+ </classpath>
+ </javac>
+ <mkdir dir="${maven.build.testOutputDir}/META-INF"/>
+ <copy todir="${maven.build.testOutputDir}/META-INF">
+ <fileset dir="${maven.build.testResourceDir.1}">
+ <include name="NOTICE.txt"/>
+ <include name="LICENSE.txt"/>
+ </fileset>
+ </copy>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Run all tests -->
+ <!-- ====================================================================== -->
+
+ <target name="test"
+ depends="compile-tests, junit-missing"
+ unless="junit.skipped"
+ description="Run the test cases">
+ <mkdir dir="${maven.test.reports}"/>
+ <junit printSummary="yes" haltonerror="true" haltonfailure="true" fork="true" dir=".">
+ <sysproperty key="basedir" value="."/>
+ <formatter type="xml"/>
+ <formatter type="plain" usefile="false"/>
+ <classpath>
+ <path refid="build.test.classpath"/>
+ <pathelement location="${maven.build.outputDir}"/>
+ <pathelement location="${maven.build.testOutputDir}"/>
+ </classpath>
+ <batchtest todir="${maven.test.reports}" unless="test">
+ <fileset dir="${maven.build.testDir.0}">
+ <include name="**/Test*.java"/>
+ <include name="**/*Test.java"/>
+ <include name="**/*TestCase.java"/>
+ <exclude name="**/*Abstract*Test.java"/>
+ <exclude name="**/TestRunner.java"/>
+ </fileset>
+ </batchtest>
+ <batchtest todir="${maven.test.reports}" if="test">
+ <fileset dir="${maven.build.testDir.0}">
+ <include name="**/${test}.java"/>
+ <exclude name="**/*Abstract*Test.java"/>
+ </fileset>
+ </batchtest>
+ </junit>
+ </target>
+
+ <target name="test-junit-present">
+ <available classname="junit.framework.Test" property="junit.present" classpathref="build.test.classpath"/>
+ </target>
+
+ <target name="test-junit-status"
+ depends="test-junit-present">
+ <condition property="junit.missing">
+ <and>
+ <isfalse value="${junit.present}"/>
+ <isfalse value="${maven.test.skip}"/>
+ </and>
+ </condition>
+ <condition property="junit.skipped">
+ <or>
+ <isfalse value="${junit.present}"/>
+ <istrue value="${maven.test.skip}"/>
+ </or>
+ </condition>
+ </target>
+
+ <target name="junit-missing"
+ depends="test-junit-status"
+ if="junit.missing">
+ <echo>=================================== WARNING ===================================</echo>
+ <echo> JUnit is not present in the test classpath or your $ANT_HOME/lib directory. Tests not executed.</echo>
+ <echo>===============================================================================</echo>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Javadoc target -->
+ <!-- ====================================================================== -->
+
+ <target name="javadoc" description="Generates the Javadoc of the application">
+ <javadoc sourcepath="${maven.build.srcDir.0}"
+ packagenames="*"
+ destdir="${maven.reporting.outputDirectory}/apidocs"
+ access="protected"
+ old="false"
+ verbose="false"
+ encoding="iso-8859-1"
+ version="true"
+ use="true"
+ author="true"
+ splitindex="false"
+ nodeprecated="false"
+ nodeprecatedlist="false"
+ notree="false"
+ noindex="false"
+ nohelp="false"
+ nonavbar="false"
+ serialwarn="false"
+ charset="ISO-8859-1"
+ source="1.6"
+ linksource="true"
+ breakiterator="false">
+ <link href="http://download.oracle.com/javase/6/docs/api/"/>
+ <link href="http://download.oracle.com/javaee/6/api/"/>
+ </javadoc>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Package target -->
+ <!-- ====================================================================== -->
+
+ <target name="package" depends="compile,test" description="Package the application">
+ <jar jarfile="${maven.build.dir}/${maven.build.finalName}.jar"
+ compress="true"
+ index="false"
+ basedir="${maven.build.outputDir}"
+ excludes="**/package.html">
+ <manifest>
+ <attribute name="Main-Class" value="Main"/>
+ </manifest>
+ </jar>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- A dummy target for the package named after the type it creates -->
+ <!-- ====================================================================== -->
+
+ <target name="jar" depends="package" description="Builds the jar for the application"/>
+
+ <!-- ====================================================================== -->
+ <!-- Download dependencies target -->
+ <!-- ====================================================================== -->
+
+ <target name="test-offline">
+ <condition property="maven.mode.offline">
+ <equals arg1="${maven.settings.offline}" arg2="true"/>
+ </condition>
+ </target>
+
+</project>