summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-08-02 18:58:56 +0000
committerSam James <sam@gentoo.org>2020-08-02 18:58:56 +0000
commite25cfee90b8696e6dfedf93dc9ca7da5e1eb6ea4 (patch)
treee6517b88f6133f430c192a93c108e5760012ed5b
parentdev-python/enzyme: add Python 3.9 (diff)
downloadgentoo-e25cfee90b8696e6dfedf93dc9ca7da5e1eb6ea4.tar.gz
gentoo-e25cfee90b8696e6dfedf93dc9ca7da5e1eb6ea4.tar.bz2
gentoo-e25cfee90b8696e6dfedf93dc9ca7da5e1eb6ea4.zip
dev-python/dogpile-cache: add Python 3.9
Acked-by: Matthew Thode <prometheanfire@gentoo.org> Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-python/dogpile-cache/dogpile-cache-0.9.1.ebuild11
1 files changed, 4 insertions, 7 deletions
diff --git a/dev-python/dogpile-cache/dogpile-cache-0.9.1.ebuild b/dev-python/dogpile-cache/dogpile-cache-0.9.1.ebuild
index f4834cc71ca1..a4f70aebb554 100644
--- a/dev-python/dogpile-cache/dogpile-cache-0.9.1.ebuild
+++ b/dev-python/dogpile-cache/dogpile-cache-0.9.1.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python{3_6,3_7,3_8} )
+PYTHON_COMPAT=( python{3_6,3_7,3_8,3_9} )
inherit distutils-r1
@@ -14,17 +14,14 @@ S="${WORKDIR}/dogpile.cache-${PV}"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="amd64 ~arm arm64 x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
RDEPEND=""
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+BDEPEND="
>=dev-python/decorator-4.0.0[${PYTHON_USEDEP}]
test? (
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-cov[${PYTHON_USEDEP}]
dev-python/mock[${PYTHON_USEDEP}]
dev-python/mako[${PYTHON_USEDEP}]
- )"
+ )
+"
distutils_enable_tests pytest