summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2016-01-02 12:16:23 +0000
committerPatrice Clement <monsieurp@gentoo.org>2016-01-02 13:08:33 +0000
commite289dce531b130bf45d889e1bcf0d03f42311eef (patch)
tree81ecda140adaf507c7ed94304a835b464e9c150d
parentdev-python/rencode: DEPEND on cython (thanks Toralf Förster, bug 569004). (diff)
parentnet-misc/sx: version bump to 2.0 (diff)
downloadgentoo-e289dce531b130bf45d889e1bcf0d03f42311eef.tar.gz
gentoo-e289dce531b130bf45d889e1bcf0d03f42311eef.tar.bz2
gentoo-e289dce531b130bf45d889e1bcf0d03f42311eef.zip
Merge remote-tracking branch 'github/pr/592'.
-rw-r--r--net-misc/sx/Manifest1
-rw-r--r--net-misc/sx/sx-2.0.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/net-misc/sx/Manifest b/net-misc/sx/Manifest
index cac19f7f39b6..0ae31eea7af2 100644
--- a/net-misc/sx/Manifest
+++ b/net-misc/sx/Manifest
@@ -1 +1,2 @@
DIST sx-1.2.tar.gz 7218016 SHA256 98c37a84e1653364226aff47e63b715500636c0af3b20f4e74eefe3397ee2d63 SHA512 b1366cd7968b678a877d163e4183d7dbdc1b1d0a90fd1a8bc9e795cbbeb75677e6f15da7f770c77e61cf97ed20c27acc5ab1d17d25cd1c5f1f40271ced42b41a WHIRLPOOL 4dbb5453b4123bfe5380e604ad2782e66642b442e2e2b2609d847de4e06a1bb543231273f55c4605f9562c3936f8c91a150851182fbed3150c92402c44ad16c5
+DIST sx-2.0.tar.gz 7641676 SHA256 649ab7ccc1e2fc94aa79169a55bc99bc2b72da50dad82419d7f3c1ee4ef884aa SHA512 7de59d6c794d11a88f2ee87daf04cd2987cbbac2797536d9b62eaa38b5fd7d1dc1a7794ae12155b4df7096fd484b74faec066e8cd47da0a73595b57c8831dbaf WHIRLPOOL 0a07e5adf109a0ba1d9e9cbc741cc950c3567bbd3c7d0f48006c458c1b299c5560e9d84d284e2786325977db1477aeff609258e6f4bffb3a5fc7b4b1b4907075
diff --git a/net-misc/sx/sx-2.0.ebuild b/net-misc/sx/sx-2.0.ebuild
new file mode 100644
index 000000000000..f24f7a7a7e2f
--- /dev/null
+++ b/net-misc/sx/sx-2.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Skylable SX - a distributed object-storage software for data clusters"
+HOMEPAGE="http://www.skylable.com/products/sx"
+SRC_URI="http://cdn.skylable.com/source/${P}.tar.gz"
+LICENSE="GPL-2 LGPL-2.1"
+# If a package appears that links against another .so apart from sxclient-2.0.0.so, change the subslot accordingly.
+SLOT="0/2"
+KEYWORDS="~amd64"
+IUSE="+client ipv6 +server ssl"
+nginx_modules_use="nginx_modules_http_fastcgi(-),nginx_modules_http_gzip(-),nginx_modules_http_proxy(-),nginx_modules_http_scgi(-),nginx_modules_http_uwsgi(-)"
+DEPEND="
+ dev-libs/libltdl:0
+ dev-libs/yajl
+ net-misc/curl[idn,ipv6(-)?,ssh,ssl(-)?]
+ server? ( >=dev-db/sqlite-3.8.4.3:3
+ dev-libs/fcgi
+ www-servers/nginx:mainline[http,ipv6(-)?,${nginx_modules_use},ssl(-)?] )
+"
+RDEPEND="${DEPEND}"
+
+# The server build depends on tools only built during client build.
+# The client, though, is fully functional without server components
+# (for remote access, for example).
+# Deactivate both only if you know you need *only* the libs.
+REQUIRED_USE="server? ( client )"
+
+# tests make a temporary install relative to $prefix, so docdir must be relative to it as well
+src_configure() {
+ econf --disable-sxhttpd \
+ --with-system-libs \
+ --docdir="\${prefix}/usr/share/doc/${PF}" \
+ $(use_enable client sxclient) \
+ $(use_enable server)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ prune_libtool_files --all
+}